summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-11-02 18:49:36 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-11-02 18:49:36 +0000
commit4384cb7c6181795ad7b7ccde991fe82a753354bd (patch)
tree98ddb1fc867fab8183b814a31ece13af00b49e47 /dev-lang/parrot
parentia64/s390/sh/sparc stable wrt #288572 (diff)
downloadgentoo-2-4384cb7c6181795ad7b7ccde991fe82a753354bd.tar.gz
gentoo-2-4384cb7c6181795ad7b7ccde991fe82a753354bd.tar.bz2
gentoo-2-4384cb7c6181795ad7b7ccde991fe82a753354bd.zip
Bump to 1.7.0
(Portage version: 2.2_rc48/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/parrot')
-rw-r--r--dev-lang/parrot/ChangeLog7
-rw-r--r--dev-lang/parrot/parrot-1.7.0.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-lang/parrot/ChangeLog b/dev-lang/parrot/ChangeLog
index eba31239c584..e2280baf5b8b 100644
--- a/dev-lang/parrot/ChangeLog
+++ b/dev-lang/parrot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/parrot
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/ChangeLog,v 1.26 2009/08/16 10:25:23 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/ChangeLog,v 1.27 2009/11/02 18:49:36 patrick Exp $
+
+*parrot-1.7.0 (02 Nov 2009)
+
+ 02 Nov 2009; Patrick Lauer <patrick@gentoo.org> +parrot-1.7.0.ebuild:
+ Bump to 1.7.0
16 Aug 2009; Torsten Veller <tove@gentoo.org>
-files/parrot-0.4.5-pod-test.patch, -files/mod_parrot.patch,
diff --git a/dev-lang/parrot/parrot-1.7.0.ebuild b/dev-lang/parrot/parrot-1.7.0.ebuild
new file mode 100644
index 000000000000..17755e2b1750
--- /dev/null
+++ b/dev-lang/parrot/parrot-1.7.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-1.7.0.ebuild,v 1.1 2009/11/02 18:49:36 patrick Exp $
+
+EAPI=2
+
+inherit eutils multilib
+
+DESCRIPTION="Parrot is a virtual machine designed to efficiently compile and execute bytecode for dynamic languages"
+HOMEPAGE="http://www.parrot.org/"
+SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/devel/${PV}/${P}.tar.gz"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="opengl nls doc examples gdbm gmp ssl unicode pcre"
+
+RDEPEND="opengl? ( virtual/glut )
+ nls? ( sys-devel/gettext )
+ unicode? ( >=dev-libs/icu-2.6 )
+ gdbm? ( >=sys-libs/gdbm-1.8.3-r1 )
+ gmp? ( >=dev-libs/gmp-4.1.4 )
+ ssl? ( dev-libs/openssl )
+ pcre? ( dev-libs/libpcre )"
+
+DEPEND="dev-lang/perl[doc?]
+ ${RDEPEND}"
+
+src_prepare() {
+ sed -e "s:/lib/:/$(get_libdir)/:" -i "${S}/tools/dev/install_files.pl"
+}
+
+src_configure() {
+ myconf=""
+ use unicode || myconf="$myconf --without-icu"
+ use ssl || myconf="$myconf --without-crypto"
+ use gdbm || myconf="$myconf --without-gdbm"
+ use nls || myconf="$myconf --without-gettext"
+ use gmp || myconf="$myconf --without-gmp"
+ use opengl || myconf="$myconf --without-opengl"
+ use pcre || myconf="$myconf --without-pcre"
+
+ perl Configure.pl --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ --sysconfdir=/etc \
+ --sharedstatedir=/var/lib/parrot \
+ $myconf
+}
+
+src_compile() {
+ emake || die
+ use doc && make html
+}
+
+src_install() {
+ emake -j1 install-dev DESTDIR="${D}" DOC_DIR="/usr/share/doc/${P}" || die
+}