summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-09-03 08:56:34 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-09-03 08:56:34 +0000
commit272ad360e52ea7f1bc3faa309601c64ad8108a6a (patch)
treee0f4761876dea1567ccb939c505e5601fadfa696 /dev-lang/parrot
parentStable for alpha, wrt bug #480392 (diff)
downloadgentoo-2-272ad360e52ea7f1bc3faa309601c64ad8108a6a.tar.gz
gentoo-2-272ad360e52ea7f1bc3faa309601c64ad8108a6a.tar.bz2
gentoo-2-272ad360e52ea7f1bc3faa309601c64ad8108a6a.zip
Fix for #454058, at last
(Portage version: 2.2.1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-lang/parrot')
-rw-r--r--dev-lang/parrot/ChangeLog6
-rw-r--r--dev-lang/parrot/files/perldoc.patch33
-rw-r--r--dev-lang/parrot/parrot-5.6.0.ebuild4
3 files changed, 41 insertions, 2 deletions
diff --git a/dev-lang/parrot/ChangeLog b/dev-lang/parrot/ChangeLog
index e9ae41360527..b3bf598ccb53 100644
--- a/dev-lang/parrot/ChangeLog
+++ b/dev-lang/parrot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/parrot
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/ChangeLog,v 1.69 2013/08/01 04:25:43 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/ChangeLog,v 1.70 2013/09/03 08:56:34 patrick Exp $
+
+ 03 Sep 2013; Patrick Lauer <patrick@gentoo.org> +files/perldoc.patch,
+ parrot-5.6.0.ebuild:
+ Fix for #454058, at last
01 Aug 2013; Patrick Lauer <patrick@gentoo.org> -parrot-4.10.0.ebuild,
-parrot-4.11.0.ebuild, -parrot-5.0.0.ebuild, -parrot-5.1.0.ebuild,
diff --git a/dev-lang/parrot/files/perldoc.patch b/dev-lang/parrot/files/perldoc.patch
new file mode 100644
index 000000000000..710148949435
--- /dev/null
+++ b/dev-lang/parrot/files/perldoc.patch
@@ -0,0 +1,33 @@
+diff -Naur parrot-5.5.0/config/auto/perldoc.pm parrot-5.5.0/config/auto/perldoc.pm
+--- parrot-5.5.0/config/auto/perldoc.pm 2013-04-30 19:11:28.000000000 +0000
++++ parrot-5.5.0/config/auto/perldoc.pm 2013-06-26 15:44:31.031675583 +0000
+@@ -38,7 +38,7 @@
+
+ my $cmd = File::Spec->catfile($conf->data->get('scriptdirexp_provisional'), q{perldoc});
+ my ( $fh, $filename ) = tempfile( UNLINK => 1 );
+- my $content = capture_output("$cmd -ud $filename perldoc") || undef;
++ my $content = capture_output("$cmd -u perldoc > $filename") || undef;
+
+ return 1 unless defined( $self->_initial_content_check($conf, $content) );
+
+@@ -67,7 +67,7 @@
+ if ( $new_perldoc ) {
+ $TEMP_pod_build .= <<"END";
+ ops/$pod: ../src/ops/$ops
+-\t\$(PERLDOC) -ud ops/$pod ../src/ops/$ops
++\t\$(PERLDOC) -u ../src/ops/$ops > ops/$pod
+ \t\$(CHMOD) 0644 ops/$pod
+ \t\$(ADDGENERATED) "docs/\$\@" "[doc]"
+
+diff -Naur parrot-5.5.0/config/gen/makefiles/docs.in parrot-5.5.0/config/gen/makefiles/docs.in
+--- parrot-5.5.0/config/gen/makefiles/docs.in 2013-06-15 17:36:41.000000000 +0000
++++ parrot-5.5.0/config/gen/makefiles/docs.in 2013-06-26 15:39:41.109881123 +0000
+@@ -63,7 +63,7 @@
+ $(TOUCH) doc-prep
+
+ packfile-c.pod: ../src/packfile/api.c
+-#IF(new_perldoc): $(PERLDOC) -ud packfile-c.pod ../src/packfile/api.c
++#IF(new_perldoc): $(PERLDOC) -u ../src/packfile/api.c > packfile-c.pod
+ #ELSE: $(PERLDOC) -u ../src/packfile/api.c > packfile-c.pod
+ $(ADDGENERATED) "docs/$@" "[doc]"
+
diff --git a/dev-lang/parrot/parrot-5.6.0.ebuild b/dev-lang/parrot/parrot-5.6.0.ebuild
index 1b0070ff26b6..30a2abb8442a 100644
--- a/dev-lang/parrot/parrot-5.6.0.ebuild
+++ b/dev-lang/parrot/parrot-5.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-5.6.0.ebuild,v 1.1 2013/07/18 07:49:11 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-5.6.0.ebuild,v 1.2 2013/09/03 08:56:34 patrick Exp $
EAPI=3
@@ -30,6 +30,8 @@ DEPEND="dev-lang/perl[doc?]
src_prepare() {
# Fix for #404195 - pcre detection is wonky
sed -i 's:libpcre.so.0:libpcre.so.1:' runtime/parrot/library/pcre.pir || die "Couldn't fix pcre location"
+ # Fix perldoc sandbox madness
+ epatch "${FILESDIR}/perldoc.patch" || die
}
src_configure() {