summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Plank <alexander@gentoo.org>2004-07-26 14:26:44 +0000
committerAlexander Plank <alexander@gentoo.org>2004-07-26 14:26:44 +0000
commite571ea33cd0661b569cc1dab900d97fbde5605ee (patch)
tree577cf6a2ccce35e30ef17c357560af84f2f409ad /dev-lang/ocaml
parentInitial revision (Manifest recommit) (diff)
downloadgentoo-2-e571ea33cd0661b569cc1dab900d97fbde5605ee.tar.gz
gentoo-2-e571ea33cd0661b569cc1dab900d97fbde5605ee.tar.bz2
gentoo-2-e571ea33cd0661b569cc1dab900d97fbde5605ee.zip
add ranlib stuff, change to macos (tested with unison)
Diffstat (limited to 'dev-lang/ocaml')
-rw-r--r--dev-lang/ocaml/ChangeLog6
-rw-r--r--dev-lang/ocaml/ocaml-3.07-r1.ebuild20
2 files changed, 23 insertions, 3 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index ebd34e437b18..2625561dad15 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ocaml
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.37 2004/07/26 02:06:40 alexander Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.38 2004/07/26 14:26:44 alexander Exp $
+
+ 26 Jun 2004; Alexander Plank <alexander@gentoo.org> ocaml-3.07-r1.ebuild
+ add ranlib bit to ebuild and rekeyword macos (i tested it with unison) (thanks
+Philippe Bouamriou for bug #57917 ))
25 Jun 2004; Alexander Plank <alexander@gentoo.org> ocaml-3.07-r1.ebuild
~macos keyword (unison fails and cites ocaml problems)
diff --git a/dev-lang/ocaml/ocaml-3.07-r1.ebuild b/dev-lang/ocaml/ocaml-3.07-r1.ebuild
index 71a82b4e0c92..f6de9c0a93b5 100644
--- a/dev-lang/ocaml/ocaml-3.07-r1.ebuild
+++ b/dev-lang/ocaml/ocaml-3.07-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07-r1.ebuild,v 1.17 2004/07/26 02:06:40 alexander Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07-r1.ebuild,v 1.18 2004/07/26 14:26:44 alexander Exp $
inherit flag-o-matic eutils
@@ -12,7 +12,7 @@ SRC_URI="http://caml.inria.fr/distrib/${P}/${P}.tar.gz
LICENSE="QPL-1.0 LGPL-2"
SLOT="0"
-KEYWORDS="x86 ~sparc ~ppc alpha ~ia64 ~amd64 hppa ~macos"
+KEYWORDS="x86 ~sparc ~ppc alpha ~ia64 ~amd64 hppa macos"
IUSE="tcltk"
DEPEND="virtual/libc
@@ -65,6 +65,22 @@ src_install() {
}
pkg_postinst() {
+ ranlib /usr/lib/ocaml/libasmrunp.a
+ ranlib /usr/lib/ocaml/libbigarray.a
+ ranlib /usr/lib/ocaml/libcamlrun.a
+ ranlib /usr/lib/ocaml/libgraphics.a
+ ranlib /usr/lib/ocaml/libmldbm.a
+ ranlib /usr/lib/ocaml/libnums.a
+ ranlib /usr/lib/ocaml/libstr.a
+ ranlib /usr/lib/ocaml/libthreads.a
+ ranlib /usr/lib/ocaml/libthreadsnat.a
+ ranlib /usr/lib/ocaml/libunix.a
+ ranlib /usr/lib/ocaml/libstr.a
+ ranlib /usr/lib/ocaml/str.a
+ ranlib /usr/lib/ocaml/unix.a
+ ranlib /usr/lib/ocaml/stdlib.a
+ ranlib /usr/lib/ocaml/libasmrun.a
+
echo
einfo "OCaml is not binary compatible from version to version,"
einfo "so you (may) need to rebuild all packages depending on it that"