summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-12-20 19:45:17 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-12-20 19:45:17 +0000
commit92e9bd05020df5eb00c40b18043127273811105c (patch)
treebbfe9fd726c1825f59f6ea814f9f8d3926a4efd5 /dev-lang/ocaml
parentVersion bump (diff)
downloadgentoo-2-92e9bd05020df5eb00c40b18043127273811105c.tar.gz
gentoo-2-92e9bd05020df5eb00c40b18043127273811105c.tar.bz2
gentoo-2-92e9bd05020df5eb00c40b18043127273811105c.zip
Add ocaml 3.10.1 release candidate 1, for testing purposes
(Portage version: 2.1.4_rc10)
Diffstat (limited to 'dev-lang/ocaml')
-rw-r--r--dev-lang/ocaml/ChangeLog8
-rw-r--r--dev-lang/ocaml/files/digest-ocaml-3.10.1_rc13
-rw-r--r--dev-lang/ocaml/ocaml-3.10.1_rc1.ebuild135
3 files changed, 145 insertions, 1 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index 9f4aa06dd5ed..e9203208eef9 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/ocaml
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.128 2007/12/19 16:58:08 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.129 2007/12/20 19:45:17 aballier Exp $
+
+*ocaml-3.10.1_rc1 (20 Dec 2007)
+
+ 20 Dec 2007; Alexis Ballier <aballier@gentoo.org>
+ +ocaml-3.10.1_rc1.ebuild:
+ Add ocaml 3.10.1 release candidate 1, for testing purposes
19 Dec 2007; Alexis Ballier <aballier@gentoo.org> ocaml-3.10.0.ebuild:
make the information about the need to run ocaml-rebuild.sh a warning
diff --git a/dev-lang/ocaml/files/digest-ocaml-3.10.1_rc1 b/dev-lang/ocaml/files/digest-ocaml-3.10.1_rc1
new file mode 100644
index 000000000000..3e6cf66702c8
--- /dev/null
+++ b/dev-lang/ocaml/files/digest-ocaml-3.10.1_rc1
@@ -0,0 +1,3 @@
+MD5 00563ca3d5dbb7a28628d3716b36e63f ocaml-3.10.1+rc1.tar.gz 2783125
+RMD160 6a17ef19111cd954eb74d1f87895553d9e096347 ocaml-3.10.1+rc1.tar.gz 2783125
+SHA256 6e827f93790981e21d8deea30dbe66357c51e6684d9cb2c5e2a4c730aec7073e ocaml-3.10.1+rc1.tar.gz 2783125
diff --git a/dev-lang/ocaml/ocaml-3.10.1_rc1.ebuild b/dev-lang/ocaml/ocaml-3.10.1_rc1.ebuild
new file mode 100644
index 000000000000..bbf2354c5cf2
--- /dev/null
+++ b/dev-lang/ocaml/ocaml-3.10.1_rc1.ebuild
@@ -0,0 +1,135 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.10.1_rc1.ebuild,v 1.1 2007/12/20 19:45:17 aballier Exp $
+
+inherit flag-o-matic eutils multilib versionator toolchain-funcs
+
+MY_P="${P/_rc/+rc}"
+DESCRIPTION="fast modern type-inferring functional programming language descended from the ML (Meta Language) family"
+HOMEPAGE="http://www.ocaml.org/"
+SRC_URI="http://caml.inria.fr/distrib/ocaml-$( get_version_component_range 1-2)/${MY_P}.tar.gz"
+
+LICENSE="QPL-1.0 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="emacs gdbm latex ncurses tk X xemacs"
+
+DEPEND="tk? ( >=dev-lang/tk-3.3.3 )
+ ncurses? ( sys-libs/ncurses )
+ X? ( x11-libs/libX11 x11-proto/xproto )
+ gdbm? ( sys-libs/gdbm )"
+
+PDEPEND="emacs? ( app-emacs/ocaml-mode )
+ xemacs? ( app-xemacs/ocaml )"
+
+S="${WORKDIR}/${MY_P}"
+pkg_setup() {
+ # dev-lang/ocaml creates its own objects but calls gcc for linking, which will
+ # results in relocations if gcc wants to create a PIE executable
+ if gcc-specs-pie ; then
+ append-ldflags -nopie
+ ewarn "Ocaml generates its own native asm, you're using a PIE compiler"
+ ewarn "We have appended -nopie to ocaml build options"
+ ewarn "because linking an executable with pie while the objects are not pic will not work"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix the EXEC_STACK in ocaml compiled binaries (#153382)
+ epatch "${FILESDIR}"/${PN}-3.10.0-exec-stack-fixes.patch
+
+ # Quick and somewhat dirty fix for bug #110541
+ # The sed in the Makefile doesn't replace all occurences of @compiler@
+ # in driver/ocamlcomp.sh.in. Reported upstream as issue 0004268.
+ #epatch "${FILESDIR}"/${P}-execheap.patch
+
+ # The configure script doesn't inherit previous defined variables,
+ # overwriting previous declarations of bytecccompopts, bytecclinkopts,
+ # nativecccompopts and nativecclinkopts. Reported upstream as issue 0004267.
+ epatch "${FILESDIR}"/${PN}-3.10.0-configure.patch
+
+ # ocaml has automagics on libX11 and gdbm
+ # http://caml.inria.fr/mantis/view.php?id=4278
+ epatch "${FILESDIR}/${PN}-3.10.0-automagic.patch"
+
+ # Call ld with proper flags, different from gcc ones
+ # This happens when calling ocamlc -pack
+ # See comment in the patch
+ epatch "${FILESDIR}/${PN}-3.10.0-call-ld-with-proper-ldflags.patch"
+
+}
+
+src_compile() {
+ local myconf="--host ${CHOST}"
+
+ # dev-lang/ocaml tends to break/give unexpected results with "unsafe" CFLAGS.
+ strip-flags
+ replace-flags "-O?" -O2
+
+ # It doesn't compile on alpha without this LDFLAGS
+ use alpha && append-ldflags "-Wl,--no-relax"
+
+ use tk || myconf="${myconf} -no-tk"
+ use ncurses || myconf="${myconf} -no-curses"
+ use X || myconf="${myconf} -no-graph"
+ use gdbm || myconf="${myconf} -no-dbm"
+
+ # ocaml uses a home-brewn configure script, preventing it to use econf.
+ ./configure -prefix /usr \
+ --bindir /usr/bin \
+ --libdir /usr/$(get_libdir)/ocaml \
+ --mandir /usr/share/man \
+ --with-pthread ${myconf} || die "configure failed!"
+
+ make world || die "make world failed!"
+
+ # Native code generation is unsupported on some archs
+ if ! use ppc64 ; then
+ make opt || die "make opt failed!"
+ make opt.opt || die "make opt.opt failed!"
+ fi
+}
+
+src_install() {
+ make BINDIR="${D}"/usr/bin \
+ LIBDIR="${D}"/usr/$(get_libdir)/ocaml \
+ MANDIR="${D}"/usr/share/man \
+ install || die "make install failed!"
+
+ # Install the compiler libs
+ dodir /usr/$(get_libdir)/ocaml/compiler-libs
+ insinto /usr/$(get_libdir)/ocaml/compiler-libs
+ doins {utils,typing,parsing}/*.{mli,cmi,cmo,cmx,o}
+
+ # Symlink the headers to the right place
+ dodir /usr/include
+ dosym /usr/$(get_libdir)/ocaml/caml /usr/include/
+
+ # Remove ${D} from ld.conf, as the buildsystem isn't $(DESTDIR) aware
+ dosed "s:${D}::g" /usr/$(get_libdir)/ocaml/ld.conf
+
+ dodoc Changes INSTALL README Upgrading
+
+ # Create and envd entry for latex input files (this definitely belongs into
+ # CONTENT and not in pkg_postinst.
+ if use latex ; then
+ echo "TEXINPUTS=/usr/$(get_libdir)/ocaml/ocamldoc:" > "${T}"/99ocamldoc
+ doenvd "${T}"/99ocamldoc
+ fi
+
+ # Install ocaml-rebuild.sh script rather than keeping it in $PORTDIR
+ dosbin "${FILESDIR}/ocaml-rebuild.sh"
+}
+
+pkg_postinst() {
+ echo
+ ewarn "OCaml is not binary compatible from version to version, so you"
+ ewarn "need to rebuild all packages depending on it, that are actually"
+ ewarn "installed on your system. To do so, you can run:"
+ ewarn "/usr/sbin/ocaml-rebuild.sh [-h | emerge options]"
+ ewarn "Which will call emerge on all old packages with the given options"
+ echo
+}