summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-10-06 21:26:57 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-10-06 21:26:57 +0000
commit6a351457e895a9facffb68b6b21b97e82dfcd75b (patch)
treeda28a2be23b8f7cf65acbc9dfbe978ad51632480 /dev-lang/ocaml
parentmetadata (diff)
downloadgentoo-2-6a351457e895a9facffb68b6b21b97e82dfcd75b.tar.gz
gentoo-2-6a351457e895a9facffb68b6b21b97e82dfcd75b.tar.bz2
gentoo-2-6a351457e895a9facffb68b6b21b97e82dfcd75b.zip
new version
Diffstat (limited to 'dev-lang/ocaml')
-rw-r--r--dev-lang/ocaml/Manifest16
-rw-r--r--dev-lang/ocaml/files/digest-ocaml-3.071
-rw-r--r--dev-lang/ocaml/ocaml-3.07.ebuild62
3 files changed, 72 insertions, 7 deletions
diff --git a/dev-lang/ocaml/Manifest b/dev-lang/ocaml/Manifest
index 7c100014c6c0..5796af276190 100644
--- a/dev-lang/ocaml/Manifest
+++ b/dev-lang/ocaml/Manifest
@@ -1,12 +1,14 @@
-MD5 d87725dccc5fef74def133e1aac090b8 ChangeLog 3449
-MD5 e85fd8053cc693729f0740b2ac855a44 ocaml-3.06.ebuild 1377
-MD5 8b350f19c06fcabf1053b0421b7c3f5a metadata.xml 155
MD5 8143dd48dfed3a4e3213352b958c77af ocaml-3.06-r1.ebuild 1444
-MD5 c50e8173b3a6104df726f87a39ba5f62 ocaml-3.06-r2.ebuild 1556
+MD5 e85fd8053cc693729f0740b2ac855a44 ocaml-3.06.ebuild 1377
MD5 c850861736892791084d5b2476b2fdc0 ocaml-3.07_beta2.ebuild 1566
-MD5 30ac0d14e37ff0be57927d84e4e7e1c6 files/digest-ocaml-3.06 197
-MD5 91579cecf8659312c2324d8d40709433 files/ocaml-3.06-sparc-configure.patch 1660
-MD5 13c4abf06e236e8835011a387f90ecc9 files/digest-ocaml-3.06-r1 63
+MD5 c50e8173b3a6104df726f87a39ba5f62 ocaml-3.06-r2.ebuild 1556
+MD5 a5b6568ba66135bdb8c65294b84843ec ocaml-3.07.ebuild 1495
+MD5 d87725dccc5fef74def133e1aac090b8 ChangeLog 3449
+MD5 8b350f19c06fcabf1053b0421b7c3f5a metadata.xml 155
MD5 4df214d6cd74b3c5955d868879dd6cc7 files/ocaml-3.06-tcltk-8.4compat-patch.bz2 639
+MD5 13c4abf06e236e8835011a387f90ecc9 files/digest-ocaml-3.06-r1 63
MD5 13c4abf06e236e8835011a387f90ecc9 files/digest-ocaml-3.06-r2 63
MD5 775d7436073205d935d3979a326b0729 files/digest-ocaml-3.07_beta2 68
+MD5 30ac0d14e37ff0be57927d84e4e7e1c6 files/digest-ocaml-3.06 197
+MD5 6e02dcc33419f9e035b77ff4a0104e8b files/digest-ocaml-3.07 63
+MD5 91579cecf8659312c2324d8d40709433 files/ocaml-3.06-sparc-configure.patch 1660
diff --git a/dev-lang/ocaml/files/digest-ocaml-3.07 b/dev-lang/ocaml/files/digest-ocaml-3.07
new file mode 100644
index 000000000000..33759519a3ff
--- /dev/null
+++ b/dev-lang/ocaml/files/digest-ocaml-3.07
@@ -0,0 +1 @@
+MD5 2dd038055f5e1350078ad81270411b78 ocaml-3.07.tar.gz 2537449
diff --git a/dev-lang/ocaml/ocaml-3.07.ebuild b/dev-lang/ocaml/ocaml-3.07.ebuild
new file mode 100644
index 000000000000..5110f2c2791b
--- /dev/null
+++ b/dev-lang/ocaml/ocaml-3.07.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.07.ebuild,v 1.1 2003/10/06 21:26:56 george Exp $
+
+inherit flag-o-matic eutils
+filter-flags "-fstack-protector"
+
+DESCRIPTION="fast modern type-inferring functional programming language descended from the ML (Meta Language) family"
+HOMEPAGE="http://www.ocaml.org/"
+
+SRC_URI="http://caml.inria.fr/distrib/${P}/${P}.tar.gz"
+
+LICENSE="QPL-1.0 LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha"
+IUSE="tcltk"
+
+DEPEND="virtual/glibc
+ tcltk? ( >=dev-lang/tk-3.3.3 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ grep -rle "head -1" . | xargs sed -i "s:head -1:head -n 1:g"
+
+ # Fix for bug #23767
+ if [ "${ARCH}" = "sparc" ]
+ then
+ # We need a patch and to make sure it builds
+ # for the right host type
+ epatch ${FILESDIR}/ocaml-3.06-sparc-configure.patch
+ myconf="${myconfg} -host sparc-unknown-linux-gnu"
+ fi
+}
+
+src_compile() {
+ local myconf
+ use tcltk || myconf="-no-tk"
+
+ ./configure -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/lib/ocaml \
+ -mandir /usr/share/man \
+ --with-pthread ${myconf} || die
+
+ make world || die
+ make opt || die
+ make opt.opt || die
+}
+
+src_install() {
+ make BINDIR=${D}/usr/bin \
+ LIBDIR=${D}/usr/lib/ocaml \
+ MANDIR=${D}/usr/share/man \
+ install || die
+
+ # silly, silly makefiles
+ dosed "s:${D}::g" /usr/lib/ocaml/ld.conf
+
+ # documentation
+ dodoc Changes INSTALL LICENSE README Upgrading
+}