summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-01-20 08:43:57 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-01-20 08:43:57 +0000
commit1a1e1cdeef82d802b5165e2c35dd40496caa269a (patch)
tree2008643dc84a32fb8967772ffc4f705b08bc6b51 /dev-lang/ocaml
parentinclude upstream bug report link in the patch (diff)
downloadgentoo-2-1a1e1cdeef82d802b5165e2c35dd40496caa269a.tar.gz
gentoo-2-1a1e1cdeef82d802b5165e2c35dd40496caa269a.tar.bz2
gentoo-2-1a1e1cdeef82d802b5165e2c35dd40496caa269a.zip
explicitly set RDEPEND to DEPEND
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/ocaml')
-rw-r--r--dev-lang/ocaml/ChangeLog6
-rw-r--r--dev-lang/ocaml/ocaml-3.08.4.ebuild5
-rw-r--r--dev-lang/ocaml/ocaml-3.10.2.ebuild3
-rw-r--r--dev-lang/ocaml/ocaml-3.11.0.ebuild3
4 files changed, 12 insertions, 5 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index 763b6009b39c..e58aac432775 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ocaml
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.159 2009/01/20 08:37:43 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.160 2009/01/20 08:43:57 aballier Exp $
+
+ 20 Jan 2009; Alexis Ballier <aballier@gentoo.org> ocaml-3.08.4.ebuild,
+ ocaml-3.10.2.ebuild, ocaml-3.11.0.ebuild:
+ explicitly set RDEPEND to DEPEND
20 Jan 2009; Alexis Ballier <aballier@gentoo.org>
files/ocaml-3.11.0_beta1-yaccldflags.patch:
diff --git a/dev-lang/ocaml/ocaml-3.08.4.ebuild b/dev-lang/ocaml/ocaml-3.08.4.ebuild
index d795ceb11e8d..ef1273adfb9b 100644
--- a/dev-lang/ocaml/ocaml-3.08.4.ebuild
+++ b/dev-lang/ocaml/ocaml-3.08.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.08.4.ebuild,v 1.19 2008/06/16 19:44:37 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.08.4.ebuild,v 1.20 2009/01/20 08:43:57 aballier Exp $
inherit flag-o-matic eutils multilib
@@ -15,6 +15,7 @@ KEYWORDS="alpha amd64 arm hppa ia64 ~ppc ~ppc64 -s390 sparc ~x86"
IUSE="tk latex"
DEPEND="tk? ( >=dev-lang/tk-3.3.3 )"
+RDEPEND="${DEPEND}"
pkg_setup() {
ewarn
diff --git a/dev-lang/ocaml/ocaml-3.10.2.ebuild b/dev-lang/ocaml/ocaml-3.10.2.ebuild
index e28ae5faedf0..d4e9e778c531 100644
--- a/dev-lang/ocaml/ocaml-3.10.2.ebuild
+++ b/dev-lang/ocaml/ocaml-3.10.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.10.2.ebuild,v 1.11 2009/01/20 08:23:31 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.10.2.ebuild,v 1.12 2009/01/20 08:43:57 aballier Exp $
inherit flag-o-matic eutils multilib versionator toolchain-funcs
@@ -20,6 +20,7 @@ DEPEND="tk? ( >=dev-lang/tk-3.3.3 )
ncurses? ( sys-libs/ncurses )
X? ( x11-libs/libX11 x11-proto/xproto )
gdbm? ( sys-libs/gdbm )"
+RDEPEND="${DEPEND}"
PDEPEND="emacs? ( app-emacs/ocaml-mode )
xemacs? ( app-xemacs/ocaml )"
diff --git a/dev-lang/ocaml/ocaml-3.11.0.ebuild b/dev-lang/ocaml/ocaml-3.11.0.ebuild
index f5ea510e552d..c6560730446f 100644
--- a/dev-lang/ocaml/ocaml-3.11.0.ebuild
+++ b/dev-lang/ocaml/ocaml-3.11.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.11.0.ebuild,v 1.2 2009/01/20 08:23:31 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.11.0.ebuild,v 1.3 2009/01/20 08:43:57 aballier Exp $
inherit flag-o-matic eutils multilib versionator toolchain-funcs
@@ -20,6 +20,7 @@ DEPEND="tk? ( >=dev-lang/tk-3.3.3 )
ncurses? ( sys-libs/ncurses )
X? ( x11-libs/libX11 x11-proto/xproto )
gdbm? ( sys-libs/gdbm )"
+RDEPEND="${DEPEND}"
PDEPEND="emacs? ( app-emacs/ocaml-mode )
xemacs? ( app-xemacs/ocaml )"