summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-01-23 03:50:21 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-01-23 03:50:21 +0000
commit608037bc30840a4e2737c15590d80fba7ec11f46 (patch)
tree1446e4208981a914d3f492c79399caafa069f195 /dev-lang/nqp
parentRemove old. (diff)
downloadgentoo-2-608037bc30840a4e2737c15590d80fba7ec11f46.tar.gz
gentoo-2-608037bc30840a4e2737c15590d80fba7ec11f46.tar.bz2
gentoo-2-608037bc30840a4e2737c15590d80fba7ec11f46.zip
Work around weird build system failure with libffi, add missing dep on libffi
(Portage version: 2.2.15/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-lang/nqp')
-rw-r--r--dev-lang/nqp/ChangeLog7
-rw-r--r--dev-lang/nqp/nqp-2014.12.ebuild13
2 files changed, 14 insertions, 6 deletions
diff --git a/dev-lang/nqp/ChangeLog b/dev-lang/nqp/ChangeLog
index 37e57be9f02e..7ff3b94f6172 100644
--- a/dev-lang/nqp/ChangeLog
+++ b/dev-lang/nqp/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/nqp
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/ChangeLog,v 1.57 2014/12/20 09:01:39 patrick Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/ChangeLog,v 1.58 2015/01/23 03:50:21 patrick Exp $
+
+ 23 Jan 2015; Patrick Lauer <patrick@gentoo.org> nqp-2014.12.ebuild:
+ Work around weird build system failure with libffi, add missing dep on libffi
*nqp-2014.12 (20 Dec 2014)
diff --git a/dev-lang/nqp/nqp-2014.12.ebuild b/dev-lang/nqp/nqp-2014.12.ebuild
index 680ee7b118f2..2cf30f89969d 100644
--- a/dev-lang/nqp/nqp-2014.12.ebuild
+++ b/dev-lang/nqp/nqp-2014.12.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/nqp-2014.12.ebuild,v 1.1 2014/12/20 09:01:39 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/nqp-2014.12.ebuild,v 1.2 2015/01/23 03:50:21 patrick Exp $
EAPI=5
# still not working
RESTRICT="test"
-inherit eutils multilib
+inherit eutils multilib versionator
GITCRAP=64e7d41
PARROT_VERSION="6.7.0"
@@ -24,7 +24,8 @@ REQUIRED_USE="|| ( parrot java moar )"
RDEPEND="parrot? ( >=dev-lang/parrot-${PARROT_VERSION}:=[unicode] )
java? ( >=virtual/jre-1.7 )
- moar? ( =dev-lang/moarvm-${PV} )"
+ moar? ( =dev-lang/moarvm-${PV} )
+ dev-libs/libffi"
DEPEND="${RDEPEND}
java? ( >=virtual/jdk-1.7 )
dev-lang/perl"
@@ -44,6 +45,10 @@ src_configure() {
# more dirty hack to allow building with newer gcc
sed -i -e 's/-Werror=implicit-function-declaration//' Makefile || die
sed -i -e 's/-Werror=nested-externs//' Makefile || die
+
+ # horrible hackery, but we need to know where libffi hides its headers ...
+ libffi_path=$(echo /usr/lib64/libffi-*)
+ sed -i -e "s:/usr/lib64/libffi-3.1:${libffi_path}:" Makefile || die
}
src_compile() {