summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-10-05 04:54:30 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-10-05 04:54:30 +0000
commit6c11559f14f184c080a148915b1f38043fe8f537 (patch)
treecdb2e41cddb6abd37f3b9f89d11820842cff8559 /dev-lang/nqp/nqp-2012.09.ebuild
parentBump (diff)
downloadgentoo-2-6c11559f14f184c080a148915b1f38043fe8f537.tar.gz
gentoo-2-6c11559f14f184c080a148915b1f38043fe8f537.tar.bz2
gentoo-2-6c11559f14f184c080a148915b1f38043fe8f537.zip
Bump
(Portage version: 2.2.0_alpha135/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/nqp/nqp-2012.09.ebuild')
-rw-r--r--dev-lang/nqp/nqp-2012.09.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-lang/nqp/nqp-2012.09.ebuild b/dev-lang/nqp/nqp-2012.09.ebuild
new file mode 100644
index 000000000000..099dced8b583
--- /dev/null
+++ b/dev-lang/nqp/nqp-2012.09.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/nqp-2012.09.ebuild,v 1.1 2012/10/05 04:54:30 patrick Exp $
+
+EAPI=3
+
+inherit eutils multilib
+
+PARROT_VERSION="4.4.0"
+
+DESCRIPTION="Not Quite Perl, a Perl 6 bootstrapping compiler"
+HOMEPAGE="http://rakudo.org/"
+SRC_URI="http://github.com/perl6/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/parrot-${PARROT_VERSION}[unicode]"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+src_prepare() {
+ cd "${WORKDIR}"
+ ln -s * "${S}" || die
+ cd "${S}"
+ echo "${PV}" > VERSION
+}
+
+src_configure() {
+ perl Configure.pl || die
+}
+
+src_compile() {
+ emake -j1 || die
+}
+
+src_test() {
+ emake -j1 test || die
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install || die
+
+ dodoc CREDITS README || die
+
+ if use doc; then
+ dodoc docs/* || die
+ fi
+}