summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-05 16:21:25 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-05 16:21:25 +0000
commitc8b463b31ba0ca8f69f70b855ef7d3ebe575dac4 (patch)
treedec07ee11a4203a6eb8813defcd625d2145b8257 /dev-lang/nhc98/nhc98-1.16.ebuild
parentneed eutils for epatch (diff)
downloadgentoo-2-c8b463b31ba0ca8f69f70b855ef7d3ebe575dac4.tar.gz
gentoo-2-c8b463b31ba0ca8f69f70b855ef7d3ebe575dac4.tar.bz2
gentoo-2-c8b463b31ba0ca8f69f70b855ef7d3ebe575dac4.zip
need eutils for epatch
Diffstat (limited to 'dev-lang/nhc98/nhc98-1.16.ebuild')
-rw-r--r--dev-lang/nhc98/nhc98-1.16.ebuild25
1 files changed, 10 insertions, 15 deletions
diff --git a/dev-lang/nhc98/nhc98-1.16.ebuild b/dev-lang/nhc98/nhc98-1.16.ebuild
index b90c57a431a0..b1fb5573dc76 100644
--- a/dev-lang/nhc98/nhc98-1.16.ebuild
+++ b/dev-lang/nhc98/nhc98-1.16.ebuild
@@ -1,35 +1,30 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nhc98/nhc98-1.16.ebuild,v 1.4 2003/07/11 22:14:07 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nhc98/nhc98-1.16.ebuild,v 1.5 2003/08/05 16:21:25 vapier Exp $
-IUSE="readline"
-
-TARBALL="nhc98src-${PV}.tar.gz"
+inherit eutils
DESCRIPTION="Haskell 98 compiler"
-SRC_URI="ftp://ftp.cs.york.ac.uk/pub/haskell/nhc98/${TARBALL}
- ftp://ftp.cs.york.ac.uk/pub/haskell/nhc98/patch-1.16-typesyn"
HOMEPAGE="http://www.cs.york.ac.uk/fp/nhc98/"
+SRC_URI="ftp://ftp.cs.york.ac.uk/pub/haskell/nhc98/nhc98src-${PV}.tar.gz
+ ftp://ftp.cs.york.ac.uk/pub/haskell/nhc98/patch-1.16-typesyn"
-SLOT="0"
LICENSE="nhc98"
-KEYWORDS="x86 ~sparc "
+SLOT="0"
+KEYWORDS="x86 ~sparc"
+IUSE="readline"
DEPEND="virtual/glibc
readline? ( >=readline-4.1 )"
src_unpack() {
- # unpack the source
- unpack "${TARBALL}"
+ unpack nhc98src-${PV}.tar.gz
# type synoym patch
cd ${S}
epatch ${DISTDIR}/patch-1.16-typesyn
-# cd ${P}
-# patch -p0 < ${FILESDIR}/patch-1.16-typesyn
}
src_compile() {
-
./configure --buildwith=gcc \
--prefix=/usr --installdir=/usr \
-man -docs \
@@ -39,7 +34,7 @@ src_compile() {
make || die
}
-src_install () {
+src_install() {
# The install location is taken care of by the
# configure script.
make DESTDIR=${D} install || die
@@ -54,7 +49,7 @@ src_install () {
dodoc bugs/README
}
-pkg_postinst () {
+pkg_postinst() {
#nhc's build system does not update hmakerc when using DESTDIR;
#therefore, we do it manually here