summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2009-08-10 06:33:41 +0000
committerKeri Harris <keri@gentoo.org>2009-08-10 06:33:41 +0000
commit67ffefce980eb3f9dfcf5851d741d7cd678e826e (patch)
tree617f1336667c311c1f7f8ec3541e0ca2b60d192e /dev-lang/mozart
parentVersion bump. (diff)
downloadgentoo-2-67ffefce980eb3f9dfcf5851d741d7cd678e826e.tar.gz
gentoo-2-67ffefce980eb3f9dfcf5851d741d7cd678e826e.tar.bz2
gentoo-2-67ffefce980eb3f9dfcf5851d741d7cd678e826e.zip
glibc2.10 fixes; amd64 chroot fixes
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/mozart')
-rw-r--r--dev-lang/mozart/ChangeLog9
-rw-r--r--dev-lang/mozart/files/mozart-1.4.0-const-cast.patch32
-rw-r--r--dev-lang/mozart/files/mozart-1.4.0-ozplatform-amd64.patch11
-rw-r--r--dev-lang/mozart/mozart-1.4.0.ebuild9
4 files changed, 55 insertions, 6 deletions
diff --git a/dev-lang/mozart/ChangeLog b/dev-lang/mozart/ChangeLog
index 22b603d87e1f..116bfae6d5de 100644
--- a/dev-lang/mozart/ChangeLog
+++ b/dev-lang/mozart/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/mozart
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mozart/ChangeLog,v 1.23 2008/11/27 05:32:08 keri Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mozart/ChangeLog,v 1.24 2009/08/10 06:33:41 keri Exp $
+
+ 10 Aug 2009; <keri@gentoo.org> mozart-1.4.0.ebuild,
+ +files/mozart-1.4.0-const-cast.patch,
+ +files/mozart-1.4.0-ozplatform-amd64.patch:
+ glibc2.10 fixes; amd64 chroot fixes
27 Nov 2008; <keri@gentoo.org> mozart-1.3.2.ebuild,
mozart-1.3.2-r1.ebuild, mozart-1.4.0.ebuild:
diff --git a/dev-lang/mozart/files/mozart-1.4.0-const-cast.patch b/dev-lang/mozart/files/mozart-1.4.0-const-cast.patch
new file mode 100644
index 000000000000..927b9e278427
--- /dev/null
+++ b/dev-lang/mozart/files/mozart-1.4.0-const-cast.patch
@@ -0,0 +1,32 @@
+diff -ur mozart-1.4.0.20080704.orig/platform/emulator/urlc.cc mozart-1.4.0.20080704/platform/emulator/urlc.cc
+--- mozart-1.4.0.20080704.orig/platform/emulator/urlc.cc 2005-05-19 00:23:12.000000000 +0000
++++ mozart-1.4.0.20080704/platform/emulator/urlc.cc 2009-08-09 22:03:30.000000000 +0000
+@@ -625,13 +625,13 @@
+ }
+ port = 21;
+
+- p_collon = strchr(line, ':');
+- p_at = strchr(line, '@');
++ p_collon = strchr(const_cast<char*>(line), ':');
++ p_at = strchr(const_cast<char*>(line), '@');
+ if(NULL != p_at) // we have a pass
+ p_slash = strchr(p_at + 1, '/');
+ else
+- p_slash = strchr(line, '/');
+- p_semi = strchr(line, ';'); // to avoid masking by pass
++ p_slash = strchr(const_cast<char*>(line), '/');
++ p_semi = strchr(const_cast<char*>(line), ';'); // to avoid masking by pass
+
+ // sanity checks
+ if((NULL != p_collon) && (0 == p_collon[1]))
+@@ -1140,8 +1140,8 @@
+
+ if((NULL == line) || (0 == *line)) // emtpy line?
+ return (URLC_EEMPTY);
+- p_collon = strchr(line, ':');
+- p_slash = strchr(line, '/');
++ p_collon = strchr(const_cast<char*>(line), ':');
++ p_slash = strchr(const_cast<char*>(line), '/');
+
+ // sanity checks
+ if((NULL != p_collon) && (0 == p_collon[1])) // nothing after :
diff --git a/dev-lang/mozart/files/mozart-1.4.0-ozplatform-amd64.patch b/dev-lang/mozart/files/mozart-1.4.0-ozplatform-amd64.patch
new file mode 100644
index 000000000000..5b49aefb8e86
--- /dev/null
+++ b/dev-lang/mozart/files/mozart-1.4.0-ozplatform-amd64.patch
@@ -0,0 +1,11 @@
+--- mozart-1.4.0.20080704.orig/share/bin/ozplatform 2007-09-17 05:33:08.000000000 +0000
++++ mozart-1.4.0.20080704/share/bin/ozplatform 2009-08-09 22:36:47.000000000 +0000
+@@ -78,6 +78,8 @@
+ ;;
+ *i*86*Darwin*) OZARCH=darwin-i386
+ ;;
++ x86_64\ Linux*) OZARCH=linux-x86_64_32
++ ;;
+ *) OZARCH=unknown-unknown
+ ;;
+ esac
diff --git a/dev-lang/mozart/mozart-1.4.0.ebuild b/dev-lang/mozart/mozart-1.4.0.ebuild
index 131405b8a013..7468afdc154d 100644
--- a/dev-lang/mozart/mozart-1.4.0.ebuild
+++ b/dev-lang/mozart/mozart-1.4.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mozart/mozart-1.4.0.ebuild,v 1.5 2008/11/27 05:32:08 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mozart/mozart-1.4.0.ebuild,v 1.6 2009/08/10 06:33:41 keri Exp $
inherit elisp-common eutils
@@ -37,7 +37,9 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${P}-cstdio.patch
+ epatch "${FILESDIR}"/${P}-const-cast.patch
epatch "${FILESDIR}"/${P}-ozhome.patch
+ epatch "${FILESDIR}"/${P}-ozplatform-amd64.patch
epatch "${FILESDIR}"/${P}-ozplatform-sparc.patch
epatch "${FILESDIR}"/${P}-parallel-make.patch
epatch "${FILESDIR}"/${P}-contrib.patch
@@ -81,8 +83,7 @@ src_test() {
}
src_install() {
- # Parallel make install issues, bug #244872
- emake -j1 \
+ emake \
PREFIX="${D}"/usr/lib/mozart \
ELISPDIR="${D}${SITELISP}/${PN}" \
install || die "emake install failed"