summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-07-23 23:14:32 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-07-23 23:14:32 +0000
commitf8fb2b1386f1b0c975084449915f64e38ac16893 (patch)
treefffdffc73220e3c2974fa178eada09bb55ecad4e /dev-lang/mosml
parentRestore ~x86 I've dropped by accident. (diff)
downloadgentoo-2-f8fb2b1386f1b0c975084449915f64e38ac16893.tar.gz
gentoo-2-f8fb2b1386f1b0c975084449915f64e38ac16893.tar.bz2
gentoo-2-f8fb2b1386f1b0c975084449915f64e38ac16893.zip
Respecting CC variable, closes bug #243880
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'dev-lang/mosml')
-rw-r--r--dev-lang/mosml/ChangeLog8
-rw-r--r--dev-lang/mosml/mosml-2.01-r1.ebuild8
-rw-r--r--dev-lang/mosml/mosml-2.01.ebuild16
3 files changed, 21 insertions, 11 deletions
diff --git a/dev-lang/mosml/ChangeLog b/dev-lang/mosml/ChangeLog
index 2a51acd27aef..c60cf0924ab7 100644
--- a/dev-lang/mosml/ChangeLog
+++ b/dev-lang/mosml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/mosml
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mosml/ChangeLog,v 1.10 2009/05/30 02:11:23 darkside Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mosml/ChangeLog,v 1.11 2009/07/23 23:14:32 vostorga Exp $
+
+ 23 Jul 2009; Víctor Ostorga <vostorga@gentoo.org> mosml-2.01.ebuild,
+ mosml-2.01-r1.ebuild:
+ Respecting CC variable, closes bug #243880
30 May 2009; Jeremy Olexa <darkside@gentoo.org> mosml-2.01-r1.ebuild:
(non maintainer commit) Fix by Victor Ostorga to no longer pre-strip files,
diff --git a/dev-lang/mosml/mosml-2.01-r1.ebuild b/dev-lang/mosml/mosml-2.01-r1.ebuild
index f065eaefa9ea..ecbd7e7e4af5 100644
--- a/dev-lang/mosml/mosml-2.01-r1.ebuild
+++ b/dev-lang/mosml/mosml-2.01-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mosml/mosml-2.01-r1.ebuild,v 1.2 2009/05/30 02:11:23 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mosml/mosml-2.01-r1.ebuild,v 1.3 2009/07/23 23:14:32 vostorga Exp $
inherit eutils
@@ -9,11 +9,13 @@ DESCRIPTION="Moscow ML - a lightweight implementation of Standard ML (SML)"
SRC_URI="http://www.itu.dk/people/sestoft/mosml/mos201src.tar.gz"
HOMEPAGE="http://www.itu.dk/people/sestoft/mosml.html"
LICENSE="GPL-2"
-DEPEND=""
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
SLOT="0"
+DEPEND=""
+RDEPEND=""
+
src_unpack() {
unpack ${A}
cd "${S}"
@@ -25,7 +27,7 @@ src_unpack() {
}
src_compile() {
- emake MOSMLHOME=/opt/mosml world || die
+ emake CC=$(tc-getCC) MOSMLHOME=/opt/mosml world || die
}
src_install () {
diff --git a/dev-lang/mosml/mosml-2.01.ebuild b/dev-lang/mosml/mosml-2.01.ebuild
index 8fda1d697491..ac63e354c5f2 100644
--- a/dev-lang/mosml/mosml-2.01.ebuild
+++ b/dev-lang/mosml/mosml-2.01.ebuild
@@ -1,25 +1,29 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mosml/mosml-2.01.ebuild,v 1.7 2005/06/05 12:22:21 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mosml/mosml-2.01.ebuild,v 1.8 2009/07/23 23:14:32 vostorga Exp $
+
+inherit toolchain-funcs
S="${WORKDIR}/${PN}/src"
DESCRIPTION="Moscow ML - a lightweight implementation of Standard ML (SML)"
SRC_URI="http://www.dina.kvl.dk/~sestoft/mosml/mos201src.tar.gz"
HOMEPAGE="http://www.dina.dk/~sestoft/mosml.html"
LICENSE="GPL-2"
-DEPEND=""
KEYWORDS="~amd64 ppc x86"
IUSE=""
SLOT="0"
+DEPEND=""
+RDEPEND=""
+
src_compile() {
- emake MOSMLHOME=/opt/mosml world || die
+ emake CC="$(tc-getCC)" MOSMLHOME=/opt/mosml world || die
}
src_install () {
- make MOSMLHOME=${D}/opt/mosml install || die
- rm ${D}/opt/mosml/lib/camlrunm # This is a bad symlink
+ make MOSMLHOME="${D}"/opt/mosml install || die
+ rm "${D}"/opt/mosml/lib/camlrunm # This is a bad symlink
echo "#!/opt/mosml/bin/camlrunm" > ${D}/opt/mosml/lib/header
dodoc ../README