summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-11-27 15:50:40 +0000
committerPacho Ramos <pacho@gentoo.org>2010-11-27 15:50:40 +0000
commitaee8109e36eac1b2cf8547a6e77c489e45830403 (patch)
tree9e6de9db5670f54d720e1342bf92ffa4648231dc /dev-lang/mono
parentversion bump; support new filestructure and fileformat of VDR-1.7.3 (diff)
downloadgentoo-2-aee8109e36eac1b2cf8547a6e77c489e45830403.tar.gz
gentoo-2-aee8109e36eac1b2cf8547a6e77c489e45830403.tar.bz2
gentoo-2-aee8109e36eac1b2cf8547a6e77c489e45830403.zip
Backport upstream patch to fix radegast crash (bug #341435 by tman).
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/mono')
-rw-r--r--dev-lang/mono/ChangeLog8
-rw-r--r--dev-lang/mono/files/mono-2.8.1-radegast-crash.patch15
-rw-r--r--dev-lang/mono/mono-2.8.1-r1.ebuild (renamed from dev-lang/mono/mono-2.8.1.ebuild)7
3 files changed, 26 insertions, 4 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index 641259e1c715..aa3b25216e19 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/mono
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.204 2010/11/26 10:47:43 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.205 2010/11/27 15:50:40 pacho Exp $
+
+*mono-2.8.1-r1 (27 Nov 2010)
+
+ 27 Nov 2010; Pacho Ramos <pacho@gentoo.org> -mono-2.8.1.ebuild,
+ +mono-2.8.1-r1.ebuild, +files/mono-2.8.1-radegast-crash.patch:
+ Backport upstream patch to fix radegast crash (bug #341435 by tman).
*mono-2.8.1 (26 Nov 2010)
diff --git a/dev-lang/mono/files/mono-2.8.1-radegast-crash.patch b/dev-lang/mono/files/mono-2.8.1-radegast-crash.patch
new file mode 100644
index 000000000000..9260273d0d2a
--- /dev/null
+++ b/dev-lang/mono/files/mono-2.8.1-radegast-crash.patch
@@ -0,0 +1,15 @@
+--- /home/pacho/mono-2.8.1/mcs/class/Managed.Windows.Forms/System.Windows.Forms/TextBoxBase.cs.orig 2010-11-27 15:46:31.000000000 +0100
++++ /home/pacho/mono-2.8.1/mcs/class/Managed.Windows.Forms/System.Windows.Forms/TextBoxBase.cs 2010-11-27 15:47:02.000000000 +0100
+@@ -667,9 +667,10 @@
+ } else {
+ document.Empty();
+
+- document.SetSelectionToCaret (true);
+- if (IsHandleCreated)
++ if (IsHandleCreated) {
++ document.SetSelectionToCaret (true);
+ CalculateDocument ();
++ }
+ }
+
+ OnTextChanged(EventArgs.Empty);
diff --git a/dev-lang/mono/mono-2.8.1.ebuild b/dev-lang/mono/mono-2.8.1-r1.ebuild
index c79b6457b4dc..cd720ade3418 100644
--- a/dev-lang/mono/mono-2.8.1.ebuild
+++ b/dev-lang/mono/mono-2.8.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.8.1.ebuild,v 1.1 2010/11/26 10:47:43 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-2.8.1-r1.ebuild,v 1.1 2010/11/27 15:50:40 pacho Exp $
EAPI="2"
@@ -34,8 +34,9 @@ RESTRICT="test"
PATCHES=(
"${WORKDIR}/${PN}-2.8-libdir.patch"
- "${FILESDIR}/mono-2.2-ppc-threading.patch"
- "${FILESDIR}/mono-2.2-uselibdir.patch"
+ "${FILESDIR}/${PN}-2.2-ppc-threading.patch"
+ "${FILESDIR}/${PN}-2.2-uselibdir.patch"
+ "${FILESDIR}/${PN}-2.8.1-radegast-crash.patch"
)
pkg_setup() {