summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2008-06-18 02:52:18 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2008-06-18 02:52:18 +0000
commit628a4dfaf2d4c3a9f993aaf77b4d21311263e7ee (patch)
tree455c0029917143c4fc48f1ba3c8ce9b7190e9da3 /dev-lang/mono
parentremove old. bug #226529 (diff)
downloadgentoo-2-628a4dfaf2d4c3a9f993aaf77b4d21311263e7ee.tar.gz
gentoo-2-628a4dfaf2d4c3a9f993aaf77b4d21311263e7ee.tar.bz2
gentoo-2-628a4dfaf2d4c3a9f993aaf77b4d21311263e7ee.zip
add patch for building aginst glibc 2.8
(Portage version: 2.1.5.5)
Diffstat (limited to 'dev-lang/mono')
-rw-r--r--dev-lang/mono/ChangeLog6
-rw-r--r--dev-lang/mono/files/mono-1.9.1-glibc-2.8-deprecated-arg-max.patch21
-rw-r--r--dev-lang/mono/mono-1.9.1.ebuild3
3 files changed, 28 insertions, 2 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index aef64aaa2860..a9500027623b 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/mono
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.140 2008/05/31 12:31:14 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.141 2008/06/18 02:52:17 compnerd Exp $
+
+ 18 Jun 2008; Saleem Abdulrasool <compnerd@gentoo.org>
+ +files/mono-1.9.1-glibc-2.8-deprecated-arg-max.patch, mono-1.9.1.ebuild:
+ Add patch for building against glibc 2.8
31 May 2008; Jurek Bartuszek <jurek@gentoo.org> mono-1.9.ebuild,
mono-1.9.1.ebuild:
diff --git a/dev-lang/mono/files/mono-1.9.1-glibc-2.8-deprecated-arg-max.patch b/dev-lang/mono/files/mono-1.9.1-glibc-2.8-deprecated-arg-max.patch
new file mode 100644
index 000000000000..491302ba7dab
--- /dev/null
+++ b/dev-lang/mono/files/mono-1.9.1-glibc-2.8-deprecated-arg-max.patch
@@ -0,0 +1,21 @@
+--- mono/io-layer/wapi_glob.c.orig 2008-06-13 21:22:30.000000000 -0700
++++ mono/io-layer/wapi_glob.c 2008-06-13 21:31:59.000000000 -0700
+@@ -266,6 +266,9 @@
+ u_int newsize, len;
+ char *copy;
+ const gchar *p;
++ long arglen;
++
++ arglen = sysconf(_SC_ARG_MAX);
+
+ newsize = sizeof(*pathv) * (2 + pglob->gl_pathc + pglob->gl_offs);
+ pathv = pglob->gl_pathv ? realloc((char *)pglob->gl_pathv, newsize) :
+@@ -300,7 +303,7 @@
+ pathv[pglob->gl_offs + pglob->gl_pathc] = NULL;
+
+ if ((pglob->gl_flags & WAPI_GLOB_LIMIT) &&
+- newsize + *limitp >= ARG_MAX) {
++ newsize + *limitp >= arglen) {
+ errno = 0;
+ return(WAPI_GLOB_NOSPACE);
+ }
diff --git a/dev-lang/mono/mono-1.9.1.ebuild b/dev-lang/mono/mono-1.9.1.ebuild
index 25c27a37b3b5..0711ff1b02b6 100644
--- a/dev-lang/mono/mono-1.9.1.ebuild
+++ b/dev-lang/mono/mono-1.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.9.1.ebuild,v 1.2 2008/05/31 12:31:14 jurek Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.9.1.ebuild,v 1.3 2008/06/18 02:52:17 compnerd Exp $
inherit eutils flag-o-matic multilib autotools
@@ -55,6 +55,7 @@ src_unpack() {
rm -f "${S}"/libgc/ltconfig
epatch "${FILESDIR}/${PN}-biginteger_overflow.diff"
+ epatch "${FILESDIR}/${PN}-1.9.1-glibc-2.8-deprecated-arg-max.patch"
einfo "Regenerating the build files, this will take some time..."
eautoreconf