summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2007-05-16 22:24:19 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2007-05-16 22:24:19 +0000
commit4f18f44e9619b6238977c9c89c24badd39fcb5e7 (patch)
treebb6de086792c5f243b0573b6a89ab6b738bc2f62 /dev-lang/mono
parentversion bump from upstream (diff)
downloadgentoo-2-4f18f44e9619b6238977c9c89c24badd39fcb5e7.tar.gz
gentoo-2-4f18f44e9619b6238977c9c89c24badd39fcb5e7.tar.bz2
gentoo-2-4f18f44e9619b6238977c9c89c24badd39fcb5e7.zip
version bump from upstream
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-lang/mono')
-rw-r--r--dev-lang/mono/ChangeLog7
-rw-r--r--dev-lang/mono/files/digest-mono-1.2.43
-rw-r--r--dev-lang/mono/mono-1.2.4.ebuild96
3 files changed, 105 insertions, 1 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index 6cf1461ff6bf..1ab076e7cf26 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/mono
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.109 2007/04/30 17:23:11 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.110 2007/05/16 22:24:19 compnerd Exp $
+
+*mono-1.2.4 (16 May 2007)
+
+ 16 May 2007; Saleem Abdulrasool <compnerd@gentoo.org> +mono-1.2.4.ebuild:
+ Version bump from upstream
30 Apr 2007; Roy Marples <uberlord@gentoo.org> mono-1.2.3.1.ebuild:
Added ~x86-fbsd keyword.
diff --git a/dev-lang/mono/files/digest-mono-1.2.4 b/dev-lang/mono/files/digest-mono-1.2.4
new file mode 100644
index 000000000000..4a37194aa4a9
--- /dev/null
+++ b/dev-lang/mono/files/digest-mono-1.2.4
@@ -0,0 +1,3 @@
+MD5 1d106acef8e3af3593c779f281541a0b mono-1.2.4.tar.bz2 17146737
+RMD160 f8886b7690dde27c433484fcfaff1913c60a874a mono-1.2.4.tar.bz2 17146737
+SHA256 780987a48256e6aff4206364a59f131a9aafbd5e3aa36694380d27b1d955176c mono-1.2.4.tar.bz2 17146737
diff --git a/dev-lang/mono/mono-1.2.4.ebuild b/dev-lang/mono/mono-1.2.4.ebuild
new file mode 100644
index 000000000000..5e4086dc0ea1
--- /dev/null
+++ b/dev-lang/mono/mono-1.2.4.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.2.4.ebuild,v 1.1 2007/05/16 22:24:19 compnerd Exp $
+
+inherit eutils flag-o-matic multilib autotools
+
+DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
+HOMEPAGE="http://www.go-mono.com"
+SRC_URI="http://www.go-mono.com/sources/mono/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2 LGPL-2 X11 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="X nptl"
+
+RDEPEND="!<dev-dotnet/pnet-0.6.12
+ >=dev-libs/glib-2.6
+ nptl? ( >=sys-devel/gcc-3.3.5-r1 )
+ ppc? (
+ >=sys-devel/gcc-3.2.3-r4
+ >=sys-libs/glibc-2.3.3_pre20040420
+ )
+ X? ( >=dev-dotnet/libgdiplus-1.2.4 )"
+DEPEND="${RDEPEND}
+ sys-devel/bc
+ >=dev-util/pkgconfig-0.19"
+PDEPEND="dev-dotnet/pe-format"
+
+# confcache causes build errors
+RESTRICT="confcache"
+
+function get-memory-total() {
+ cat /proc/meminfo | grep MemTotal | sed -r "s/[^0-9]*([[0-9]+).*/\1/"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Fix the install path, install into $(libdir)
+ sed -i -e 's:$(prefix)/lib:$(libdir):' \
+ -i -e 's:$(exec_prefix)/lib:$(libdir):' \
+ -i -e "s:'mono_libdir=\${exec_prefix}/lib':\"mono_libdir=\$libdir\":" \
+ ${S}/{scripts,mono/metadata}/Makefile.am ${S}/configure.in \
+ || die "sed failed"
+
+ sed -i -e 's:^libdir.*:libdir=@libdir@:' \
+ -i -e 's:${prefix}/lib/:${libdir}/:g' \
+ ${S}/{scripts,}/*.pc.in \
+ || die "sed failed"
+
+ # Remove dummy ltconfig and let libtool handle it
+ rm -f ${S}/libgc/ltconfig
+
+ einfo "Regenerating the build files, this will take some time..."
+ eautoreconf
+}
+
+src_compile() {
+ # mono's build system is finiky, strip the flags
+ strip-flags
+
+ # Enable the 2.0 FX, use the system glib and the gc
+ local myconf="--with-preview=yes --with-glib=system --with-gc=included"
+
+ # Threading support
+ if use amd64 || use nptl ; then
+ # force __thread on amd64 (bug #83770)
+ myconf="${myconf} --with-tls=__thread"
+ else
+ myconf="${myconf} --wiht-tls=pthread"
+ fi
+
+ # Enable large heaps if memory is more than >=3GB
+ if [[ $(get-memory-total) -ge 3145728 ]] ; then
+ myconf="${myconf} --with-large-heap=yes"
+ fi
+
+ # Force the use of monolite mcs to prevent issues with classlibs (bug #118062)
+ touch ${S}/mcs/build/deps/use-monolite
+
+ econf ${myconf} || die "configure failed"
+ emake || die "compile failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README
+
+ docinto docs
+ dodoc docs/*
+
+ docinto libgc
+ dodoc libgc/ChangeLog
+}