summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2006-10-22 22:55:33 +0000
committerKeri Harris <keri@gentoo.org>2006-10-22 22:55:33 +0000
commiteabe12b53906266c8cc8976be03ec0ce83c259ed (patch)
treed3afc420b1270dbae4e81f552cde034a04b878de /dev-lang/mercury-extras
parentVersion bump, reported by M. Edward Borasky <znmeb@cesmail.net> in bug #152309. (diff)
downloadgentoo-2-eabe12b53906266c8cc8976be03ec0ce83c259ed.tar.gz
gentoo-2-eabe12b53906266c8cc8976be03ec0ce83c259ed.tar.bz2
gentoo-2-eabe12b53906266c8cc8976be03ec0ce83c259ed.zip
Install lex libgrade targets sequentially.
(Portage version: 2.1.2_pre3-r6)
Diffstat (limited to 'dev-lang/mercury-extras')
-rw-r--r--dev-lang/mercury-extras/ChangeLog6
-rw-r--r--dev-lang/mercury-extras/files/mercury-extras-0.12.2-lex.patch21
-rw-r--r--dev-lang/mercury-extras/files/mercury-extras-0.13.0-lex.patch13
3 files changed, 30 insertions, 10 deletions
diff --git a/dev-lang/mercury-extras/ChangeLog b/dev-lang/mercury-extras/ChangeLog
index e8f72770ad05..7d43543f685c 100644
--- a/dev-lang/mercury-extras/ChangeLog
+++ b/dev-lang/mercury-extras/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/mercury-extras
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury-extras/ChangeLog,v 1.50 2006/10/19 07:28:27 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mercury-extras/ChangeLog,v 1.51 2006/10/22 22:55:33 keri Exp $
+
+ 22 Oct 2006; keri <keri@gentoo.org> files/mercury-extras-0.12.2-lex.patch,
+ files/mercury-extras-0.13.0-lex.patch:
+ Install lex libgrade targets sequentially.
19 Oct 2006; keri <keri@gentoo.org> mercury-extras-0.12.2.ebuild,
mercury-extras-0.12.2-r1.ebuild, mercury-extras-0.12.2-r2.ebuild,
diff --git a/dev-lang/mercury-extras/files/mercury-extras-0.12.2-lex.patch b/dev-lang/mercury-extras/files/mercury-extras-0.12.2-lex.patch
index a45c7ad90ae4..312b9c28cc5b 100644
--- a/dev-lang/mercury-extras/files/mercury-extras-0.12.2-lex.patch
+++ b/dev-lang/mercury-extras/files/mercury-extras-0.12.2-lex.patch
@@ -1,12 +1,6 @@
--- mercury-extras-0.12.2.orig/lex/Mmakefile 2002-12-03 17:48:31.000000000 +1300
-+++ mercury-extras-0.12.2/lex/Mmakefile 2006-04-01 15:14:41.000000000 +1200
-@@ -20,12 +20,12 @@
- # necessary, and everything put there.
- #
- #INSTALL_PREFIX := $(INSTALL_PREFIX)/extras
--INSTALL_PREFIX = .
-+#INSTALL_PREFIX = .
-
++++ mercury-extras-0.12.2/lex/Mmakefile 2006-10-23 11:49:12.000000000 +1300
+@@ -25,7 +25,7 @@
# Omit this line if you want to install the default grades.
# Edit this line if you want to install with different grades.
#
@@ -15,3 +9,14 @@
# Any application using these libraries will also need the following
# in its Mmakefile:
+@@ -47,7 +47,9 @@
+
+ depend: lex.depend regex.depend
+
+-install: liblex.install libregex.install
++install:
++ $(MMAKE) $(MMAKEFLAGS) liblex.install
++ $(MMAKE) $(MMAKEFLAGS) libregex.install
+
+ check: install
+ (cd tests; mmake check)
diff --git a/dev-lang/mercury-extras/files/mercury-extras-0.13.0-lex.patch b/dev-lang/mercury-extras/files/mercury-extras-0.13.0-lex.patch
index f71cef6cda9b..481a63cdf6ad 100644
--- a/dev-lang/mercury-extras/files/mercury-extras-0.13.0-lex.patch
+++ b/dev-lang/mercury-extras/files/mercury-extras-0.13.0-lex.patch
@@ -1,5 +1,5 @@
--- mercury-extras-0.13.0.orig/lex/Mmakefile 2002-12-03 17:48:31.000000000 +1300
-+++ mercury-extras-0.13.0/lex/Mmakefile 2006-09-17 09:05:13.000000000 +1200
++++ mercury-extras-0.13.0/lex/Mmakefile 2006-10-23 11:08:38.000000000 +1300
@@ -25,7 +25,7 @@
# Omit this line if you want to install the default grades.
# Edit this line if you want to install with different grades.
@@ -9,3 +9,14 @@
# Any application using these libraries will also need the following
# in its Mmakefile:
+@@ -47,7 +47,9 @@
+
+ depend: lex.depend regex.depend
+
+-install: liblex.install libregex.install
++install:
++ $(MMAKE) $(MMAKEFLAGS) liblex.install
++ $(MMAKE) $(MMAKEFLAGS) libregex.install
+
+ check: install
+ (cd tests; mmake check)