summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2006-12-06 18:06:32 +0000
committerMatti Bickel <mabi@gentoo.org>2006-12-06 18:06:32 +0000
commitdd1a7b092466b111105d3b6379db0aec125e33ca (patch)
tree64c596e25893402e4c6d219987ca1150c91c2542 /dev-lang/lua
parentcleanup old versions (diff)
downloadgentoo-2-dd1a7b092466b111105d3b6379db0aec125e33ca.tar.gz
gentoo-2-dd1a7b092466b111105d3b6379db0aec125e33ca.tar.bz2
gentoo-2-dd1a7b092466b111105d3b6379db0aec125e33ca.zip
Reverting back to the liblua* naming
(Portage version: 2.1.1-r2)
Diffstat (limited to 'dev-lang/lua')
-rw-r--r--dev-lang/lua/files/lua-5.1.1-make.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-lang/lua/files/lua-5.1.1-make.patch b/dev-lang/lua/files/lua-5.1.1-make.patch
index ca79d3086c2e..03959c05ef47 100644
--- a/dev-lang/lua/files/lua-5.1.1-make.patch
+++ b/dev-lang/lua/files/lua-5.1.1-make.patch
@@ -36,8 +36,8 @@
+ mkdir -p $(INSTALL_BIN) $(INSTALL_INC) $(INSTALL_LIB) $(INSTALL_MAN)
+ cd src; $(LIBTOOL) --mode=install $(INSTALL_EXEC) lua luac $(INSTALL_BIN)
+ cd src; $(INSTALL_DATA) $(TO_INC) $(INSTALL_INC)
-+ cd src; $(LIBTOOL) --mode=install $(INSTALL_DATA) liblualib.la $(INSTALL_LIB)
-+ cd src; $(LIBTOOL) --mode=install $(INSTALL_DATA) liblualib.a $(INSTALL_LIB)
++ cd src; $(LIBTOOL) --mode=install $(INSTALL_DATA) liblua.la $(INSTALL_LIB)
++ cd src; $(LIBTOOL) --mode=install $(INSTALL_DATA) liblua.a $(INSTALL_LIB)
--- /home/mabi/gentoo/lua-5.1.1.orig/src/Makefile 2006-03-22 01:41:49.000000000 +0100
+++ ./src/Makefile 2006-11-16 02:10:27.000000000 +0100
@@ -176,3 +176,36 @@
@@ -51,7 +51,7 @@
+# The following rules use libtool for compiling and linking in order to
+# provide shared library support.
+
-+LIB_NAME = liblualib.la
++LIB_NAME = liblua.la
+LIB_OBJS = $(CORE_O:.o=.lo) $(LIB_O:.o=.lo)
+
+%.lo %.o: %.c
@@ -65,7 +65,7 @@
+ $(LIBTOOL) --mode=link $(CC) -static -o $(LIB_NAME:.la=.a) $(LIB_OBJS)
+
+lua: $(LUA_O) $(LIB_NAME)
-+ $(LIBTOOL) --mode=link $(CC) -Wl,-E -o $@ $(LUA_O) $(LUA_LIBS) -llualib
++ $(LIBTOOL) --mode=link $(CC) -Wl,-E -o $@ $(LUA_O) $(LUA_LIBS) -llua
+
+lua_test: $(LUA_O) $(LIB_NAME)
+ $(LIBTOOL) --mode=link $(CC) -static -Wl,-E -o $@ $(LUA_O) $(LIB_NAME) $(LUA_LIBS)