summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2006-11-21 14:47:10 +0000
committerMatti Bickel <mabi@gentoo.org>2006-11-21 14:47:10 +0000
commit95a5623fdf4a2f0bca17644e7b41dd93afea4b8f (patch)
tree218a7ff7eadc40521ca7a7807e6746dd37b30f03 /dev-lang/lua
parentAdded myself as co-maintainer. (diff)
downloadgentoo-2-95a5623fdf4a2f0bca17644e7b41dd93afea4b8f.tar.gz
gentoo-2-95a5623fdf4a2f0bca17644e7b41dd93afea4b8f.tar.bz2
gentoo-2-95a5623fdf4a2f0bca17644e7b41dd93afea4b8f.zip
Added static useflag
(Portage version: 2.1.1-r2)
Diffstat (limited to 'dev-lang/lua')
-rw-r--r--dev-lang/lua/ChangeLog6
-rw-r--r--dev-lang/lua/files/lua-5.1.1-make.patch2
-rw-r--r--dev-lang/lua/files/lua-5.1.1-make_static.patch12
-rw-r--r--dev-lang/lua/lua-5.1.1.ebuild12
4 files changed, 28 insertions, 4 deletions
diff --git a/dev-lang/lua/ChangeLog b/dev-lang/lua/ChangeLog
index c6e29ba212c2..193843876c56 100644
--- a/dev-lang/lua/ChangeLog
+++ b/dev-lang/lua/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/lua
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/ChangeLog,v 1.52 2006/11/18 10:55:05 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/ChangeLog,v 1.53 2006/11/21 14:47:10 mabi Exp $
+
+ 21 Nov 2006; Matti Bickel <mabi@gentoo.org> files/lua-5.1.1-make.patch,
+ +files/lua-5.1.1-make_static.patch, lua-5.1.1.ebuild:
+ Added static useflag to allow to be closer to upstreams recommendations
18 Nov 2006; Christian Faulhammer <opfer@gentoo.org> lua-5.1.1.ebuild:
keyworded ~x86, bug #155518
diff --git a/dev-lang/lua/files/lua-5.1.1-make.patch b/dev-lang/lua/files/lua-5.1.1-make.patch
index 7522e56bb08c..3dc7aee59a7e 100644
--- a/dev-lang/lua/files/lua-5.1.1-make.patch
+++ b/dev-lang/lua/files/lua-5.1.1-make.patch
@@ -63,7 +63,7 @@
+ -rpath $(RPATH) -o $(LIB_NAME) $(LIB_OBJS) $(LIB_LIBS)
+
+lua-$(V): $(LUA_O) $(LIB_NAME)
-+ $(LIBTOOL) --mode=link $(CC) -static -Wl,-E -o $@ $(LUA_O) $(LIB_NAME) $(LUA_LIBS)
++ $(LIBTOOL) --mode=link $(CC) -Wl,-E -o $@ $(LUA_O) $(LUA_LIBS) -llua
+
+luac-$(V): $(LUAC_O) $(LIB_NAME)
+ $(LIBTOOL) --mode=link $(CC) -static -o $@ $(LUAC_O) $(LIB_NAME)
diff --git a/dev-lang/lua/files/lua-5.1.1-make_static.patch b/dev-lang/lua/files/lua-5.1.1-make_static.patch
new file mode 100644
index 000000000000..b25cb5c89c95
--- /dev/null
+++ b/dev-lang/lua/files/lua-5.1.1-make_static.patch
@@ -0,0 +1,12 @@
+diff -ru lua-5.1.1.orig/src/Makefile lua-5.1.1/src/Makefile
+--- lua-5.1.1.orig/src/Makefile 2006-11-21 07:19:31 +0000
++++ lua-5.1.1/src/Makefile 2006-11-21 07:19:52 +0000
+@@ -196,7 +196,7 @@
+ -rpath $(RPATH) -o $(LIB_NAME) $(LIB_OBJS) $(LIB_LIBS)
+
+ lua-$(V): $(LUA_O) $(LIB_NAME)
+- $(LIBTOOL) --mode=link $(CC) -Wl,-E -o $@ $(LUA_O) $(LUA_LIBS) -llua
++ $(LIBTOOL) --mode=link $(CC) -static -Wl,-E -o $@ $(LUA_O) $(LIB_NAME) $(LUA_LIBS)
+
+ luac-$(V): $(LUAC_O) $(LIB_NAME)
+ $(LIBTOOL) --mode=link $(CC) -static -o $@ $(LUAC_O) $(LIB_NAME)
diff --git a/dev-lang/lua/lua-5.1.1.ebuild b/dev-lang/lua/lua-5.1.1.ebuild
index cfdd2b0b91fe..9d1343f25b8f 100644
--- a/dev-lang/lua/lua-5.1.1.ebuild
+++ b/dev-lang/lua/lua-5.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.1.1.ebuild,v 1.2 2006/11/18 10:55:05 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.1.1.ebuild,v 1.3 2006/11/21 14:47:10 mabi Exp $
inherit eutils portability
@@ -11,7 +11,7 @@ SRC_URI="http://www.lua.org/ftp/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~ppc ~x86"
-IUSE="readline"
+IUSE="readline static"
RDEPEND="readline? ( sys-libs/readline )"
DEPEND="${RDEPEND}"
@@ -28,6 +28,14 @@ src_unpack() {
if ! use readline ; then
epatch "${FILESDIR}"/${P}-readline.patch
fi
+
+ # Using dynamic linked lua is not recommended upstream for performance
+ # reasons. http://article.gmane.org/gmane.comp.lang.lua.general/18519
+ # Mainly, this is of concern if your arch is poor with GPRs, like x86
+ # Note that the lua compiler is build statically anyway
+ if use static ; then
+ epatch "${FILESDIR}"/${P}-make_static.patch
+ fi
}
src_compile() {