summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2007-03-06 22:15:09 +0000
committerMatti Bickel <mabi@gentoo.org>2007-03-06 22:15:09 +0000
commit0f00bd2bc56a6cbd6861ab8d1288eb35f2a77b6b (patch)
tree95ffe244352caa2abbbb5af22f1fadca8e1959a3 /dev-lang/lua/lua-5.1.1-r2.ebuild
parentCleanup. (diff)
downloadgentoo-2-0f00bd2bc56a6cbd6861ab8d1288eb35f2a77b6b.tar.gz
gentoo-2-0f00bd2bc56a6cbd6861ab8d1288eb35f2a77b6b.tar.bz2
gentoo-2-0f00bd2bc56a6cbd6861ab8d1288eb35f2a77b6b.zip
fix to the .pc file
(Portage version: 2.1.2.1)
Diffstat (limited to 'dev-lang/lua/lua-5.1.1-r2.ebuild')
-rw-r--r--dev-lang/lua/lua-5.1.1-r2.ebuild100
1 files changed, 100 insertions, 0 deletions
diff --git a/dev-lang/lua/lua-5.1.1-r2.ebuild b/dev-lang/lua/lua-5.1.1-r2.ebuild
new file mode 100644
index 000000000000..cb999df46fc4
--- /dev/null
+++ b/dev-lang/lua/lua-5.1.1-r2.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.1.1-r2.ebuild,v 1.1 2007/03/06 22:15:09 mabi Exp $
+
+inherit eutils portability
+
+DESCRIPTION="A powerful light-weight programming language designed for extending applications"
+HOMEPAGE="http://www.lua.org/"
+SRC_URI="http://www.lua.org/ftp/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="readline static"
+
+RDEPEND="readline? ( sys-libs/readline )"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-make.patch
+ epatch "${FILESDIR}"/${P}-module_paths.patch
+
+ sed -i -e 's:\(/README\)\("\):\1.gz\2:g' doc/readme.html
+
+ if ! use readline ; then
+ epatch "${FILESDIR}"/${P}-readline.patch
+ fi
+
+ # Using dynamic linked lua is not recommended upstream for performance
+ # reasons. http://article.gmane.org/gmane.comp.lang.lua.general/18519
+ # Mainly, this is of concern if your arch is poor with GPRs, like x86
+ # Note that the lua compiler is build statically anyway
+ if use static ; then
+ epatch "${FILESDIR}"/${P}-make_static.patch
+ fi
+
+ # We want packages to find our things...
+ sed -i -e 's:/usr/local:/usr:' etc/lua.pc
+}
+
+src_compile() {
+ myflags=
+ # what to link to liblua
+ liblibs="-lm"
+ if use ppc-macos; then
+ mycflags="${mycflags} -DLUA_USE_MACOSX"
+ else # building for standard linux (and bsd too)
+ mycflags="${mycflags} -DLUA_USE_LINUX"
+ liblibs="${liblibs} $(dlopen_lib)"
+ fi
+
+ # what to link to the executables
+ mylibs=
+ if use readline; then
+ mylibs="-lreadline"
+ fi
+
+ cd src
+ emake CFLAGS="${mycflags} ${CFLAGS}" \
+ RPATH="/usr/$(get_libdir)/" \
+ LUA_LIBS="${mylibs}" \
+ LIB_LIBS="${liblibs}" \
+ V=${PV} \
+ gentoo_all || die "emake failed"
+
+ mv lua_test ../test/lua.static
+}
+
+src_install() {
+ emake INSTALL_TOP="${D}/usr/" INSTALL_LIB="${D}/usr/$(get_libdir)/" \
+ V=${PV} gentoo_install \
+ || die "emake install gentoo_install failed"
+
+ dodoc HISTORY README
+ dohtml doc/*.html doc/*.gif
+
+ insinto /usr/share/pixmaps
+ doins etc/lua.ico
+ insinto /usr/$(get_libdir)/pkgconfig
+ doins etc/lua.pc
+}
+
+src_test() {
+ local positive="bisect cf echo env factorial fib fibfor hello printf sieve
+ sort trace-calls trace-globals"
+ local negative="readonly"
+ local test
+
+ cd "${S}"
+ for test in ${positive}; do
+ test/lua.static test/${test}.lua &> /dev/null || die "test $test failed"
+ done
+
+ for test in ${negative}; do
+ test/lua.static test/${test}.lua &> /dev/null && die "test $test failed"
+ done
+}