summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-04-29 09:16:12 +0000
committerTim Harder <radhermit@gentoo.org>2014-04-29 09:16:12 +0000
commit2d1037ca36f87db14696233c73e76806b2d76465 (patch)
treeb55a11a24aba059dfecbdfd82ed05cb00c689f39 /dev-lang/lazarus
parentStable for amd64 wrt bug #506786 (diff)
downloadgentoo-2-2d1037ca36f87db14696233c73e76806b2d76465.tar.gz
gentoo-2-2d1037ca36f87db14696233c73e76806b2d76465.tar.bz2
gentoo-2-2d1037ca36f87db14696233c73e76806b2d76465.zip
Version bump (bug #508950).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-lang/lazarus')
-rw-r--r--dev-lang/lazarus/ChangeLog9
-rw-r--r--dev-lang/lazarus/lazarus-1.2.2.ebuild76
2 files changed, 83 insertions, 2 deletions
diff --git a/dev-lang/lazarus/ChangeLog b/dev-lang/lazarus/ChangeLog
index a34ae914da0a..2a77c81b32fc 100644
--- a/dev-lang/lazarus/ChangeLog
+++ b/dev-lang/lazarus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/lazarus
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lazarus/ChangeLog,v 1.42 2013/12/24 12:42:10 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lazarus/ChangeLog,v 1.43 2014/04/29 09:16:12 radhermit Exp $
+
+*lazarus-1.2.2 (29 Apr 2014)
+
+ 29 Apr 2014; Tim Harder <radhermit@gentoo.org> +lazarus-1.2.2.ebuild:
+ Version bump (bug #508950).
24 Dec 2013; Agostino Sarubbo <ago@gentoo.org> lazarus-1.0.12.ebuild:
Stable for x86, wrt bug #491544
diff --git a/dev-lang/lazarus/lazarus-1.2.2.ebuild b/dev-lang/lazarus/lazarus-1.2.2.ebuild
new file mode 100644
index 000000000000..74d70ce805dd
--- /dev/null
+++ b/dev-lang/lazarus/lazarus-1.2.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lazarus/lazarus-1.2.2.ebuild,v 1.1 2014/04/29 09:16:12 radhermit Exp $
+
+EAPI=5
+inherit eutils
+
+FPCVER="2.6.4"
+
+DESCRIPTION="Lazarus IDE is a feature rich visual programming environment emulating Delphi"
+HOMEPAGE="http://www.lazarus.freepascal.org/"
+SRC_URI="http://downloads.sourceforge.net/project/${PN}/Lazarus%20Zip%20_%20GZip/Lazarus%20${PV}/${PN}-${PV}-0.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1-with-linking-exception"
+SLOT="0" # Note: Slotting Lazarus needs slotting fpc, see DEPEND.
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="minimal"
+
+DEPEND=">=dev-lang/fpc-${FPCVER}[source]
+ net-misc/rsync
+ x11-libs/gtk+:2"
+RDEPEND="${DEPEND}
+ !=gnome-base/librsvg-2.16.1"
+DEPEND="${DEPEND}
+ >=sys-devel/binutils-2.19.1-r1"
+
+RESTRICT="strip" #269221
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.9.26-fpcsrc.patch
+
+ # Use default configuration (minus stripping) unless specifically requested otherwise
+ if ! test ${PPC_CONFIG_PATH+set} ; then
+ local FPCVER=$(fpc -iV)
+ export PPC_CONFIG_PATH="${WORKDIR}"
+ sed -e 's/^FPBIN=/#&/' /usr/lib/fpc/${FPCVER}/samplecfg |
+ sh -s /usr/lib/fpc/${FPCVER} "${PPC_CONFIG_PATH}" || die
+ #sed -i -e '/^-Xs/d' "${PPC_CONFIG_PATH}"/fpc.cfg || die
+ fi
+}
+
+src_compile() {
+ LCL_PLATFORM=gtk2 emake \
+ $(usex minimal "" "bigide") \
+ -j1
+}
+
+src_install() {
+ diropts -m0755
+ dodir /usr/share
+ # Using rsync to avoid unnecessary copies and cleaning...
+ # Note: *.o and *.ppu are needed
+ rsync -a \
+ --exclude="CVS" --exclude=".cvsignore" \
+ --exclude="*.ppw" --exclude="*.ppl" \
+ --exclude="*.ow" --exclude="*.a"\
+ --exclude="*.rst" --exclude=".#*" \
+ --exclude="*.~*" --exclude="*.bak" \
+ --exclude="*.orig" --exclude="*.rej" \
+ --exclude=".xvpics" --exclude="*.compiled" \
+ --exclude="killme*" --exclude=".gdb_hist*" \
+ --exclude="debian" --exclude="COPYING*" \
+ --exclude="*.app" \
+ "${S}" "${ED%/}"/usr/share \
+ || die "Unable to copy files!"
+
+ dosym ../share/lazarus/startlazarus /usr/bin/startlazarus
+ dosym ../share/lazarus/startlazarus /usr/bin/lazarus
+ dosym ../share/lazarus/lazbuild /usr/bin/lazbuild
+ use minimal || dosym ../share/lazarus/components/chmhelp/lhelp/lhelp /usr/bin/lhelp
+ dosym ../lazarus/images/ide_icon48x48.png /usr/share/pixmaps/lazarus.png
+
+ make_desktop_entry startlazarus "Lazarus IDE" "lazarus" || die "Failed making desktop entry!"
+}