summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-07-07 00:48:30 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-07-07 00:48:30 +0000
commitfc4e3a63e756fa0e22c39e7c9154e2f0ea9598f1 (patch)
treecab3e8eec7d9b27e33bd139d298f4b5c050c5706 /dev-lang/ispc
parentfixed examples installation directory, bug #424942 (diff)
downloadgentoo-2-fc4e3a63e756fa0e22c39e7c9154e2f0ea9598f1.tar.gz
gentoo-2-fc4e3a63e756fa0e22c39e7c9154e2f0ea9598f1.tar.bz2
gentoo-2-fc4e3a63e756fa0e22c39e7c9154e2f0ea9598f1.zip
version bump
(Portage version: 2.2.0_alpha116/cvs/Linux i686)
Diffstat (limited to 'dev-lang/ispc')
-rw-r--r--dev-lang/ispc/ChangeLog7
-rw-r--r--dev-lang/ispc/ispc-1.3.0.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-lang/ispc/ChangeLog b/dev-lang/ispc/ChangeLog
index 0b6a44c29edc..9e636c5125c1 100644
--- a/dev-lang/ispc/ChangeLog
+++ b/dev-lang/ispc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/ispc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ChangeLog,v 1.3 2012/06/19 12:22:33 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ChangeLog,v 1.4 2012/07/07 00:48:30 ottxor Exp $
+
+*ispc-1.3.0 (07 Jul 2012)
+
+ 07 Jul 2012; Christoph Junghans <ottxor@gentoo.org> +ispc-1.3.0.ebuild:
+ version bump
19 Jun 2012; Agostino Sarubbo <ago@gentoo.org> ispc-1.2.2.ebuild:
Add ~amd64
diff --git a/dev-lang/ispc/ispc-1.3.0.ebuild b/dev-lang/ispc/ispc-1.3.0.ebuild
new file mode 100644
index 000000000000..521d2d8045d4
--- /dev/null
+++ b/dev-lang/ispc/ispc-1.3.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ispc-1.3.0.ebuild,v 1.1 2012/07/07 00:48:30 ottxor Exp $
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="Intel SPMD Program Compiler"
+HOMEPAGE="http://ispc.github.com/"
+
+if [[ ${PV} = *9999 ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/ispc/ispc.git"
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/ispc/ispc/tarball/v${PV} -> ${PN}-git-${PV}.tgz"
+ GITHUB_ID="c6ec130"
+ S="${WORKDIR}/${PN}-${PN}-${GITHUB_ID}"
+fi
+
+LICENSE="BSD BSD-2 UoI-NCSA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ >=sys-devel/clang-3.0
+ >=sys-devel/llvm-3.0
+ "
+DEPEND="
+ ${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ "
+
+DOCS=( README.rst )
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}" OPT="${CXXFLAGS}" CXX="$(tc-getCXX)" CPP="$(tc-getCPP)"
+}
+
+src_install() {
+ dobin ispc
+
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ docompress -x "/usr/share/doc/${PF}/examples"
+ doins -r examples/*
+ fi
+}