summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-02-12 08:14:32 +0000
committerJustin Lecher <jlec@gentoo.org>2015-02-12 08:14:32 +0000
commitf1c1aec5145eec5a18c63c03ba17678a81cf2c26 (patch)
tree105d93c129c665254c5f55491a691aebc3c1fa4d /dev-lang/ifc
parentBump (diff)
downloadgentoo-2-f1c1aec5145eec5a18c63c03ba17678a81cf2c26.tar.gz
gentoo-2-f1c1aec5145eec5a18c63c03ba17678a81cf2c26.tar.bz2
gentoo-2-f1c1aec5145eec5a18c63c03ba17678a81cf2c26.zip
Version Bump
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-lang/ifc')
-rw-r--r--dev-lang/ifc/ChangeLog10
-rw-r--r--dev-lang/ifc/ifc-15.0.2.164.ebuild35
2 files changed, 42 insertions, 3 deletions
diff --git a/dev-lang/ifc/ChangeLog b/dev-lang/ifc/ChangeLog
index 272cf9a08c06..c4b616dd9cc6 100644
--- a/dev-lang/ifc/ChangeLog
+++ b/dev-lang/ifc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/ifc
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ifc/ChangeLog,v 1.78 2014/11/30 17:58:39 jlec Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ifc/ChangeLog,v 1.79 2015/02/12 08:14:32 jlec Exp $
+
+*ifc-15.0.2.164 (12 Feb 2015)
+
+ 12 Feb 2015; Justin Lecher <jlec@gentoo.org> +ifc-15.0.2.164.ebuild:
+ Version Bump
*ifc-15.0.1.133 (30 Nov 2014)
@@ -287,4 +292,3 @@
-ifc-7.0.064.ebuild, +ifc-9.0.021.ebuild, +ifc-9.0.026.ebuild:
Added ifc-9.0.021 (public) and ifc-9.0.026 (only available via
premier.intel.com). Removed obsolete version 7.0.064.
-
diff --git a/dev-lang/ifc/ifc-15.0.2.164.ebuild b/dev-lang/ifc/ifc-15.0.2.164.ebuild
new file mode 100644
index 000000000000..98c0b976eb5c
--- /dev/null
+++ b/dev-lang/ifc/ifc-15.0.2.164.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ifc/ifc-15.0.2.164.ebuild,v 1.1 2015/02/12 08:14:32 jlec Exp $
+
+EAPI=5
+
+INTEL_DPN=parallel_studio_xe
+INTEL_DID=5207
+INTEL_DPV=2015_update2
+INTEL_SUBDIR=composerxe
+INTEL_SINGLE_ARCH=false
+
+inherit intel-sdp
+
+DESCRIPTION="Intel FORTRAN Compiler"
+HOMEPAGE="http://software.intel.com/en-us/articles/intel-composer-xe/"
+
+IUSE="linguas_ja"
+KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="!dev-lang/ifc[linguas_jp]"
+RDEPEND="${DEPEND}
+ ~dev-libs/intel-common-${PV}[compiler,multilib=]"
+
+INTEL_BIN_RPMS="compilerprof compilerprof-devel"
+INTEL_DAT_RPMS="compilerprof-common compilerprof-vars"
+
+CHECKREQS_DISK_BUILD=375M
+
+src_install() {
+ if ! use linguas_ja; then
+ find "${S}" -type d -name ja_JP -exec rm -rf '{}' + || die
+ fi
+ intel-sdp_src_install
+}