summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam McArthur <sandymac@gentoo.org>2002-05-14 03:46:13 +0000
committerWilliam McArthur <sandymac@gentoo.org>2002-05-14 03:46:13 +0000
commit7d1b614a476a7fe3f5ef5ed4a7d2077acb178ed3 (patch)
treea0b4b1bda290c285ea5b6786e1f40c4e4d02945a /dev-lang/ifc
parentoops, sorry. backing out previous change; i want a better, generic solution ... (diff)
downloadgentoo-2-7d1b614a476a7fe3f5ef5ed4a7d2077acb178ed3.tar.gz
gentoo-2-7d1b614a476a7fe3f5ef5ed4a7d2077acb178ed3.tar.bz2
gentoo-2-7d1b614a476a7fe3f5ef5ed4a7d2077acb178ed3.zip
Add package for the Intel Fortan Compiler (ifc) and fixed a bug with the icc-6
ebuild. Also made changes to icc-6 pacakge to be more friendly with ifc since the packages are so similar.
Diffstat (limited to 'dev-lang/ifc')
-rw-r--r--dev-lang/ifc/ChangeLog14
-rw-r--r--dev-lang/ifc/files/6.0/05icc-ifc6
-rw-r--r--dev-lang/ifc/files/digest-ifc-6.01
-rw-r--r--dev-lang/ifc/ifc-6.0.ebuild88
4 files changed, 109 insertions, 0 deletions
diff --git a/dev-lang/ifc/ChangeLog b/dev-lang/ifc/ChangeLog
new file mode 100644
index 000000000000..84522e4bf2cd
--- /dev/null
+++ b/dev-lang/ifc/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for dev-lang/icc
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ifc/ChangeLog,v 1.1 2002/05/14 03:46:13 sandymac Exp $
+
+*ifc-6.0 (13 May 2002)
+
+ 13 May 2002 William McArthur <sandymac@gentoo.org> icc-6.0.ebuild :
+
+ Made some changes to Remco's work to better fit with icc-6.0. Both packages
+ are very similar and can use some of the same files.
+
+ 10 May 2002 Remco van den Bosch <bosch@muon.xs4all.nl> ifc-6.0.ebuild :
+
+ Tweaked icc ebuild to install ifc.
diff --git a/dev-lang/ifc/files/6.0/05icc-ifc b/dev-lang/ifc/files/6.0/05icc-ifc
new file mode 100644
index 000000000000..f5f50b9cc29f
--- /dev/null
+++ b/dev-lang/ifc/files/6.0/05icc-ifc
@@ -0,0 +1,6 @@
+IA32ROOT=/opt/intel/compiler60/ia32
+INTEL_FLEXLM_LICENSE=/opt/intel/licenses
+LDPATH=/opt/intel/compiler60/ia32/lib
+MANPATH=/opt/intel/compiler60/man
+PATH=/opt/intel/compiler60/ia32/bin
+ROOTPATH=/opt/intel/compiler60/ia32/bin
diff --git a/dev-lang/ifc/files/digest-ifc-6.0 b/dev-lang/ifc/files/digest-ifc-6.0
new file mode 100644
index 000000000000..037ef0017fbd
--- /dev/null
+++ b/dev-lang/ifc/files/digest-ifc-6.0
@@ -0,0 +1 @@
+MD5 7eb172e4148261373e43fda07bb7aaf7 l_fc_p_6.0.140.tar 53882880
diff --git a/dev-lang/ifc/ifc-6.0.ebuild b/dev-lang/ifc/ifc-6.0.ebuild
new file mode 100644
index 000000000000..bfd0479de55f
--- /dev/null
+++ b/dev-lang/ifc/ifc-6.0.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: William McArthur <sandymac@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ifc/ifc-6.0.ebuild,v 1.1 2002/05/14 03:46:13 sandymac Exp $
+
+S=${WORKDIR}
+
+DESCRIPTION="Intel Fortran Compiler - The Pentium optimized compiler for Linux"
+
+#RESTRICT="fetch"
+
+SRC_URI1="http://developer.intel.com/software/products/compilers/downloads/l_fc_p_6.0.140.tar"
+SRC_URI2="ftp://download.intel.com/software/products/compilers/downloads/l_fc_p_6.0.140.tar"
+SRC_URI3="ftp://download.intel.co.jp/software/products/compilers/downloads/l_fc_p_6.0.140.tar"
+SRC_URI="${SRC_URI1} ${SRC_URI2} ${SRC_URI3}"
+
+HOMEPAGE="http://www.intel.com/software/products/compilers/f60l/"
+
+# The ifc-6 license is the same copy with minimal name changes.
+LICENSE="icc-6.0"
+
+DEPEND=">=virtual/linux-sources-2.4
+ >=sys-libs/glibc-2.2.2
+ sys-apps/cpio
+ app-arch/rpm"
+
+RDEPEND=">=virtual/linux-sources-2.4
+ >=sys-libs/glibc-2.2.2"
+
+src_compile() {
+ # Keep disk space to a minimum
+ rm -f intel-*.ia64.rpm
+
+ mkdir opt
+
+ for x in intel-*.i386.rpm
+ do
+ einfo "Extracting: ${x}"
+ rpm2cpio ${x} | cpio --extract --make-directories --unconditional
+ done
+
+ # From UNTAG_CFG_FILES in 'install'
+ SD=${S}/opt/intel # Build DESTINATION
+ RD=/opt/intel # Real DESTINATION
+ for FILE in $(find $SD/compiler60/ia??/bin/ -regex '.*[ei][cf]p?c$\|.*cfg$\|.*pcl$\|.*vars[^/]*.c?sh$' 2>/dev/null)
+ do
+ sed s@\<INSTALLDIR\>@$RD@g ${FILE} > ${FILE}.abs
+ mv -f ${FILE}.abs ${FILE}
+ chmod 755 ${FILE}
+ done
+
+ # From UNTAG_SUPPORT in 'install'
+ eval `grep "^[ ]*COMBOPACKAGEID=" install`
+
+ SUPPORTFILE=${SD}/compiler60/docs/fsupport
+ sed s@\<INSTALLTIMECOMBOPACKAGEID\>@$COMBOPACKAGEID@g $SUPPORTFILE > $SUPPORTFILE.abs
+ mv $SUPPORTFILE.abs $SUPPORTFILE
+ chmod 644 $SUPPORTFILE
+
+ SUPPORTFILE=${SD}/compiler60/docs/ldbsupport
+ sed s@\<INSTALLTIMECOMBOPACKAGEID\>@$COMBOPACKAGEID@g $SUPPORTFILE > $SUPPORTFILE.abs
+ mv $SUPPORTFILE.abs $SUPPORTFILE
+ chmod 644 $SUPPORTFILE
+}
+
+src_install () {
+ dodoc lgpltext
+ dodoc flicense
+ cp -a opt ${D}
+
+ # ifc enviroment
+ insinto /etc/env.d
+ doins ${FILESDIR}/${PVR}/05icc-ifc
+}
+
+pkg_postinst () {
+ einfo
+ einfo "http://www.intel.com/software/products/compilers/f60l/f60l_noncom_lic.htm"
+ einfo "From the above url you can get a free, non-time limited, non-commercial"
+ einfo "personal use license key that comes with no support. You will need to read"
+ einfo "and agree to the license and then fill in your info to have one emailed to"
+ einfo "you. Read the website for the details."
+ einfo
+ einfo "Documentation can be found in /opt/intel/compiler60/docs/ ."
+ einfo
+ einfo "You will need to place your license in /opt/intel/licenses/ ."
+ einfo
+}