summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-10-02 13:15:03 +0000
committerJustin Lecher <jlec@gentoo.org>2013-10-02 13:15:03 +0000
commit5f8f957e9908e8ca6ee319274829070e6f1269d3 (patch)
tree1469961f584b324543255c812c5c13b00939dac1 /dev-lang/ifc/ifc-14.0.0.080.ebuild
parentStable for HPPA (bug #484032). (diff)
downloadgentoo-2-5f8f957e9908e8ca6ee319274829070e6f1269d3.tar.gz
gentoo-2-5f8f957e9908e8ca6ee319274829070e6f1269d3.tar.bz2
gentoo-2-5f8f957e9908e8ca6ee319274829070e6f1269d3.zip
dev-lang/ifc: Version Bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-lang/ifc/ifc-14.0.0.080.ebuild')
-rw-r--r--dev-lang/ifc/ifc-14.0.0.080.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-lang/ifc/ifc-14.0.0.080.ebuild b/dev-lang/ifc/ifc-14.0.0.080.ebuild
new file mode 100644
index 000000000000..dcd21517733a
--- /dev/null
+++ b/dev-lang/ifc/ifc-14.0.0.080.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ifc/ifc-14.0.0.080.ebuild,v 1.1 2013/10/02 13:15:03 jlec Exp $
+
+EAPI=5
+
+INTEL_DPN=parallel_studio_xe
+INTEL_DID=3447
+INTEL_DPV=2013_sp1
+INTEL_SUBDIR=composerxe
+INTEL_SINGLE_ARCH=false
+
+inherit intel-sdp
+
+DESCRIPTION="Intel FORTRAN Compiler"
+HOMEPAGE="http://software.intel.com/en-us/articles/intel-composer-xe/"
+
+IUSE="linguas_ja"
+KEYWORDS="-* ~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="!dev-lang/ifc[linguas_jp]"
+RDEPEND="${DEPEND}
+ ~dev-libs/intel-common-${PV}[compiler]"
+
+INTEL_BIN_RPMS="compilerprof compilerprof-devel"
+INTEL_DAT_RPMS="compilerprof-common"
+
+CHECKREQS_DISK_BUILD=375M
+
+src_install() {
+ if ! use linguas_ja; then
+ find "${S}" -type d -name ja_JP -exec rm -rf '{}' + || die
+ fi
+ intel-sdp_src_install
+}