summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2010-07-24 14:39:07 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2010-07-24 14:39:07 +0000
commitd4598e7280759cd26bac989a0abc2115fcf3376f (patch)
treef2710b6778eda628f49f4409b2a126a1e4e45e96 /dev-lang/helium
parentVersion Bump, 280332 (diff)
downloadgentoo-2-d4598e7280759cd26bac989a0abc2115fcf3376f.tar.gz
gentoo-2-d4598e7280759cd26bac989a0abc2115fcf3376f.tar.bz2
gentoo-2-d4598e7280759cd26bac989a0abc2115fcf3376f.zip
Fixed build breakage against ghc-6.8+ (bug #247044).
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/helium')
-rw-r--r--dev-lang/helium/ChangeLog8
-rw-r--r--dev-lang/helium/helium-1.6.ebuild61
2 files changed, 62 insertions, 7 deletions
diff --git a/dev-lang/helium/ChangeLog b/dev-lang/helium/ChangeLog
index 6b39014817af..f76c2ee610fc 100644
--- a/dev-lang/helium/ChangeLog
+++ b/dev-lang/helium/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/helium
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/helium/ChangeLog,v 1.23 2009/04/17 20:07:20 caster Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/helium/ChangeLog,v 1.24 2010/07/24 14:39:07 slyfox Exp $
+
+ 24 Jul 2010; Sergei Trofimovich <slyfox@gentoo.org> helium-1.6.ebuild:
+ Fixed build breakage against ghc-6.8+ (bug #247044). Thanks to Diego E.
+ 'Flameeyes' Pettenò <flameeyes@gentoo.org> for the report.
17 Apr 2009; Vlastimil Babka <caster@gentoo.org> helium-1.1,
helium-1.2-r1:
diff --git a/dev-lang/helium/helium-1.6.ebuild b/dev-lang/helium/helium-1.6.ebuild
index 091e7b4feb01..3052414354a5 100644
--- a/dev-lang/helium/helium-1.6.ebuild
+++ b/dev-lang/helium/helium-1.6.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/helium/helium-1.6.ebuild,v 1.2 2007/10/31 13:22:01 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/helium/helium-1.6.ebuild,v 1.3 2010/07/24 14:39:07 slyfox Exp $
-inherit eutils
+inherit autotools eutils
DESCRIPTION="Helium (for learning Haskell)"
HOMEPAGE="http://www.cs.uu.nl/helium"
@@ -15,14 +15,65 @@ SLOT="0"
KEYWORDS="-amd64 ~ppc -sparc ~x86"
IUSE="readline"
-DEPEND=">=dev-lang/ghc-6.4.2
- readline? ( sys-libs/readline )"
+DEPEND=">=dev-lang/ghc-6.8
+ dev-haskell/mtl
+ dev-haskell/parsec
+ readline? ( dev-haskell/readline )"
RDEPEND="dev-libs/gmp
readline? ( sys-libs/readline )"
src_unpack() {
unpack ${A}
epatch "${P}-ghc.patch"
+
+ # split base only
+ sed -e 's/^GHCFLAGS =.*$/& -package containers/' \
+ -i "${S}/helium/src/Makefile.in"
+
+ # file has non-ASCII syms and it's pulled to ghc for dependency generaton
+ # ghc w/UTF-8 dislikes it:
+ sed -e 's/\xCA//g' \
+ -i "${S}/helium/src/Makefile.in"
+
+ # mangle evil 'rec' to 'rec_'. It's not very accurate, but less,
+ # than manually patching ~250 occurences. (ghc-6.10+ has rec as reserved word)
+ local bad_file
+
+ for bad_file in Top/src/Top/Types/Unification.hs \
+ Top/src/Top/Types/Quantification.hs \
+ Top/src/Top/Types/Primitive.hs \
+ Top/src/Top/Solver/PartitionCombinator.hs \
+ Top/src/Top/Repair/Repair.hs \
+ Top/src/Top/Ordering/Tree.hs \
+ Top/src/Top/Implementation/TypeGraph/Standard.hs \
+ Top/src/Top/Implementation/TypeGraph/Path.hs \
+ Top/src/Top/Implementation/TypeGraph/EquivalenceGroup.hs \
+ Top/src/Top/Implementation/TypeGraph/Basics.hs \
+ Top/src/Top/Implementation/TypeGraph/ApplyHeuristics.hs \
+ lvm/src/lib/lvm/LvmRead.hs \
+ lvm/src/lib/core/CoreNoShadow.hs \
+ helium/src/utils/LoggerEnabled.hs \
+ helium/src/staticanalysis/miscellaneous/TypesToAlignedDocs.hs \
+ helium/src/staticanalysis/miscellaneous/TypeConversion.hs \
+ helium/src/staticanalysis/inferencers/TypeInferencing.hs \
+ helium/src/staticanalysis/heuristics/RepairSystem.hs \
+ helium/src/staticanalysis/heuristics/RepairHeuristics.hs \
+ helium/src/staticanalysis/heuristics/ListOfHeuristics.hs \
+ helium/src/staticanalysis/directives/TS_PatternMatching.ag
+ do
+ # take all symbols from exactly this source. This set is not universal,
+ # but it aims to catch (same) lexeme separators on the left and on the right
+ sed -e 's/\([^a-zA-Z_0-9"]\|^\)rec\([^a-zA-Z_0-9"]\|$\)/\1rec_\2/g' \
+ -i "${S}/$bad_file"
+ done
+
+ # cabal is their friend (oneOf bwcame polymorphic and breaks the test)
+ sed -e 's/Text.ParserCombinators.Parsec/&.Pos/g' \
+ -e 's/oneOf/newPos/g' \
+ -i "${S}/helium/configure.in"
+
+ cd "${S}/helium"
+ eautoreconf
}
src_compile() {