summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2010-05-06 15:50:59 +0000
committerVictor Ostorga <vostorga@gentoo.org>2010-05-06 15:50:59 +0000
commit7c4a98f105e26b9b6fa83419425ab78ed9f02d26 (patch)
tree3521420d3eecec4e013f46afdba8edff5abe4a93 /dev-lang/gnu-smalltalk
parentVersion bump (diff)
downloadgentoo-2-7c4a98f105e26b9b6fa83419425ab78ed9f02d26.tar.gz
gentoo-2-7c4a98f105e26b9b6fa83419425ab78ed9f02d26.tar.bz2
gentoo-2-7c4a98f105e26b9b6fa83419425ab78ed9f02d26.zip
Version bump, using econf in place of ./configure, fixes bundled copies of libltdl bug 277089
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'dev-lang/gnu-smalltalk')
-rw-r--r--dev-lang/gnu-smalltalk/ChangeLog9
-rw-r--r--dev-lang/gnu-smalltalk/gnu-smalltalk-3.2.ebuild64
2 files changed, 72 insertions, 1 deletions
diff --git a/dev-lang/gnu-smalltalk/ChangeLog b/dev-lang/gnu-smalltalk/ChangeLog
index 9d1b0d149b67..859f9c52ec9f 100644
--- a/dev-lang/gnu-smalltalk/ChangeLog
+++ b/dev-lang/gnu-smalltalk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/gnu-smalltalk
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/ChangeLog,v 1.40 2010/01/04 04:55:54 araujo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/ChangeLog,v 1.41 2010/05/06 15:50:59 vostorga Exp $
+
+*gnu-smalltalk-3.2 (06 May 2010)
+
+ 06 May 2010; Víctor Ostorga <vostorga@gentoo.org>
+ +gnu-smalltalk-3.2.ebuild:
+ Version bump, using econf in place of ./configure, fixes bundled copies of
+ libltdl bug 277089
*gnu-smalltalk-3.1 (04 Jan 2010)
diff --git a/dev-lang/gnu-smalltalk/gnu-smalltalk-3.2.ebuild b/dev-lang/gnu-smalltalk/gnu-smalltalk-3.2.ebuild
new file mode 100644
index 000000000000..5e6cfd90a2d6
--- /dev/null
+++ b/dev-lang/gnu-smalltalk/gnu-smalltalk-3.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/gnu-smalltalk-3.2.ebuild,v 1.1 2010/05/06 15:50:59 vostorga Exp $
+
+inherit elisp-common flag-o-matic eutils
+
+DESCRIPTION="GNU Smalltalk"
+HOMEPAGE="http://smalltalk.gnu.org"
+SRC_URI="http://ftp.gnu.org/gnu/smalltalk/smalltalk-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="tk readline emacs gtk gmp"
+
+DEPEND="sys-libs/gdbm
+ sys-apps/debianutils
+ dev-libs/libsigsegv
+ virtual/libffi
+ emacs? ( virtual/emacs )
+ readline? ( sys-libs/readline )
+ tk? ( dev-lang/tk )
+ gtk? ( =x11-libs/gtk+-2* )
+ gmp? ( dev-libs/gmp )"
+RDEPEND=""
+
+S="${WORKDIR}/smalltalk-${PV}"
+
+SITEFILE=50gnu-smalltalk-gentoo.el
+
+src_compile() {
+ replace-flags '-O3' '-O2'
+ econf \
+ --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ --with-system-libsigsegv \
+ --with-system-libffi \
+ --with-system-libltdl \
+ $(use_with emacs emacs) \
+ $(use_with readline readline) \
+ $(use_with gmp gmp) \
+ $(use_with tk tcl /usr/$(get_libdir)) \
+ $(use_with tk tk /usr/$(get_libdir)) \
+ $(use_enable gtk gtk)
+ emake || die "emake failed"
+ use emacs && elisp-compile *.el
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS COPYING* ChangeLog NEWS README THANKS TODO
+ if use emacs; then
+ elisp-install "${PN}" *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+ fperms 0444 /usr/share/smalltalk/packages.xml
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}