summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2008-04-21 15:27:56 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2008-04-21 15:27:56 +0000
commit6415807a98343aed30602521841c711810785a03 (patch)
treea7e727839f952aaa9d71565d3441a16ad8296521 /dev-lang/gnu-smalltalk
parentAdd ~sparc (diff)
downloadgentoo-2-6415807a98343aed30602521841c711810785a03.tar.gz
gentoo-2-6415807a98343aed30602521841c711810785a03.tar.bz2
gentoo-2-6415807a98343aed30602521841c711810785a03.zip
Adding new release. Fixing bugs #217777 and #217508
(Portage version: 2.1.5_rc5)
Diffstat (limited to 'dev-lang/gnu-smalltalk')
-rw-r--r--dev-lang/gnu-smalltalk/ChangeLog8
-rw-r--r--dev-lang/gnu-smalltalk/gnu-smalltalk-3.0.2.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/dev-lang/gnu-smalltalk/ChangeLog b/dev-lang/gnu-smalltalk/ChangeLog
index c6cc7456f3a7..ea1327f29416 100644
--- a/dev-lang/gnu-smalltalk/ChangeLog
+++ b/dev-lang/gnu-smalltalk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/gnu-smalltalk
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/ChangeLog,v 1.36 2008/04/08 08:07:01 araujo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/ChangeLog,v 1.37 2008/04/21 15:27:56 araujo Exp $
+
+*gnu-smalltalk-3.0.2 (21 Apr 2008)
+
+ 21 Apr 2008; Luis F. Araujo <araujo@gentoo.org>
+ +gnu-smalltalk-3.0.2.ebuild:
+ Adding new release and fixing bugs #217777 and #217508
*gnu-smalltalk-3.0.1-r1 (08 Apr 2008)
diff --git a/dev-lang/gnu-smalltalk/gnu-smalltalk-3.0.2.ebuild b/dev-lang/gnu-smalltalk/gnu-smalltalk-3.0.2.ebuild
new file mode 100644
index 000000000000..6670a249abd1
--- /dev/null
+++ b/dev-lang/gnu-smalltalk/gnu-smalltalk-3.0.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnu-smalltalk/gnu-smalltalk-3.0.2.ebuild,v 1.1 2008/04/21 15:27:56 araujo Exp $
+
+inherit elisp-common flag-o-matic eutils
+
+DESCRIPTION="GNU Smalltalk"
+HOMEPAGE="http://smalltalk.gnu.org"
+SRC_URI="http://ftp.gnu.org/gnu/smalltalk/smalltalk-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="tk readline emacs gtk gmp"
+
+DEPEND="sys-libs/gdbm
+ sys-apps/debianutils
+ dev-libs/libsigsegv
+ emacs? ( virtual/emacs )
+ readline? ( sys-libs/readline )
+ tk? ( dev-lang/tk )
+ gtk? ( =x11-libs/gtk+-2* )
+ gmp? ( dev-libs/gmp )"
+RDEPEND=""
+
+S="${WORKDIR}/smalltalk-${PV}"
+
+SITEFILE=50gnu-smalltalk-gentoo.el
+
+src_compile() {
+ replace-flags '-O3' '-O2'
+ ./configure --prefix=/usr \
+ `use_with emacs emacs` \
+ `use_with readline readline` \
+ `use_with gmp gmp` \
+ `use_with tk tcl /usr/lib` \
+ `use_with tk tk /usr/lib` \
+ `use_enable gtk gtk` \
+ || die
+ emake || die "emake failed"
+ use emacs && elisp-compile *.el
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ # Remove libsigsegv
+ rm -rf "${D}/usr/include/sigsegv.h" \
+ "${D}/usr/include/snprintfv" \
+ "${D}/usr/share/aclocal/snprintfv.m4"
+ rm "${D}"/usr/lib/libsigsegv*
+ dodoc AUTHORS COPYING* ChangeLog NEWS README THANKS TODO
+ if use emacs; then
+ elisp-install "${PN}" *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+ fperms 0444 /usr/share/smalltalk/packages.xml
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}