summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2008-02-15 21:47:52 +0000
committerGeorge Shapovalov <george@gentoo.org>2008-02-15 21:47:52 +0000
commit5ad0b502acf13eeb9d054ef5fc291e715f6dfc4b (patch)
treeac6c517fc6098e4820d54cf956393169f1ceae7c /dev-lang/gnat-gcc
parentStable on ppc wrt bug 210197 (diff)
downloadgentoo-2-5ad0b502acf13eeb9d054ef5fc291e715f6dfc4b.tar.gz
gentoo-2-5ad0b502acf13eeb9d054ef5fc291e715f6dfc4b.tar.bz2
gentoo-2-5ad0b502acf13eeb9d054ef5fc291e715f6dfc4b.zip
added the 4.3 snapshot in preparison for release
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-lang/gnat-gcc')
-rw-r--r--dev-lang/gnat-gcc/ChangeLog8
-rw-r--r--dev-lang/gnat-gcc/gnat-gcc-4.3_pre20080208.ebuild70
2 files changed, 77 insertions, 1 deletions
diff --git a/dev-lang/gnat-gcc/ChangeLog b/dev-lang/gnat-gcc/ChangeLog
index 50e86bc5fada..f6c6931df32f 100644
--- a/dev-lang/gnat-gcc/ChangeLog
+++ b/dev-lang/gnat-gcc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/gnat-gcc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/ChangeLog,v 1.21 2008/02/10 21:10:44 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/ChangeLog,v 1.22 2008/02/15 21:47:52 george Exp $
+
+*gnat-gcc-4.3_pre20080208 (15 Feb 2008)
+
+ 15 Feb 2008; George Shapovalov <george@gentoo.org>
+ +gnat-gcc-4.3_pre20080208.ebuild:
+ added the 4.3 snapshot in preparison for release
10 Feb 2008; Markus Meier <maekke@gentoo.org> gnat-gcc-3.4.6.ebuild:
x86 stable, bug #209000
diff --git a/dev-lang/gnat-gcc/gnat-gcc-4.3_pre20080208.ebuild b/dev-lang/gnat-gcc/gnat-gcc-4.3_pre20080208.ebuild
new file mode 100644
index 000000000000..77e25faa1eb1
--- /dev/null
+++ b/dev-lang/gnat-gcc/gnat-gcc-4.3_pre20080208.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/gnat-gcc-4.3_pre20080208.ebuild,v 1.1 2008/02/15 21:47:52 george Exp $
+
+inherit versionator
+
+# GCCVER should be set before inherit
+Issue="$(get_version_component_range 3)"
+GCCVER="$(get_version_component_range 1-2)-${Issue:3}"
+
+inherit gnatbuild
+
+DESCRIPTION="GNAT Ada Compiler - gcc version"
+HOMEPAGE="http://gcc.gnu.org/"
+LICENSE="GMGPL"
+
+# overriding the BOOT_SLOT, as 4.1 should do fine, no need for bootstrap duplication
+BOOT_SLOT="4.1"
+
+# SLOT is set in gnatbuild.eclass, depends only on PV (basically SLOT=GCCBRANCH)
+# so the URI's are static.
+SRC_URI="ftp://gcc.gnu.org/pub/gcc/snapshots/${GCCVER}/gcc-core-${GCCVER}.tar.bz2
+ ftp://gcc.gnu.org/pub/gcc/snapshots/${GCCVER}/gcc-ada-${GCCVER}.tar.bz2
+ ppc? ( mirror://gentoo/gnatboot-${BOOT_SLOT}-ppc.tar.bz2 )
+ x86? ( mirror://gentoo/gnatboot-${BOOT_SLOT}-i386.tar.bz2 )
+ amd64? ( mirror://gentoo/gnatboot-${BOOT_SLOT}-amd64.tar.bz2 )"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+QA_EXECSTACK="${BINPATH:1}/gnatls ${BINPATH:1}/gnatbind ${BINPATH:1}/gnatmake
+ ${LIBEXECPATH:1}/gnat1 ${LIBPATH:1}/adalib/libgnat-${SLOT}.so"
+
+src_unpack() {
+ gnatbuild_src_unpack
+
+ #fixup some hardwired flags
+ cd "${S}"/gcc/ada
+
+ # universal gcc -> gnatgcc substitution occasionally produces lines too long
+ # and then build halts on the style check.
+ #
+ # The sed in makegpr.adb is actually not for the line length but rather to
+ # "undo" the fixing, Last3 is matching just that - the last three characters
+ # of the compiler name.
+ sed -i -e 's:(Last3 = "gnatgcc"):(Last3 = "gcc"):' makegpr.adb &&
+ sed -i -e 's:and Nam is "gnatgcc":and Nam is "gcc":' osint.ads ||
+ die "reversing [gnat]gcc substitution in comments failed"
+
+ # All snapshots seem to have a problem compiling with all the
+ # extra versioning declarations. Cleanup some vars..
+ sed -i -e "/-DREVISION/d" -e "/-DDEVPHASE/d" \
+ -e "s: -DDATESTAMP=\$(DATESTAMP_s)::" "${S}"/gcc/Makefile.in
+# -e "s:-DBUGURL=\$(BUGURL_s) ::"
+ sed -i -e "s: DATESTAMP DEVPHASE REVISION::" \
+ -e "s:PKGVERSION:\"4.3.0\":" "${S}"/gcc/version.c
+}
+
+src_compile() {
+ # looks like gnatlib_and_tools and gnatlib_shared have become part of
+ # bootstrap
+ gnatbuild_src_compile configure make-tools bootstrap
+}
+
+
+src_install() {
+# echo "contents of ${LIBEXECPATH}/gcc/${CTARGET}/${GCCRELEASE} :"
+# ls "${D}${LIBEXECPATH}/gcc/${CTARGET}/${GCCRELEASE}"
+# die
+ GCCVER="4.3.0" GCCRELEASE="4.3.0" gnatbuild_src_install
+}