summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2013-11-14 07:22:24 +0000
committerSteve Arnold <nerdboy@gentoo.org>2013-11-14 07:22:24 +0000
commit8071fd47286881d87815e378c5ac2373f1524c53 (patch)
tree1013cecefd4b416739f37b3d2bce88d86ff1730b /dev-lang/gnat-gcc/gnat-gcc-4.6.4.ebuild
parentalpha stable, bug 476364. (diff)
downloadgentoo-2-8071fd47286881d87815e378c5ac2373f1524c53.tar.gz
gentoo-2-8071fd47286881d87815e378c5ac2373f1524c53.tar.bz2
gentoo-2-8071fd47286881d87815e378c5ac2373f1524c53.zip
Added 4.6.4 ebuild (but no fixing of the older ones yet).
(Portage version: 2.2.7/cvs/Linux x86_64, RepoMan options: --ignore-arches, signed Manifest commit with key )
Diffstat (limited to 'dev-lang/gnat-gcc/gnat-gcc-4.6.4.ebuild')
-rw-r--r--dev-lang/gnat-gcc/gnat-gcc-4.6.4.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-lang/gnat-gcc/gnat-gcc-4.6.4.ebuild b/dev-lang/gnat-gcc/gnat-gcc-4.6.4.ebuild
new file mode 100644
index 000000000000..c7953d788038
--- /dev/null
+++ b/dev-lang/gnat-gcc/gnat-gcc-4.6.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/gnat-gcc-4.6.4.ebuild,v 1.1 2013/11/14 07:22:24 nerdboy Exp $
+
+inherit gnatbuild
+
+DESCRIPTION="GNAT Ada Compiler - gcc version"
+HOMEPAGE="http://gcc.gnu.org/"
+LICENSE="GMGPL"
+
+IUSE="lto"
+
+BOOT_SLOT="4.4"
+
+# SLOT is set in gnatbuild.eclass, depends only on PV (basically SLOT=GCCBRANCH)
+# so the URI's are static.
+SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-core-${PV}.tar.bz2
+ ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-ada-${PV}.tar.bz2
+ amd64? ( http://dev.gentoo.org/~george/src/gnatboot-${BOOT_SLOT}-amd64.tar.bz2 )
+ sparc? ( http://dev.gentoo.org/~george/src/gnatboot-${BOOT_SLOT}-sparc.tar.bz2 )
+ x86? ( http://dev.gentoo.org/~george/src/gnatboot-${BOOT_SLOT}-i686.tar.bz2 )"
+# ppc? ( mirror://gentoo/gnatboot-${BOOT_SLOT}-ppc.tar.bz2 )
+
+KEYWORDS="~amd64 ~x86 ~sparc"
+
+# starting with 4.3.0 gnat needs these libs
+RDEPEND=">=dev-libs/mpfr-3.1.2
+ >=dev-libs/gmp-5.1.3
+ >=dev-libs/mpc-1.0.1
+ >=sys-libs/zlib-1.2
+ >=sys-libs/ncurses-5.7"
+
+DEPEND="${RDEPEND}
+ <sys-apps/texinfo-5.1
+ >=sys-devel/bison-1.875
+ >=sys-libs/glibc-2.8
+ >=sys-devel/binutils-2.20"
+
+src_unpack() {
+ gnatbuild_src_unpack
+
+ #fixup some hardwired flags
+ cd "${S}"/gcc/ada
+
+ # universal gcc -> gnatgcc substitution occasionally produces lines too long
+ # and then build halts on the style check.
+ #
+ sed -i -e 's:gnatgcc:gcc:' osint.ads switch.ads ||
+ die "reversing [gnat]gcc substitution in comments failed"
+
+ # gcc pretty much ignores --with-system-zlib. At least it still descends
+ # into zlib and does configure and build there (gcc bug@7125?). For whatever
+ # reason this conflicts with multilib in gcc-4.4..
+ sed -i -e "s:libgui zlib:libgui:" "${S}"/configure
+}
+
+src_compile() {
+ # looks like gnatlib_and_tools and gnatlib_shared have become part of
+ # bootstrap
+ gnatbuild_src_compile configure make-tools bootstrap
+}