summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Parrott <cparrott@gentoo.org>2006-05-07 15:09:42 +0000
committerChris Parrott <cparrott@gentoo.org>2006-05-07 15:09:42 +0000
commitfcd14da731055ae5f82b94faeb2790332d45332e (patch)
treed786aa7028c771f0155b0881674e2854fb8aab24 /dev-lang/ghc
parentFix digests. (diff)
downloadgentoo-2-fcd14da731055ae5f82b94faeb2790332d45332e.tar.gz
gentoo-2-fcd14da731055ae5f82b94faeb2790332d45332e.tar.bz2
gentoo-2-fcd14da731055ae5f82b94faeb2790332d45332e.zip
temporarily removed openal USE flag from ebuild, pending resolution of broken OpenAL binding.
(Portage version: 2.1_pre10-r3)
Diffstat (limited to 'dev-lang/ghc')
-rw-r--r--dev-lang/ghc/ChangeLog5
-rw-r--r--dev-lang/ghc/ghc-6.4.2.ebuild11
2 files changed, 10 insertions, 6 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index 257bcdb258be..7e75984e3385 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/ghc
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.99 2006/05/03 23:05:28 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.100 2006/05/07 15:09:42 cparrott Exp $
+
+ 05 May 2006; Chris Parrott <cparrott@gentoo.org> ghc-6.4.2.ebuild:
+ Temporarily disabled openal USE flag, pending fix to openal bindings.
03 May 2006; Duncan Coutts <dcoutts@gentoo.org> ghc-6.4.1-r3.ebuild,
ghc-6.4.2.ebuild:
diff --git a/dev-lang/ghc/ghc-6.4.2.ebuild b/dev-lang/ghc/ghc-6.4.2.ebuild
index 05e9b1a022ef..3a3c6819e9a6 100644
--- a/dev-lang/ghc/ghc-6.4.2.ebuild
+++ b/dev-lang/ghc/ghc-6.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.4.2.ebuild,v 1.2 2006/05/03 23:05:28 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.4.2.ebuild,v 1.3 2006/05/07 15:09:42 cparrott Exp $
# Brief explanation of the bootstrap logic:
#
@@ -32,20 +32,20 @@ SRC_URI="http://www.haskell.org/ghc/dist/${EXTRA_SRC_URI}/${MY_P}-src.tar.bz2
LICENSE="as-is"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="test doc X opengl openal"
+IUSE="test doc X opengl" # openal temporarily disabled pending fix
S="${WORKDIR}/${MY_P}"
PROVIDE="virtual/ghc"
+# openal temporarily disabled pending fix
RDEPEND="
>=sys-devel/gcc-2.95.3
>=dev-lang/perl-5.6.1
>=dev-libs/gmp-4.1
>=sys-libs/readline-4.2
X? ( || ( x11-libs/libX11 virtual/x11 ) )
- opengl? ( virtual/opengl virtual/glu virtual/glut )
- openal? ( media-libs/openal )"
+ opengl? ( virtual/opengl virtual/glu virtual/glut )"
# ghc cannot usually be bootstrapped using later versions ...
DEPEND="${RDEPEND}
@@ -186,10 +186,11 @@ src_compile() {
echo "SplitObjs=NO" >> mk/build.mk
fi
+ # openal temporarily disabled pending fix
econf \
$(use_enable opengl opengl) \
$(use_enable opengl glut) \
- $(use_enable openal openal) \
+ --disable-openal \
--disable-alut \
$(use_enable X x11) \
$(use_enable X hgl) \