summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-09-29 18:22:25 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-09-29 18:22:25 +0000
commitd9dab1198bf5f91f92637e15de7acd5bf0d02b26 (patch)
treeb94b7ce6da080439241802991d0801aeaf38e183 /dev-lang/ghc
parentVersion bump. (diff)
downloadgentoo-2-d9dab1198bf5f91f92637e15de7acd5bf0d02b26.tar.gz
gentoo-2-d9dab1198bf5f91f92637e15de7acd5bf0d02b26.tar.bz2
gentoo-2-d9dab1198bf5f91f92637e15de7acd5bf0d02b26.zip
Disable ghci linker hack on x86-hardened (bug #486140 by Anton Kochkov).
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-lang/ghc')
-rw-r--r--dev-lang/ghc/ChangeLog5
-rw-r--r--dev-lang/ghc/ghc-7.6.3-r1.ebuild7
2 files changed, 10 insertions, 2 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index e8fa2581517c..12b8d4d505b7 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/ghc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.250 2013/09/22 06:44:22 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.251 2013/09/29 18:22:25 slyfox Exp $
+
+ 29 Sep 2013; Sergei Trofimovich <slyfox@gentoo.org> ghc-7.6.3-r1.ebuild:
+ Disable ghci linker hack on x86-hardened (bug #486140 by Anton Kochkov).
22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> ghc-7.6.3-r1.ebuild:
Stable for x86, wrt bug #483462
diff --git a/dev-lang/ghc/ghc-7.6.3-r1.ebuild b/dev-lang/ghc/ghc-7.6.3-r1.ebuild
index 322295b185e0..72103d81d293 100644
--- a/dev-lang/ghc/ghc-7.6.3-r1.ebuild
+++ b/dev-lang/ghc/ghc-7.6.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.6.3-r1.ebuild,v 1.6 2013/09/22 06:44:22 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.6.3-r1.ebuild,v 1.7 2013/09/29 18:22:25 slyfox Exp $
# Brief explanation of the bootstrap logic:
#
@@ -622,6 +622,11 @@ add-c_nonshared-to-ghci-libs() {
is_crosscompile && return
use elibc_glibc || return
+ # we expect 'libc.a' bits be self-sufficient
+ if gcc-specs-pie; then
+ use x86 && return # but on x86 pie means linker support: #486140
+ fi
+
get-nonshared-objects() {
# ns - 'nonshared'
local ns_objects=" "