summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2014-07-05 15:40:40 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2014-07-05 15:40:40 +0000
commit82e5a5fe1a33644f3b706308db652391b285708e (patch)
tree03c52ea3b7043a6693455de2ce05b9453b672503 /dev-lang/ghc
parentExport CC. Make CC calls verbose. Drop -O3. (diff)
downloadgentoo-2-82e5a5fe1a33644f3b706308db652391b285708e.tar.gz
gentoo-2-82e5a5fe1a33644f3b706308db652391b285708e.tar.bz2
gentoo-2-82e5a5fe1a33644f3b706308db652391b285708e.zip
pax-mark ghc-stage2 before it's used first time. Fixes bootstrap failure on hardened (bug #516430 by Markus Oehme).
(Portage version: 2.2.10_p15/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-lang/ghc')
-rw-r--r--dev-lang/ghc/ChangeLog6
-rw-r--r--dev-lang/ghc/ghc-7.6.3-r1.ebuild11
2 files changed, 13 insertions, 4 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index 4bdcc5868423..4e3fd235ada1 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ghc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.256 2014/06/27 09:54:02 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.257 2014/07/05 15:40:40 slyfox Exp $
+
+ 05 Jul 2014; Sergei Trofimovich <slyfox@gentoo.org> ghc-7.6.3-r1.ebuild:
+ pax-mark ghc-stage2 before it's used first time. Fixes bootstrap failure on
+ hardened (bug #516430 by Markus Oehme).
27 Jun 2014; Sergei Trofimovich <slyfox@gentoo.org> ghc-7.6.3-r1.ebuild:
Ignore flags '--with-compiler/--with-gcc' passed by cabal with
diff --git a/dev-lang/ghc/ghc-7.6.3-r1.ebuild b/dev-lang/ghc/ghc-7.6.3-r1.ebuild
index d2fd97b8b7cc..56f8302fcd95 100644
--- a/dev-lang/ghc/ghc-7.6.3-r1.ebuild
+++ b/dev-lang/ghc/ghc-7.6.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.6.3-r1.ebuild,v 1.11 2014/06/27 09:54:02 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.6.3-r1.ebuild,v 1.12 2014/07/05 15:40:40 slyfox Exp $
# Brief explanation of the bootstrap logic:
#
@@ -603,8 +603,13 @@ src_compile() {
# ghc massively parallel make: #409631, #409873
# but let users screw it by setting 'I_DEMAND_MY_CORES_LOADED'
# 4 parallel jobs usually does not break
- emake $(limit_jobs 4) all
- emake all V=1
+
+ # 1. build compiler binary(+wrapper) first
+ emake $(limit_jobs 4) inplace/bin/ghc-stage2 V=1
+ # 2. pax-mark (bug #516430)
+ pax-mark -m inplace/lib/ghc-stage2
+ # 3. and then all the rest
+ emake $(limit_jobs 4) all V=1
if is_crosscompile; then
# runghc does not work for a stage1 compiler, we can build it anyway