summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2010-07-07 22:18:58 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2010-07-07 22:18:58 +0000
commit78c0b0f39ef3c5769a2fbf522125c658f18109aa (patch)
tree2f4d377d7fa5e110713bd1007c054f494a655c2f /dev-lang/ghc
parentVersion bump (diff)
downloadgentoo-2-78c0b0f39ef3c5769a2fbf522125c658f18109aa.tar.gz
gentoo-2-78c0b0f39ef3c5769a2fbf522125c658f18109aa.tar.bz2
gentoo-2-78c0b0f39ef3c5769a2fbf522125c658f18109aa.zip
added alpha binary for ghc-{6.10.4-r1,6.12.3}
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/ghc')
-rw-r--r--dev-lang/ghc/ChangeLog10
-rw-r--r--dev-lang/ghc/files/ghc-6.12.3-alpha-use-libffi-for-foreign-import-wrapper.patch68
-rw-r--r--dev-lang/ghc/ghc-6.10.4-r1.ebuild5
-rw-r--r--dev-lang/ghc/ghc-6.10.4.ebuild314
-rw-r--r--dev-lang/ghc/ghc-6.12.3.ebuild8
5 files changed, 86 insertions, 319 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index e22e59e3e4f8..4f321297de08 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-lang/ghc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.180 2010/07/01 20:27:50 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.181 2010/07/07 22:18:57 slyfox Exp $
+
+ 07 Jul 2010; Sergei Trofimovich <slyfox@gentoo.org> -ghc-6.10.4.ebuild,
+ ghc-6.10.4-r1.ebuild, ghc-6.12.3.ebuild,
+ +files/ghc-6.12.3-alpha-use-libffi-for-foreign-import-wrapper.patch:
+ Added alpha binary for ghc-6.10.4-r1 (thanks to Martin Rosenberg
+ <mjrosenb@andrew.cmu.edu>);
+ added alpha binary for ghc-6.12.3, removed old ghc-6.10.4 in favour of
+ -r1.
01 Jul 2010; Jeroen Roovers <jer@gentoo.org> ghc-6.4.2.ebuild,
ghc-6.6.ebuild, ghc-6.6.1.ebuild, ghc-6.8.2.ebuild, ghc-6.8.2-r1.ebuild,
diff --git a/dev-lang/ghc/files/ghc-6.12.3-alpha-use-libffi-for-foreign-import-wrapper.patch b/dev-lang/ghc/files/ghc-6.12.3-alpha-use-libffi-for-foreign-import-wrapper.patch
new file mode 100644
index 000000000000..4df29fdaee61
--- /dev/null
+++ b/dev-lang/ghc/files/ghc-6.12.3-alpha-use-libffi-for-foreign-import-wrapper.patch
@@ -0,0 +1,68 @@
+diff --git a/compiler/typecheck/TcForeign.lhs b/compiler/typecheck/TcForeign.lhs
+index 073ca25..75e42ef 100644
+--- a/compiler/typecheck/TcForeign.lhs
++++ b/compiler/typecheck/TcForeign.lhs
+@@ -30,10 +30,6 @@ import TcEnv
+ import ForeignCall
+ import ErrUtils
+ import Id
+-#if alpha_TARGET_ARCH
+-import Type
+-import SMRep
+-#endif
+ import Name
+ import TcType
+ import DynFlags
+@@ -113,7 +109,6 @@ tcCheckFIType sig_ty arg_tys res_ty idecl@(CImport cconv safety _ CWrapper) = do
+ [arg1_ty] -> do checkForeignArgs isFFIExternalTy arg1_tys
+ checkForeignRes nonIOok isFFIExportResultTy res1_ty
+ checkForeignRes mustBeIO isFFIDynResultTy res_ty
+- checkFEDArgs arg1_tys
+ where
+ (arg1_tys, res1_ty) = tcSplitFunTys arg1_ty
+ _ -> addErrTc (illegalForeignTyErr empty sig_ty)
+@@ -175,31 +170,6 @@ checkMissingAmpersand dflags arg_tys res_ty
+ = return ()
+ \end{code}
+
+-On an Alpha, with foreign export dynamic, due to a giant hack when
+-building adjustor thunks, we only allow 4 integer arguments with
+-foreign export dynamic (i.e., 32 bytes of arguments after padding each
+-argument to a quadword, excluding floating-point arguments).
+-
+-The check is needed for both via-C and native-code routes
+-
+-\begin{code}
+-#include "nativeGen/NCG.h"
+-
+-checkFEDArgs :: [Type] -> TcM ()
+-#if alpha_TARGET_ARCH
+-checkFEDArgs arg_tys
+- = check (integral_args <= 32) err
+- where
+- integral_args = sum [ (widthInBytes . argMachRep . primRepToCgRep) prim_rep
+- | prim_rep <- map typePrimRep arg_tys,
+- primRepHint prim_rep /= FloatHint ]
+- err = ptext (sLit "On Alpha, I can only handle 32 bytes of non-floating-point arguments to foreign export dynamic")
+-#else
+-checkFEDArgs _ = return ()
+-#endif
+-\end{code}
+-
+-
+ %************************************************************************
+ %* *
+ \subsection{Exports}
+diff --git a/mk/config.mk.in b/mk/config.mk.in
+index 7399de0..a9e875c 100644
+--- a/mk/config.mk.in
++++ b/mk/config.mk.in
+@@ -176,7 +176,7 @@ endif
+ # Whether to use libffi for adjustors (foreign import "wrapper") or
+ # not. If we have built-in support (rts/Adjustor.c) then we use that,
+ # otherwise we fall back on libffi, which is slightly slower.
+-ArchHasAdjustorSupport=$(strip $(if $(findstring $(HostArch_CPP),i386 x86_64 alpha powerpc ia64,),YES,NO))
++ArchHasAdjustorSupport=$(strip $(if $(findstring $(HostArch_CPP),i386 x86_64 powerpc ia64,),YES,NO))
+ ifeq "$(ArchHasAdjustorSupport)" "YES"
+ UseLibFFIForAdjustors=NO
+ else
diff --git a/dev-lang/ghc/ghc-6.10.4-r1.ebuild b/dev-lang/ghc/ghc-6.10.4-r1.ebuild
index f16e2d423e25..1a238f495e1b 100644
--- a/dev-lang/ghc/ghc-6.10.4-r1.ebuild
+++ b/dev-lang/ghc/ghc-6.10.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.10.4-r1.ebuild,v 1.5 2010/07/01 20:27:50 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.10.4-r1.ebuild,v 1.6 2010/07/07 22:18:57 slyfox Exp $
# Brief explanation of the bootstrap logic:
#
@@ -40,6 +40,7 @@ EXTRA_SRC_URI="${PV}"
arch_binaries=""
+arch_binaries="$arch_binaries alpha? ( http://code.haskell.org/~ivanm/ghc-bin-${PV}-alpha.tbz2 )"
arch_binaries="$arch_binaries x86? ( http://code.haskell.org/~ivanm/ghc-bin-${PV}-x86.tbz2 )"
arch_binaries="$arch_binaries amd64? ( http://haskell.org/~kolmodin/ghc-bin-${PV}-amd64.tbz2 )"
arch_binaries="$arch_binaries sparc? ( http://haskell.org/~duncan/ghc/ghc-bin-${PV}-sparc.tbz2 )"
@@ -57,7 +58,7 @@ SRC_URI="!binary? ( http://haskell.org/ghc/dist/${EXTRA_SRC_URI}/${P}-src.tar.bz
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="binary doc ghcbootstrap"
RDEPEND="
diff --git a/dev-lang/ghc/ghc-6.10.4.ebuild b/dev-lang/ghc/ghc-6.10.4.ebuild
deleted file mode 100644
index 492f299062e6..000000000000
--- a/dev-lang/ghc/ghc-6.10.4.ebuild
+++ /dev/null
@@ -1,314 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.10.4.ebuild,v 1.5 2010/07/01 20:27:50 jer Exp $
-
-# Brief explanation of the bootstrap logic:
-#
-# Previous ghc ebuilds have been split into two: ghc and ghc-bin,
-# where ghc-bin was primarily used for bootstrapping purposes.
-# From now on, these two ebuilds have been combined, with the
-# binary USE flag used to determine whether or not the pre-built
-# binary package should be emerged or whether ghc should be compiled
-# from source. If the latter, then the relevant ghc-bin for the
-# arch in question will be used in the working directory to compile
-# ghc from source.
-#
-# This solution has the advantage of allowing us to retain the one
-# ebuild for both packages, and thus phase out virtual/ghc.
-
-# Note to users of hardened gcc-3.x:
-#
-# If you emerge ghc with hardened gcc it should work fine (because we
-# turn off the hardened features that would otherwise break ghc).
-# However, emerging ghc while using a vanilla gcc and then switching to
-# hardened gcc (using gcc-config) will leave you with a broken ghc. To
-# fix it you would need to either switch back to vanilla gcc or re-emerge
-# ghc (or ghc-bin). Note that also if you are using hardened gcc-3.x and
-# you switch to gcc-4.x that this will also break ghc and you'll need to
-# re-emerge ghc (or ghc-bin). People using vanilla gcc can switch between
-# gcc-3.x and 4.x with no problems.
-
-inherit base autotools bash-completion eutils flag-o-matic toolchain-funcs ghc-package versionator
-
-DESCRIPTION="The Glasgow Haskell Compiler"
-HOMEPAGE="http://www.haskell.org/ghc/"
-
-# discover if this is a snapshot release
-IS_SNAPSHOT="$(get_version_component_range 4)" # non-empty if snapshot
-EXTRA_SRC_URI="${PV}"
-[[ "${IS_SNAPSHOT}" ]] && EXTRA_SRC_URI="stable/dist"
-
-arch_binaries=""
-
-arch_binaries="$arch_binaries x86? ( http://code.haskell.org/~ivanm/ghc-bin-${PV}-x86.tbz2 )"
-arch_binaries="$arch_binaries amd64? ( http://haskell.org/~kolmodin/ghc-bin-${PV}-amd64.tbz2 )"
-arch_binaries="$arch_binaries sparc? ( http://haskell.org/~duncan/ghc/ghc-bin-${PV}-sparc.tbz2 )"
-arch_binaries="$arch_binaries ppc64? ( http://code.haskell.org/~slyfox/ghc-ppc64/ghc-bin-${PV}-ppc64.tbz2 )"
-
-#arch_binaries="$arch_binaries alpha? ( mirror://gentoo/ghc-bin-${PV}-alpha.tbz2 )"
-#arch_binaries="$arch_binaries amd64? ( mirror://gentoo/ghc-bin-${PV}-amd64.tbz2 )"
-#arch_binaries="$arch_binaries ia64? ( mirror://gentoo/ghc-bin-${PV}-ia64.tbz2 )"
-#arch_binaries="$arch_binaries sparc? ( mirror://gentoo/ghc-bin-${PV}-sparc.tbz2 )"
-#arch_binaries="$arch_binaries x86? ( mirror://gentoo/ghc-bin-${PV}-x86.tbz2 )"
-
-SRC_URI="!binary? ( http://haskell.org/ghc/dist/${EXTRA_SRC_URI}/${P}-src.tar.bz2 )
- !ghcbootstrap? ( $arch_binaries )"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
-IUSE="binary doc ghcbootstrap"
-
-RDEPEND="
- !dev-lang/ghc-bin
- >=sys-devel/gcc-2.95.3
- >=sys-devel/binutils-2.17
- >=dev-lang/perl-5.6.1
- >=dev-libs/gmp-4.1
- !<dev-haskell/haddock-2.4.2"
-# earlier versions than 2.4.2 of haddock only works with older ghc releases
-
-DEPEND="${RDEPEND}
- ghcbootstrap? ( doc? ( ~app-text/docbook-xml-dtd-4.2
- app-text/docbook-xsl-stylesheets
- >=dev-libs/libxslt-1.1.2 ) )"
-# In the ghcbootstrap case we rely on the developer having
-# >=ghc-5.04.3 on their $PATH already
-
-PDEPEND="!ghcbootstrap? ( =app-admin/haskell-updater-0.9* )"
-
-append-ghc-cflags() {
- local flag compile assemble link
- for flag in $*; do
- case ${flag} in
- compile) compile="yes";;
- assemble) assemble="yes";;
- link) link="yes";;
- *)
- [[ ${compile} ]] && GHC_CFLAGS="${GHC_CFLAGS} -optc${flag}"
- [[ ${assemble} ]] && GHC_CFLAGS="${GHC_CFLAGS} -opta${flag}"
- [[ ${link} ]] && GHC_CFLAGS="${GHC_CFLAGS} -optl${flag}";;
- esac
- done
-}
-
-ghc_setup_cflags() {
- # We need to be very careful with the CFLAGS we ask ghc to pass through to
- # gcc. There are plenty of flags which will make gcc produce output that
- # breaks ghc in various ways. The main ones we want to pass through are
- # -mcpu / -march flags. These are important for arches like alpha & sparc.
- # We also use these CFLAGS for building the C parts of ghc, ie the rts.
- strip-flags
- strip-unsupported-flags
- filter-flags -fPIC
-
- GHC_CFLAGS=""
- for flag in ${CFLAGS}; do
- case ${flag} in
-
- # Ignore extra optimisation (ghc passes -O to gcc anyway)
- # -O2 and above break on too many systems
- -O*) ;;
-
- # Arch and ABI flags are what we're really after
- -m*) append-ghc-cflags compile assemble ${flag};;
-
- # Debugging flags don't help either. You can't debug Haskell code
- # at the C source level and the mangler discards the debug info.
- -g*) ;;
-
- # Ignore all other flags, including all -f* flags
- esac
- done
-
- # hardened-gcc needs to be disabled, because the mangler doesn't accept
- # its output.
- gcc-specs-pie && append-ghc-cflags compile link -nopie
- gcc-specs-ssp && append-ghc-cflags compile -fno-stack-protector
-
- # prevent from failind building unregisterised ghc:
- # http://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg171602.html
- use ppc64 && append-ghc-cflags compile -mminimal-toc
-
- # We also add -Wa,--noexecstack to get ghc to generate .o files with
- # non-exectable stack. This it a hack until ghc does it itself properly.
- append-ghc-cflags assemble "-Wa,--noexecstack"
-}
-
-pkg_setup() {
- if use ghcbootstrap; then
- ewarn "You requested ghc bootstrapping, this is usually only used"
- ewarn "by Gentoo developers to make binary .tbz2 packages for"
- ewarn "use with the ghc ebuild's USE=\"binary\" feature."
- use binary && \
- die "USE=\"ghcbootstrap binary\" is not a valid combination."
- [[ -z $(type -P ghc) ]] && \
- die "Could not find a ghc to bootstrap with."
- fi
-}
-
-src_unpack() {
- # Create the ${S} dir if we're using the binary version
- use binary && mkdir "${S}"
-
- base_src_unpack
- ghc_setup_cflags
-
- if use binary; then
-
- # Move unpacked files to the expected place
- mv "${WORKDIR}/usr" "${S}"
- else
- if ! use ghcbootstrap; then
- # Relocate from /usr to ${WORKDIR}/usr
- sed -i -e "s|/usr|${WORKDIR}/usr|g" \
- "${WORKDIR}/usr/bin/ghc-${PV}" \
- "${WORKDIR}/usr/bin/ghci-${PV}" \
- "${WORKDIR}/usr/bin/ghc-pkg-${PV}" \
- "${WORKDIR}/usr/bin/hsc2hs" \
- "${WORKDIR}/usr/$(get_libdir)/${P}/package.conf" \
- || die "Relocating ghc from /usr to workdir failed"
- fi
-
- # Hack to prevent haddock being installed, remove when ./configure
- # supports something better to not build docs or haddock.
- sed -i -e 's/DO_NOT_INSTALL =/DO_NOT_INSTALL = haddock/' \
- "${S}/utils/Makefile"
-
- # Highly useful when you need to pass your HC opts to bootstrap libs
- # Currently it is needed for ppc64 to build with broken compiler
- epatch "${FILESDIR}/ghc-6.10.4-propagate-hc-options-to-all-libraries.patch"
-
- # see ghc_setup_cflags()
- use ppc64 && epatch "${FILESDIR}/ghc-6.10.4-ppc64-always-minimal-toc.patch"
-
- # as we have changed the build system with the readline patch
- eautoreconf
- fi
-}
-
-src_compile() {
- if ! use binary; then
-
- # initialize build.mk
- echo '# Gentoo changes' > mk/build.mk
-
- # Put docs into the right place, ie /usr/share/doc/ghc-${PV}
- echo "docdir = /usr/share/doc/${P}" >> mk/build.mk
- echo "htmldir = /usr/share/doc/${P}" >> mk/build.mk
-
- # We also need to use the GHC_CFLAGS flags when building ghc itself
- echo "SRC_HC_OPTS+=${GHC_CFLAGS}" >> mk/build.mk
- echo "SRC_CC_OPTS+=${CFLAGS} -Wa,--noexecstack" >> mk/build.mk
-
- # We can't depend on haddock except when bootstrapping when we
- # must build docs and include them into the binary .tbz2 package
- if use ghcbootstrap && use doc; then
- echo XMLDocWays="html" >> mk/build.mk
- echo HADDOCK_DOCS=YES >> mk/build.mk
- else
- echo XMLDocWays="" >> mk/build.mk
- echo HADDOCK_DOCS=NO >> mk/build.mk
- fi
-
- # circumvent a very strange bug that seems related with ghc producing
- # too much output while being filtered through tee (e.g. due to
- # portage logging) reported as bug #111183
- echo "SRC_HC_OPTS+=-w" >> mk/build.mk
-
- # GHC build system knows to build unregisterised on alpha,
- # but we have to tell it to build unregisterised on some arches
- # ppc64: EvilMangler currently does not understand some TOCs
- if use alpha || use ppc64; then
- echo "GhcUnregisterised=YES" >> mk/build.mk
- echo "GhcWithInterpreter=NO" >> mk/build.mk
- echo "GhcWithNativeCodeGen=NO" >> mk/build.mk
- echo "SplitObjs=NO" >> mk/build.mk
- echo "GhcRTSWays := debug" >> mk/build.mk
- echo "GhcNotThreaded=YES" >> mk/build.mk
- fi
- # Have "ld -r --relax" problem with split-objs on sparc:
- if use sparc; then
- echo "SplitObjs=NO" >> mk/build.mk
- fi
-
- # Get ghc from the unpacked binary .tbz2
- # except when bootstrapping we just pick ghc up off the path
- if ! use ghcbootstrap; then
- export PATH="${WORKDIR}/usr/bin:${PATH}"
- fi
-
- econf || die "econf failed"
-
- emake all || die "make failed"
-
- fi # ! use binary
-}
-
-src_install() {
- if use binary; then
- mv "${S}/usr" "${D}"
-
- # Remove the docs if not requested
- if ! use doc; then
- rm -rf "${D}/usr/share/doc/${P}/*/" \
- "${D}/usr/share/doc/${P}/*.html" \
- || die "could not remove docs (P vs PF revision mismatch?)"
- fi
- else
- local insttarget="install"
-
- # We only built docs if we were bootstrapping, otherwise
- # we copy them out of the unpacked binary .tbz2
- if use doc; then
- if use ghcbootstrap; then
- insttarget="${insttarget} install-docs"
- else
- mkdir -p "${D}/usr/share/doc"
- mv "${WORKDIR}/usr/share/doc/${P}" "${D}/usr/share/doc" \
- || die "failed to copy docs"
- fi
- fi
-
- emake -j1 ${insttarget} \
- DESTDIR="${D}" \
- || die "make ${insttarget} failed"
-
- dodoc "${S}/README" "${S}/ANNOUNCE" "${S}/LICENSE" "${S}/VERSION"
-
- dobashcompletion "${FILESDIR}/ghc-bash-completion"
-
- cp -p "${D}/usr/$(get_libdir)/${P}/package.conf"{,.shipped} \
- || die "failed to copy package.conf"
- fi
-}
-
-pkg_postinst() {
- # 'ghc-pkg check' fails in ghc 6.10.2, with the error message:
- # There are problems in package rts-1.0:
- # include-dirs: PAPI_INCLUDE_DIR doesn't exist or isn't a directory
- # Upstream suggests this solution to fix it:
- export PATH="/usr/bin:${PATH}"
- $(ghc-getghcpkg) describe rts | sed 's/PAPI_INCLUDE_DIR//' | $(ghc-getghcpkg) update -
-
- ghc-reregister
-
- ewarn "IMPORTANT:"
- ewarn "If you have upgraded from another version of ghc,"
- ewarn "once app-admin/haskell-updater has installed please run:"
- ewarn " /usr/sbin/haskell-updater --upgrade"
- ewarn "to re-build all ghc-based Haskell libraries."
-
- bash-completion_pkg_postinst
-}
-
-pkg_prerm() {
- # Overwrite the (potentially) modified package.conf with a copy of the
- # original one, so that it will be removed during uninstall.
-
- PKG="${ROOT}/usr/$(get_libdir)/${P}/package.conf"
-
- cp -p "${PKG}"{.shipped,}
-
- [[ -f ${PKG}.old ]] && rm "${PKG}.old"
-}
diff --git a/dev-lang/ghc/ghc-6.12.3.ebuild b/dev-lang/ghc/ghc-6.12.3.ebuild
index c5d5c2152482..9014f2d5aefd 100644
--- a/dev-lang/ghc/ghc-6.12.3.ebuild
+++ b/dev-lang/ghc/ghc-6.12.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.12.3.ebuild,v 1.3 2010/07/01 20:27:50 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.12.3.ebuild,v 1.4 2010/07/07 22:18:57 slyfox Exp $
# Brief explanation of the bootstrap logic:
#
@@ -35,6 +35,7 @@ HOMEPAGE="http://www.haskell.org/ghc/"
arch_binaries=""
+arch_binaries="$arch_binaries alpha? ( http://code.haskell.org/~slyfox/ghc-alpha/ghc-bin-${PV}-alpha.tbz2 )"
arch_binaries="$arch_binaries x86? ( mirror://gentoo/ghc-bin-${PV}-x86.tbz2 )"
arch_binaries="$arch_binaries amd64? ( mirror://gentoo/ghc-bin-${PV}-amd64.tbz2 )"
#arch_binaries="$arch_binaries sparc? ( http://haskell.org/~duncan/ghc/ghc-bin-${PV}-sparc.tbz2 )"
@@ -50,7 +51,7 @@ SRC_URI="!binary? ( http://darcs.haskell.org/download/dist/${PV}/${P}-src.tar.bz
!ghcbootstrap? ( $arch_binaries )"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
+KEYWORDS="~alpha ~amd64 ~ppc64 ~x86"
IUSE="binary doc ghcbootstrap"
RDEPEND="
@@ -201,6 +202,9 @@ src_unpack() {
epatch "${FILESDIR}/ghc-6.12.1-configure-CHOST.patch"
epatch "${FILESDIR}/ghc-6.12.2-configure-CHOST-part2.patch"
+ # fixes build failure of adjustor code
+ epatch "${FILESDIR}/ghc-6.12.3-alpha-use-libffi-for-foreign-import-wrapper.patch"
+
# as we have changed the build system with the readline patch
eautoreconf
fi