summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2006-10-03 23:42:18 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2006-10-03 23:42:18 +0000
commit425d11c41e8104db7b824187278114d1d5041da0 (patch)
treeedb8871db26dbfe3505bb4f3b5f85dce0c979d3d /dev-lang/ghc
parentUse eselect-opengl rather than deprecated opengl-update. Fixes bug #147244 (diff)
downloadgentoo-2-425d11c41e8104db7b824187278114d1d5041da0.tar.gz
gentoo-2-425d11c41e8104db7b824187278114d1d5041da0.tar.bz2
gentoo-2-425d11c41e8104db7b824187278114d1d5041da0.zip
Add fmccor's sparc mangler patch. Fixes bug #144752.
(Portage version: 2.1.1-r1)
Diffstat (limited to 'dev-lang/ghc')
-rw-r--r--dev-lang/ghc/ChangeLog6
-rw-r--r--dev-lang/ghc/files/ghc-6.4.2-sparcmangler.patch13
-rw-r--r--dev-lang/ghc/ghc-6.4.2.ebuild3
3 files changed, 20 insertions, 2 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index 93721a56e340..5621ec473fcc 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ghc
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.113 2006/10/03 23:15:54 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.114 2006/10/03 23:42:18 dcoutts Exp $
+
+ 03 Oct 2006; Duncan Coutts <dcoutts@gentoo.org>
+ +files/ghc-6.4.2-sparcmangler.patch, ghc-6.4.2.ebuild:
+ Add fmccor's sparc mangler patch. Fixes bug #144752.
03 Oct 2006; Duncan Coutts <dcoutts@gentoo.org> ghc-6.4.1-r3.ebuild,
ghc-6.4.2.ebuild:
diff --git a/dev-lang/ghc/files/ghc-6.4.2-sparcmangler.patch b/dev-lang/ghc/files/ghc-6.4.2-sparcmangler.patch
new file mode 100644
index 000000000000..7431ffb5a5fe
--- /dev/null
+++ b/dev-lang/ghc/files/ghc-6.4.2-sparcmangler.patch
@@ -0,0 +1,13 @@
+--- ghc/driver/mangler/ghc-asm.lprl- 2006-08-23 14:24:27.000000000 +0000
++++ ghc/driver/mangler/ghc-asm.lprl 2006-08-23 14:25:46.000000000 +0000
+@@ -417,8 +417,8 @@
+ $T_CONST_LBL = '^\.LLC(\d+):$'; # regexp for what such a lbl looks like
+ $T_POST_LBL = ':';
+
+- $T_MOVE_DIRVS = '^((\s+\.align\s+\d+|\s+\.proc\s+\d+|\s+\.global\s+\S+|\.text|\.data|\.seg|\.stab.*|\s+?\.section.*|\s+\.type.*|\s+\.size.*)\n)';
+- $T_COPY_DIRVS = '\.(global|globl|proc|stab)';
++ $T_MOVE_DIRVS = '^((\s+\.align\s+\d+|\s+\.proc\s+\d+|\s+\.global\s+\S+|\s+\.local\s+\S+|\.text|\.data|\.seg|\.stab.*|\s+?\.section.*|\s+\.type.*|\s+\.size.*)\n)';
++ $T_COPY_DIRVS = '\.(global|local|globl|proc|stab)';
+
+ $T_DOT_WORD = '\.(long|word|nword|xword|byte|half|short|skip|uahalf|uaword)';
+ $T_DOT_GLOBAL = '^\t\.global';
diff --git a/dev-lang/ghc/ghc-6.4.2.ebuild b/dev-lang/ghc/ghc-6.4.2.ebuild
index ebddee204d31..963a2a1d446a 100644
--- a/dev-lang/ghc/ghc-6.4.2.ebuild
+++ b/dev-lang/ghc/ghc-6.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.4.2.ebuild,v 1.15 2006/10/03 23:15:54 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.4.2.ebuild,v 1.16 2006/10/03 23:42:18 dcoutts Exp $
# Brief explanation of the bootstrap logic:
#
@@ -161,6 +161,7 @@ src_unpack() {
cd ${S}
epatch "${WORKDIR}/${P}-alut.patch"
epatch "${FILESDIR}/${P}-sparc32plus.patch"
+ epatch "${FILESDIR}/${P}-sparcmangler.patch"
# Modify the ghc driver script to use GHC_CFLAGS
echo "SCRIPT_SUBST_VARS += GHC_CFLAGS" >> "${S}/ghc/driver/ghc/Makefile"