summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2006-04-06 17:15:03 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2006-04-06 17:15:03 +0000
commit2efb99c1a52a19bdc565704118ff09853e86f49e (patch)
treeb30abcbaf44e4652379fabdb993d12e31af2e8c4 /dev-lang/ghc
parentredigest again... i hope it's the last. (diff)
downloadgentoo-2-2efb99c1a52a19bdc565704118ff09853e86f49e.tar.gz
gentoo-2-2efb99c1a52a19bdc565704118ff09853e86f49e.tar.bz2
gentoo-2-2efb99c1a52a19bdc565704118ff09853e86f49e.zip
-O* flags (from the users CFLAGS) breaks ghc on too many systems so don't add it to ghc's CFLAGS. Also remove ia64 GOT patch that didn't help.
(Portage version: 2.1_pre7-r3)
Diffstat (limited to 'dev-lang/ghc')
-rw-r--r--dev-lang/ghc/ChangeLog6
-rw-r--r--dev-lang/ghc/ghc-6.4.1-r3.ebuild17
2 files changed, 9 insertions, 14 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index eac4457672e4..caa5ad825a29 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ghc
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.93 2006/03/28 17:28:48 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.94 2006/04/06 17:15:03 dcoutts Exp $
+
+ 06 Apr 2006; Duncan Coutts <dcoutts@gentoo.org> ghc-6.4.1-r3.ebuild:
+ -O* flags (from the users CFLAGS) breaks ghc on too many systems so don't
+ add it to ghc's CFLAGS. Also remove ia64 GOT patch that didn't help.
28 Mar 2006; Duncan Coutts <dcoutts@gentoo.org> ghc-6.4.1-r2.ebuild:
Enable SplitObjs on ppc. This gives much smaller binaries.
diff --git a/dev-lang/ghc/ghc-6.4.1-r3.ebuild b/dev-lang/ghc/ghc-6.4.1-r3.ebuild
index 2ac489525a20..45bc6215b8b4 100644
--- a/dev-lang/ghc/ghc-6.4.1-r3.ebuild
+++ b/dev-lang/ghc/ghc-6.4.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.4.1-r3.ebuild,v 1.2 2006/03/28 17:25:20 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.4.1-r3.ebuild,v 1.3 2006/04/06 17:15:03 dcoutts Exp $
# Brief explanation of the bootstrap logic:
#
@@ -101,12 +101,9 @@ ghc_setup_cflags() {
for flag in ${CFLAGS}; do
case ${flag} in
- # These would just dup what ghc does anyway
- -O|-O1) ;;
-
- # We have to be really careful with more agressive -O flags
- # as they do break ghc on some arches.
- -O2|-O3|-Os) use ia64 || use sparc || append-ghc-cflags compile ${flag};;
+ # Ignore extra optimisation (ghc passes -O to gcc anyway)
+ # -O2 and above break on too many systems
+ -O*) ;;
# Arch and ABI flags are probably ok
-m*) append-ghc-cflags compile assemble ${flag};;
@@ -144,12 +141,6 @@ src_unpack() {
# Patch to fix parallel make
sed -i 's/mkDerivedConstants.c : $(H_CONFIG)/mkDerivedConstants.c : $(H_CONFIG) $(H_PLATFORM)/' "${S}/ghc/includes/Makefile"
-
- # We need bigger tables on ia64 to be able to load larger packages
- sed -i -e 's/#define GOT_SIZE 0x20000/#define GOT_SIZE 0x40000/' \
- -e 's/#define FUNCTION_TABLE_SIZE 0x10000/#define FUNCTION_TABLE_SIZE 0x20000/' \
- -e 's/#define PLT_SIZE 0x08000/#define PLT_SIZE 0x16000/' \
- "${S}/ghc/rts/Linker.c"
}
src_compile() {