summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2007-07-28 13:36:16 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2007-07-28 13:36:16 +0000
commit03e21a2c73477dd4a4742240a9c09c07fcb3560e (patch)
treeb55c955b835a0081fa4c3aae6111c679c64fb12d /dev-lang/ghc
parentstale mask removed (diff)
downloadgentoo-2-03e21a2c73477dd4a4742240a9c09c07fcb3560e.tar.gz
gentoo-2-03e21a2c73477dd4a4742240a9c09c07fcb3560e.tar.bz2
gentoo-2-03e21a2c73477dd4a4742240a9c09c07fcb3560e.zip
Disable the split objects feature in GHC 6.6.1 when using >=gcc-4.2.
(Portage version: 2.1.3)
Diffstat (limited to 'dev-lang/ghc')
-rw-r--r--dev-lang/ghc/ChangeLog5
-rw-r--r--dev-lang/ghc/ghc-6.6.1.ebuild9
2 files changed, 11 insertions, 3 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index 5e3797ea7624..5bb2612f2632 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/ghc
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.130 2007/07/25 18:30:23 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.131 2007/07/28 13:36:16 kolmodin Exp $
+
+ 28 Jul 2007; Lennart Kolmodin <kolmodin@gentoo.org> ghc-6.6.1.ebuild:
+ Disable the split objects feature when using >=gcc-4.2.
25 Jul 2007; Duncan Coutts <dcoutts@gentoo.org> +ghc-6.6.ebuild:
Add ghc-6.6 back since it has binaries for alpha, ppc and sparc that we do
diff --git a/dev-lang/ghc/ghc-6.6.1.ebuild b/dev-lang/ghc/ghc-6.6.1.ebuild
index 0b5954b00279..e91299ac76ec 100644
--- a/dev-lang/ghc/ghc-6.6.1.ebuild
+++ b/dev-lang/ghc/ghc-6.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.6.1.ebuild,v 1.6 2007/07/25 17:49:45 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.6.1.ebuild,v 1.7 2007/07/28 13:36:16 kolmodin Exp $
# Brief explanation of the bootstrap logic:
#
@@ -28,7 +28,7 @@
# re-emerge ghc (or ghc-bin). People using vanilla gcc can switch between
# gcc-3.x and 4.x with no problems.
-inherit base eutils flag-o-matic toolchain-funcs ghc-package
+inherit base eutils flag-o-matic toolchain-funcs ghc-package versionator
DESCRIPTION="The Glasgow Haskell Compiler"
HOMEPAGE="http://www.haskell.org/ghc/"
@@ -242,6 +242,11 @@ src_compile() {
echo "GhcNotThreaded=YES" >> mk/build.mk
fi
+ # GHC <6.8 doesn't support GCC >=4.2, split objects fails.
+ if version_is_at_least "4.2" "$(gcc-version)"; then
+ echo "SplitObjs=NO" >> mk/build.mk
+ fi
+
# Get ghc from the unpacked binary .tbz2
# except when bootstrapping we just pick ghc up off the path
use ghcbootstrap || \