summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2009-09-16 06:50:29 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2009-09-16 06:50:29 +0000
commita04d702c3c9433fc114a292e198e20b40de65b75 (patch)
tree688b93035f7f0454bf436b3a62d4babab702ecba /dev-lang/ghc/files
parentRemove 4.3.1 (not -r1) due to unsolvable deps on some arches. (diff)
downloadgentoo-2-a04d702c3c9433fc114a292e198e20b40de65b75.tar.gz
gentoo-2-a04d702c3c9433fc114a292e198e20b40de65b75.tar.bz2
gentoo-2-a04d702c3c9433fc114a292e198e20b40de65b75.zip
Add <haddock-2 blocker to ghc-6.10.4, add ppc64 binaries and patches to ghc 6.10.4.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/ghc/files')
-rw-r--r--dev-lang/ghc/files/ghc-6.10.4-ppc64-always-minimal-toc.patch9
-rw-r--r--dev-lang/ghc/files/ghc-6.10.4-propagate-hc-options-to-all-libraries.patch37
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-lang/ghc/files/ghc-6.10.4-ppc64-always-minimal-toc.patch b/dev-lang/ghc/files/ghc-6.10.4-ppc64-always-minimal-toc.patch
new file mode 100644
index 000000000000..8aaf594ee0f9
--- /dev/null
+++ b/dev-lang/ghc/files/ghc-6.10.4-ppc64-always-minimal-toc.patch
@@ -0,0 +1,9 @@
+diff --git a/ghc/ghc.wrapper b/ghc/ghc.wrapper
+index 71eae84..b02421d 100644
+--- a/ghc/ghc.wrapper
++++ b/ghc/ghc.wrapper
+@@ -1,3 +1,3 @@
+ #!/bin/sh
+
+-exec $executablename -B$datadir -dynload wrapped ${1+"$@"}
++exec $executablename -B$datadir -optc-mminimal-toc -dynload wrapped ${1+"$@"}
diff --git a/dev-lang/ghc/files/ghc-6.10.4-propagate-hc-options-to-all-libraries.patch b/dev-lang/ghc/files/ghc-6.10.4-propagate-hc-options-to-all-libraries.patch
new file mode 100644
index 000000000000..396c07974d1f
--- /dev/null
+++ b/dev-lang/ghc/files/ghc-6.10.4-propagate-hc-options-to-all-libraries.patch
@@ -0,0 +1,37 @@
+diff --git a/libraries/Makefile b/libraries/Makefile
+index bf59e9a..c85df45 100644
+--- a/libraries/Makefile
++++ b/libraries/Makefile
+@@ -128,7 +128,7 @@ ifeq "$(ghc_ge_605)" "NO"
+ CABAL_GHC_FLAGS += -cpp
+ endif
+
+-BOOTSTRAPPING_FLAGS = $(CABAL_GHC_FLAGS) -DCABAL_VERSION=$(CABAL_VERSION) -odir $(HERE_ABS)/bootstrapping -hidir $(HERE_ABS)/bootstrapping -i$(HERE_ABS)/Cabal -i$(HERE_ABS)/filepath -i$(HERE_ABS)/hpc
++BOOTSTRAPPING_FLAGS = $(SRC_HC_OPTS) $(CABAL_GHC_FLAGS) -DCABAL_VERSION=$(CABAL_VERSION) -odir $(HERE_ABS)/bootstrapping -hidir $(HERE_ABS)/bootstrapping -i$(HERE_ABS)/Cabal -i$(HERE_ABS)/filepath -i$(HERE_ABS)/hpc
+
+ .PHONY: boot
+
+@@ -141,19 +141,19 @@ cabal-bin: cabal-bin.hs
+ bootstrapping.conf: cabal-bin
+ echo "[]" > $@.tmp
+ -cd extensible-exceptions && $(CABAL) clean --distpref=dist-bootstrapping
+- cd extensible-exceptions && $(CABAL) configure --distpref=dist-bootstrapping --with-compiler=$(GHC) --with-hc-pkg=$(GHC_PKG) --package-db=$(HERE_ABS)/$@.tmp
++ cd extensible-exceptions && $(CABAL) configure --distpref=dist-bootstrapping --with-compiler=$(GHC) --ghc-options="$(BOOTSTRAPPING_FLAGS)" --with-hc-pkg=$(GHC_PKG) --package-db=$(HERE_ABS)/$@.tmp
+ cd extensible-exceptions && $(CABAL) build --distpref=dist-bootstrapping
+ cd extensible-exceptions && $(CABAL) install --distpref=dist-bootstrapping --inplace
+ -cd filepath && $(CABAL) clean --distpref=dist-bootstrapping
+- cd filepath && $(CABAL) configure --distpref=dist-bootstrapping --with-compiler=$(GHC) --with-hc-pkg=$(GHC_PKG) --package-db=$(HERE_ABS)/$@.tmp
++ cd filepath && $(CABAL) configure --distpref=dist-bootstrapping --with-compiler=$(GHC) --ghc-options="$(BOOTSTRAPPING_FLAGS)" --with-hc-pkg=$(GHC_PKG) --package-db=$(HERE_ABS)/$@.tmp
+ cd filepath && $(CABAL) build --distpref=dist-bootstrapping
+ cd filepath && $(CABAL) install --distpref=dist-bootstrapping --inplace
+ -cd Cabal && $(CABAL) clean --distpref=dist-bootstrapping
+- cd Cabal && $(CABAL) configure --distpref=dist-bootstrapping --with-compiler=$(GHC) --with-hc-pkg=$(GHC_PKG) --package-db=$(HERE_ABS)/$@.tmp
++ cd Cabal && $(CABAL) configure --distpref=dist-bootstrapping --with-compiler=$(GHC) --ghc-options="$(BOOTSTRAPPING_FLAGS)" --with-hc-pkg=$(GHC_PKG) --package-db=$(HERE_ABS)/$@.tmp
+ cd Cabal && $(CABAL) build --distpref=dist-bootstrapping
+ cd Cabal && $(CABAL) install --distpref=dist-bootstrapping --inplace
+ -cd hpc && $(CABAL) clean --distpref=dist-bootstrapping
+- cd hpc && $(CABAL) configure --distpref=dist-bootstrapping --with-compiler=$(GHC) --with-hc-pkg=$(GHC_PKG) --package-db=$(HERE_ABS)/$@.tmp
++ cd hpc && $(CABAL) configure --distpref=dist-bootstrapping --with-compiler=$(GHC) --ghc-options="$(BOOTSTRAPPING_FLAGS)" --with-hc-pkg=$(GHC_PKG) --package-db=$(HERE_ABS)/$@.tmp
+ cd hpc && $(CABAL) build --distpref=dist-bootstrapping
+ cd hpc && $(CABAL) install --distpref=dist-bootstrapping --inplace
+ mv $@.tmp $@