summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-09-06 06:50:37 +0000
committerUlrich Müller <ulm@gentoo.org>2008-09-06 06:50:37 +0000
commit39b7fe08755e4a3a97a62e61ebf59f8bab1e5ec5 (patch)
tree22d7c100001bebda62314d741fe72e1a42c645f5 /dev-lang/gforth
parentApply fix by kouyu for missing return value #236654. (diff)
downloadgentoo-2-39b7fe08755e4a3a97a62e61ebf59f8bab1e5ec5.tar.gz
gentoo-2-39b7fe08755e4a3a97a62e61ebf59f8bab1e5ec5.tar.bz2
gentoo-2-39b7fe08755e4a3a97a62e61ebf59f8bab1e5ec5.zip
Use elisp-compile instead of elisp-comp, bug 235576. Fix compile failure with USE=emacs, bug 227523 comment 2.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'dev-lang/gforth')
-rw-r--r--dev-lang/gforth/ChangeLog7
-rw-r--r--dev-lang/gforth/files/gforth.el-gentoo.patch34
-rw-r--r--dev-lang/gforth/gforth-0.6.2-r1.ebuild8
3 files changed, 40 insertions, 9 deletions
diff --git a/dev-lang/gforth/ChangeLog b/dev-lang/gforth/ChangeLog
index c1e8122375fe..3b05cf9a574e 100644
--- a/dev-lang/gforth/ChangeLog
+++ b/dev-lang/gforth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/gforth
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/ChangeLog,v 1.25 2008/08/23 05:21:14 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/ChangeLog,v 1.26 2008/09/06 06:50:36 ulm Exp $
+
+ 06 Sep 2008; Ulrich Mueller <ulm@gentoo.org> files/gforth.el-gentoo.patch,
+ gforth-0.6.2-r1.ebuild:
+ Use elisp-compile instead of elisp-comp, bug 235576. Fix compile failure
+ with USE=emacs, bug 227523 comment 2.
23 Aug 2008; Jeroen Roovers <jer@gentoo.org> metadata.xml:
Add GLEP 56 USE flag descriptions.
diff --git a/dev-lang/gforth/files/gforth.el-gentoo.patch b/dev-lang/gforth/files/gforth.el-gentoo.patch
index 710556f3ddba..cc98537e766d 100644
--- a/dev-lang/gforth/files/gforth.el-gentoo.patch
+++ b/dev-lang/gforth/files/gforth.el-gentoo.patch
@@ -1,7 +1,32 @@
-diff -ur gforth-0.6.2.orig/gforth.el gforth-0.6.2/gforth.el
---- gforth-0.6.2.orig/gforth.el 2003-08-05 04:12:47.000000000 -0500
-+++ gforth-0.6.2/gforth.el 2006-02-17 11:30:49.000000000 -0600
-@@ -1702,6 +1702,6 @@
+--- gforth-0.6.2-orig/gforth.el 2003-08-05 11:12:47.000000000 +0200
++++ gforth-0.6.2/gforth.el 2008-09-06 08:29:44.000000000 +0200
+@@ -61,9 +61,10 @@
+ (progn (string-match "^[0-9]+" emacs-version)
+ (string-to-int (match-string 0 emacs-version)))))
+
+-(defun forth-emacs-older (major minor)
+- (or (< emacs-major-version major)
+- (and (= emacs-major-version major) (< emacs-minor-version minor))))
++(eval-when-compile
++ (defun forth-emacs-older (major minor)
++ (or (< emacs-major-version major)
++ (and (= emacs-major-version major) (< emacs-minor-version minor)))))
+
+ ;; Code ripped from `subr.el' for compatability with Emacs versions
+ ;; prior to 20.1
+@@ -79,8 +80,9 @@
+
+ ;; `no-error' argument of require not supported in Emacs versions
+ ;; prior to 20.4 :-(
+-(defun forth-require (feature)
+- (condition-case err (require feature) (error nil)))
++(eval-and-compile
++ (defun forth-require (feature)
++ (condition-case err (require feature) (error nil))))
+
+ (require 'font-lock)
+
+@@ -1702,6 +1704,6 @@
(error "No current process. See variable `forth-process-buffer'"))))
) ; (memq 'comint features)
@@ -9,3 +34,4 @@ diff -ur gforth-0.6.2.orig/gforth.el gforth-0.6.2/gforth.el
+(provide 'gforth)
;;; gforth.el ends here
+
diff --git a/dev-lang/gforth/gforth-0.6.2-r1.ebuild b/dev-lang/gforth/gforth-0.6.2-r1.ebuild
index 6f79e7675c68..d3e9c454a65a 100644
--- a/dev-lang/gforth/gforth-0.6.2-r1.ebuild
+++ b/dev-lang/gforth/gforth-0.6.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/gforth-0.6.2-r1.ebuild,v 1.5 2008/03/17 15:56:08 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/gforth-0.6.2-r1.ebuild,v 1.6 2008/09/06 06:50:36 ulm Exp $
inherit elisp-common eutils toolchain-funcs flag-o-matic
@@ -55,7 +55,7 @@ src_compile() {
|| die "econf failed"
make || die
if use emacs; then
- elisp-comp *.el || die
+ elisp-compile *.el || die
fi
}
@@ -71,8 +71,8 @@ src_install() {
dodoc AUTHORS BUGS ChangeLog NEWS* README* ToDo doc/glossaries.doc doc/*.ps
if use emacs; then
- elisp-install ${PN} *.el *.elc
- elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ elisp-install ${PN} *.el *.elc || die
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE} || die
fi
}