summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-05-22 15:29:37 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-05-22 15:29:37 +0000
commit5a9ef13fdb4abee33a1bf1b6c97a2c065c88b2f2 (patch)
treefb179614689ce97339379a59ddfe21a23714a9c4 /dev-lang/gdl
parentAdded ~amd64, move scons to DEPEDN, and removed unecessary numarray dependencies (diff)
downloadgentoo-2-5a9ef13fdb4abee33a1bf1b6c97a2c065c88b2f2.tar.gz
gentoo-2-5a9ef13fdb4abee33a1bf1b6c97a2c065c88b2f2.tar.bz2
gentoo-2-5a9ef13fdb4abee33a1bf1b6c97a2c065c88b2f2.zip
Version bump
(Portage version: 2.1.5.2)
Diffstat (limited to 'dev-lang/gdl')
-rw-r--r--dev-lang/gdl/ChangeLog8
-rw-r--r--dev-lang/gdl/files/gdl-0.9_rc1-proj4.patch31
-rw-r--r--dev-lang/gdl/gdl-0.9_rc1.ebuild (renamed from dev-lang/gdl/gdl-0.9_pre5.ebuild)25
3 files changed, 52 insertions, 12 deletions
diff --git a/dev-lang/gdl/ChangeLog b/dev-lang/gdl/ChangeLog
index 58eaffee74c3..b8f93a22639c 100644
--- a/dev-lang/gdl/ChangeLog
+++ b/dev-lang/gdl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/gdl
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gdl/ChangeLog,v 1.6 2008/04/13 18:31:51 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gdl/ChangeLog,v 1.7 2008/05/22 15:29:37 bicatali Exp $
+
+*gdl-0.9_rc1 (22 May 2008)
+
+ 22 May 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/gdl-0.9_rc1-proj4.patch, -gdl-0.9_pre5.ebuild, +gdl-0.9_rc1.ebuild:
+ Version bump
13 Apr 2008; Markus Dittrich <markusle@gentoo.org>
+files/gdl-0.9_pre6-plplot-5.9.patch, gdl-0.9_pre6.ebuild:
diff --git a/dev-lang/gdl/files/gdl-0.9_rc1-proj4.patch b/dev-lang/gdl/files/gdl-0.9_rc1-proj4.patch
new file mode 100644
index 000000000000..80227f317992
--- /dev/null
+++ b/dev-lang/gdl/files/gdl-0.9_rc1-proj4.patch
@@ -0,0 +1,31 @@
+--- configure.in.orig 2008-05-22 15:03:04.000000000 +0000
++++ configure.in 2008-05-22 15:03:19.000000000 +0000
+@@ -482,14 +482,14 @@
+
+ if test "x$with_libproj4" != "xno"; then
+ if test "x$with_libproj4" != "xyes"; then
+- LIBS="$LIBS -L$with_libproj4/lib -lproj4"
++ LIBS="$LIBS -L$with_libproj4/lib -lproj"
+ INCLUDES="$INCLUDES -I$with_libproj4/include"
+ else
+ INCLUDES="$INCLUDES -I/usr/include"
+- LIBS="$LIBS -lproj4"
++ LIBS="$LIBS -lproj"
+ fi
+
+- AC_CHECK_LIB(proj4, pj_init, [AC_DEFINE([USE_LIBPROJ4], [1], [Define if you want to use LIBPROJ4])], [
++ AC_CHECK_LIB(proj, pj_init, [AC_DEFINE([USE_LIBPROJ4], [1], [Define if you want to use LIBPROJ4])], [
+ echo ""
+ echo "Error! LIBPROJ4 is required but was not found"
+ echo " Use --with-libproj4=DIR to specify the LIBPROJ4 directory tree"
+--- src/math_utl.hpp.orig 2008-05-22 15:00:39.000000000 +0000
++++ src/math_utl.hpp 2008-05-22 15:01:46.000000000 +0000
+@@ -42,7 +42,7 @@
+ #define COMPLEX COMPLEX2
+
+ extern "C" {
+-#include "lib_proj.h"
++#include <projects.h>
+ }
+
+ PJ *map_init();
diff --git a/dev-lang/gdl/gdl-0.9_pre5.ebuild b/dev-lang/gdl/gdl-0.9_rc1.ebuild
index ff1a83d6cceb..98151c57c454 100644
--- a/dev-lang/gdl/gdl-0.9_pre5.ebuild
+++ b/dev-lang/gdl/gdl-0.9_rc1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gdl/gdl-0.9_pre5.ebuild,v 1.2 2008/03/21 20:43:56 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gdl/gdl-0.9_rc1.ebuild,v 1.1 2008/05/22 15:29:37 bicatali Exp $
-inherit eutils flag-o-matic
+inherit eutils flag-o-matic autotools
MYP=${P/_/}
DESCRIPTION="An Interactive Data Language compatible incremental compiler"
@@ -21,9 +21,7 @@ RDEPEND=">=sys-libs/readline-4.3
hdf? ( sci-libs/hdf )
hdf5? ( sci-libs/hdf5 )
netcdf? ( sci-libs/netcdf )
- python? ( virtual/python
- dev-python/numarray
- dev-python/matplotlib )
+ python? ( dev-python/numarray dev-python/matplotlib )
fftw? ( >=sci-libs/fftw-3 )
proj? ( sci-libs/proj )"
@@ -36,6 +34,12 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-proj4.patch
+ epatch "${FILESDIR}"/${PN}-0.9_pre6-magick.patch
+
+ #if has_version ">=sci-libs/plplot-5.9.0"; then
+ #epatch "${FILESDIR}"/${PN}-0.9_pre6-plplot-5.9.patch
+ #fi
+ eautoreconf
}
src_compile() {
@@ -55,18 +59,17 @@ src_compile() {
src_test() {
cd "${S}"/testsuite
- PATH=${S}/src gdl <<EOF
-test_suite
-EOF
+ PATH="${S}"/src gdl <<-EOF
+ test_suite
+ EOF
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
insinto /usr/share/${PN}
- doins -r src/pro
- doins -r src/py
- dodoc README PYTHON.txt AUTHORS ChangeLog NEWS TODO HACKING
+ doins -r src/pro src/py || die "install pro and py files failed"
+ dodoc README PYTHON.txt AUTHORS ChangeLog NEWS TODO HACKING || die
# add GDL provided routines to IDL_PATH
echo "GDL_STARTUP=/usr/share/${PN}/pro" > 99gdl