summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-01-19 03:19:12 +0000
committerChris White <chriswhite@gentoo.org>2005-01-19 03:19:12 +0000
commit277a4ad60ccebc7f19c57b8a435d29de7eb31e3b (patch)
tree95476ce62c4b5375edd0770c4516f16e31287f09 /dev-lang/fpc
parentVersion bump. (diff)
downloadgentoo-2-277a4ad60ccebc7f19c57b8a435d29de7eb31e3b.tar.gz
gentoo-2-277a4ad60ccebc7f19c57b8a435d29de7eb31e3b.tar.bz2
gentoo-2-277a4ad60ccebc7f19c57b8a435d29de7eb31e3b.zip
Part 2, Fixes Bug #78273.
Diffstat (limited to 'dev-lang/fpc')
-rw-r--r--dev-lang/fpc/ChangeLog5
-rw-r--r--dev-lang/fpc/Manifest14
-rw-r--r--dev-lang/fpc/files/digest-fpc-1.9.42
-rw-r--r--dev-lang/fpc/fpc-1.9.4.ebuild30
4 files changed, 25 insertions, 26 deletions
diff --git a/dev-lang/fpc/ChangeLog b/dev-lang/fpc/ChangeLog
index 3853f52948c8..d682f20c6f1c 100644
--- a/dev-lang/fpc/ChangeLog
+++ b/dev-lang/fpc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/fpc
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpc/ChangeLog,v 1.9 2005/01/19 02:41:13 chriswhite Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpc/ChangeLog,v 1.10 2005/01/19 03:19:12 chriswhite Exp $
+
+ 19 Jan 2005; Chris White <chriswhite@gentoo.org> fpc-1.9.4.ebuild:
+ Part 2, Fixes Bug #78273.
19 Jan 2005; Chris White <chriswhite@gentoo.org> fpc-1.0.10.ebuild:
Fixed part 1 of bug #78273 for fpc-1.0.10. Also fixed bug #45768 while I was
diff --git a/dev-lang/fpc/Manifest b/dev-lang/fpc/Manifest
index c3bad06d6fe6..73893c2f7080 100644
--- a/dev-lang/fpc/Manifest
+++ b/dev-lang/fpc/Manifest
@@ -1,16 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 c4ccf2f78523349b5cf916e047cd1252 ChangeLog 1237
MD5 4fd86a5847f6c203449ef656fa08084a fpc-1.0.10.ebuild 841
-MD5 ffa441ab05c407c7dbea13babd2f5ad6 fpc-1.9.4.ebuild 723
MD5 f5f1522837a3398846f77d381fda47ec metadata.xml 226
+MD5 4fd86a5847f6c203449ef656fa08084a fpc-1.9.4.ebuild 841
+MD5 31bc5d0091da58e3ea79cb36fdfa5c32 files/digest-fpc-1.9.4 60
MD5 332b84767ddcc966fd2bf724ba8c5961 files/digest-fpc-1.0.10 61
-MD5 80d2d5c870634f6f9380a17fc6af154f files/digest-fpc-1.9.4 67
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFB7cjYFdQwWVoAgN4RAggLAKDbp8oYc1mz85CSzc7ivA+hPbgAxACfVXWL
-C5c9sOBB7uYz4TRr8BQUksI=
-=Q7yy
------END PGP SIGNATURE-----
diff --git a/dev-lang/fpc/files/digest-fpc-1.9.4 b/dev-lang/fpc/files/digest-fpc-1.9.4
index c284af05325c..2a5b712ccf29 100644
--- a/dev-lang/fpc/files/digest-fpc-1.9.4
+++ b/dev-lang/fpc/files/digest-fpc-1.9.4
@@ -1 +1 @@
-MD5 78916cca1f64c977aaa7156f01d989d0 fpc-1.9.4-0.i586.rpm 10078962
+MD5 455225329d6624bea966d766f4738f89 fpc-1.9.4.tbz2 7888365
diff --git a/dev-lang/fpc/fpc-1.9.4.ebuild b/dev-lang/fpc/fpc-1.9.4.ebuild
index 889c7f4d99f7..1042293adfd6 100644
--- a/dev-lang/fpc/fpc-1.9.4.ebuild
+++ b/dev-lang/fpc/fpc-1.9.4.ebuild
@@ -1,28 +1,34 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpc/fpc-1.9.4.ebuild,v 1.2 2005/01/19 02:41:13 chriswhite Exp $
-
-inherit rpm
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/fpc/fpc-1.9.4.ebuild,v 1.3 2005/01/19 03:19:12 chriswhite Exp $
DESCRIPTION="The Free Pascal compiler"
HOMEPAGE="http://www.freepascal.org/"
-SRC_URI="ftp://ftp.freepascal.org/pub/fpc/beta/linux-i386-${PV}/${P}-0.i586.rpm"
+SRC_URI="mirror://gentoo/${P}.tbz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 -*"
+KEYWORDS="x86 -*"
IUSE=""
DEPEND="virtual/libc
- !dev-lang/fpc-source"
+ !dev-lang/fpc-source"
+RDEPEND="virtual/libc"
S=${WORKDIR}
src_unpack() {
- rpm_unpack ${DISTDIR}/${P}-0.i586.rpm
+ einfo unpacking done in install phase
+}
+
+src_compile() {
+ einfo Nothing to compile
}
src_install() {
- mv ${WORKDIR}/usr ${D}
- cd ${D}
- mv usr/share/doc/packages/${P} usr/share/doc/${P}
- rmdir usr/share/doc/packages
- chmod -R 755 usr/lib/* usr/share/*
+ einfo Unpacking to image directory
+ einfo This may take some time depending on your system
+ tar -xjf ${DISTDIR}/${P}.tbz2 -C ${D}
+}
+
+pkg_postinst() {
+ einfo Setting up configuration
+ ${ROOT}/opt/fpc/lib/fpc/${PV}/samplecfg ${ROOT}/opt/fpc/lib/fpc/${PV} /etc
}