summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-08-21 06:31:52 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-08-21 06:31:52 +0000
commit6e2f56aa14e84db92ed3aca14fda41a54862889d (patch)
treeae28d99f0a75b2163d435ab8632c4731d5b30f33 /dev-lang/erlang
parentdon't install license file; fix desktop file so it passes KDE validation; all... (diff)
downloadgentoo-2-6e2f56aa14e84db92ed3aca14fda41a54862889d.tar.gz
gentoo-2-6e2f56aa14e84db92ed3aca14fda41a54862889d.tar.bz2
gentoo-2-6e2f56aa14e84db92ed3aca14fda41a54862889d.zip
install man files in own hierarchy in ERL_LIBDIR not in systemsystem-wide location, thus erl -man can find it; reported by Samuel Tesla <samuel.tesla@gmail.com> in bug 189639
(Portage version: 2.1.2.11)
Diffstat (limited to 'dev-lang/erlang')
-rw-r--r--dev-lang/erlang/ChangeLog10
-rw-r--r--dev-lang/erlang/erlang-11.2.5-r2.ebuild153
-rw-r--r--dev-lang/erlang/files/digest-erlang-11.2.5-r29
3 files changed, 171 insertions, 1 deletions
diff --git a/dev-lang/erlang/ChangeLog b/dev-lang/erlang/ChangeLog
index 237e6af4cd50..96a43768fe23 100644
--- a/dev-lang/erlang/ChangeLog
+++ b/dev-lang/erlang/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-lang/erlang
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.70 2007/08/15 07:59:27 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.71 2007/08/21 06:31:52 opfer Exp $
+
+*erlang-11.2.5-r2 (21 Aug 2007)
+
+ 21 Aug 2007; Christian Faulhammer <opfer@gentoo.org>
+ +erlang-11.2.5-r2.ebuild:
+ install man files in own hierarchy in ERL_LIBDIR not in systemsystem-wide
+ location, thus erl -man can find it; reported by Samuel Tesla
+ <samuel.tesla@gmail.com> in bug 189639
15 Aug 2007; Christian Faulhammer <opfer@gentoo.org>
files/50erlang-gentoo.el:
diff --git a/dev-lang/erlang/erlang-11.2.5-r2.ebuild b/dev-lang/erlang/erlang-11.2.5-r2.ebuild
new file mode 100644
index 000000000000..c543cfbab87a
--- /dev/null
+++ b/dev-lang/erlang/erlang-11.2.5-r2.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-11.2.5-r2.ebuild,v 1.1 2007/08/21 06:31:52 opfer Exp $
+
+inherit elisp-common eutils flag-o-matic multilib versionator
+
+# NOTE: You need to adjust the version number in the last comment. If you need symlinks for
+# binaries please tell maintainers or open up a bug to let it be created.
+
+# erlang uses a really weird versioning scheme which caused quite a few problems
+# already. Thus we do a slight modification converting all letters to digits to
+# make it more sane (see e.g. #26420)
+
+# the next line selects the right source.
+MY_PV="R$(get_major_version)B-$(get_version_component_range 3)"
+
+# ATTN!! Take care when processing the C, etc version!
+MY_P=otp_src_${MY_PV}
+
+DESCRIPTION="Erlang programming language, runtime environment, and large collection of libraries"
+HOMEPAGE="http://www.erlang.org/"
+SRC_URI="http://www.erlang.org/download/${MY_P}.tar.gz
+ doc? ( http://erlang.org/download/otp_doc_man_${MY_PV}.tar.gz
+ http://erlang.org/download/otp_doc_html_${MY_PV}.tar.gz )"
+
+LICENSE="EPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc emacs hipe java kpoll odbc smp ssl tk"
+
+RDEPEND=">=dev-lang/perl-5.6.1
+ ssl? ( >=dev-libs/openssl-0.9.7d )
+ emacs? ( virtual/emacs )
+ java? ( >=virtual/jdk-1.2 )
+ odbc? ( dev-db/unixODBC )"
+DEPEND="${RDEPEND}
+ tk? ( dev-lang/tk )"
+
+S="${WORKDIR}/${MY_P}"
+
+SITEFILE=50erlang-gentoo.el
+
+src_unpack() {
+ ## fix compilation on hardened systems, see bug #154338
+ filter-flags "-fstack-protector"
+ filter-flags "-fstack-protector-all"
+
+ unpack ${A}
+ cd "${S}"
+
+ # needed for amd64
+ epatch "${FILESDIR}/${PN}-10.2.6-export-TARGET.patch"
+ # needed for FreeBSD
+ epatch "${FILESDIR}/${PN}-11.2.5-gethostbyname.patch"
+ use odbc || sed -i 's: odbc : :' lib/Makefile
+
+ if use hipe; then
+ ewarn
+ ewarn "You enabled High performance Erlang. Be aware that this extension"
+ ewarn "can break the compilation in many ways, especially on hardened systems."
+ ewarn "Don't cry, don't file bugs, just disable it!"
+ ewarn
+ fi
+}
+
+src_compile() {
+ use java || export JAVAC=false
+
+ econf \
+ --enable-threads \
+ $(use_enable hipe) \
+ $(use_with ssl) \
+ $(use_enable kpoll kernell-poll) \
+ $(use_enable smp smp-support) \
+ || die "econf failed"
+ emake -j1 || die "emake failed"
+
+ if use emacs ; then
+ pushd lib/tools/emacs
+ elisp-compile *.el
+ popd
+ fi
+}
+
+extract_version() {
+ sed -n -e "/^$2 = \(.*\)$/s::\1:p" "${S}/$1/vsn.mk"
+}
+
+src_install() {
+ local ERL_LIBDIR=/usr/$(get_libdir)/erlang
+ local ERL_INTERFACE_VER=$(extract_version lib/erl_interface EI_VSN)
+ local ERL_ERTS_VER=$(extract_version erts VSN)
+
+ emake -j1 INSTALL_PREFIX="${D}" install || die "install failed"
+ dodoc AUTHORS README
+
+ dosym "${ERL_LIBDIR}/bin/erl" /usr/bin/erl
+ dosym "${ERL_LIBDIR}/bin/erlc" /usr/bin/erlc
+ dosym "${ERL_LIBDIR}/bin/ear" /usr/bin/ear
+ dosym "${ERL_LIBDIR}/bin/escript" /usr/bin/escript
+ dosym \
+ "${ERL_LIBDIR}/lib/erl_interface-${ERL_INTERFACE_VER}/bin/erl_call" \
+ /usr/bin/erl_call
+ dosym "${ERL_LIBDIR}/erts-${ERL_ERTS_VER}/bin/beam" /usr/bin/beam
+
+ ## Remove ${D} from the following files
+ dosed "${ERL_LIBDIR}/bin/erl"
+ dosed "${ERL_LIBDIR}/bin/start"
+ grep -rle "${D}" "${D}/${ERL_LIBDIR}/erts-${ERL_ERTS_VER}" | xargs sed -i -e "s:${D}::g"
+
+ ## Clean up the no longer needed files
+ rm "${D}/${ERL_LIBDIR}/Install"
+
+ if use doc ; then
+ for i in "${WORKDIR}"/man/man* ; do
+ dodir "${ERL_LIBDIR}/${i##${WORKDIR}}"
+ done
+ for file in "${WORKDIR}"/man/man*/*.[1-9]; do
+ # Man page processing tools expect a capitalized "SEE ALSO" section
+ # header
+ sed -i -e 's,\.SH See Also,\.SH SEE ALSO,g' ${newfile}
+ # doman sucks so we can't use it
+ cp ${file} "${D}/${ERL_LIBDIR}"/man/man${file##*.}/
+ done
+ dohtml -A README,erl,hrl,c,h,kwc,info -r \
+ "${WORKDIR}"/doc "${WORKDIR}"/lib "${WORKDIR}"/erts-*
+ fi
+
+ if use emacs ; then
+ pushd "${S}"
+ elisp-install erlang lib/tools/emacs/*.{el,elc}
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ popd
+ fi
+
+ # prepare erl for SMP, fixes bug #188112
+ use smp && sed -i -e 's:\(exec.*erlexec\):\1 -smp:' \
+ "${D}/${ERL_LIBDIR}/bin/erl"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ elog
+ elog "If you need a symlink to one of erlang's binaries,"
+ elog "please open a bug and tell the maintainers."
+ elog
+ elog "Gentoo's versioning scheme differs from the author's, so please refer to this version as R11B-5"
+ elog
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-lang/erlang/files/digest-erlang-11.2.5-r2 b/dev-lang/erlang/files/digest-erlang-11.2.5-r2
new file mode 100644
index 000000000000..77aa33e4a391
--- /dev/null
+++ b/dev-lang/erlang/files/digest-erlang-11.2.5-r2
@@ -0,0 +1,9 @@
+MD5 6a40146d855f98d024682cd24e9bb5bc otp_doc_html_R11B-5.tar.gz 4968176
+RMD160 73f8056b66f3bc6ec6b93c3c3dbfdf47074f8974 otp_doc_html_R11B-5.tar.gz 4968176
+SHA256 7dea67980b958ffebf7a94f3d94bd9c874e041f4f5ee574c56aab62c54a71d28 otp_doc_html_R11B-5.tar.gz 4968176
+MD5 5c387162ae6d255f525d72a91481d135 otp_doc_man_R11B-5.tar.gz 725858
+RMD160 62d200be6143183a17f5263b7341ec40afe298c7 otp_doc_man_R11B-5.tar.gz 725858
+SHA256 ab364af6e9db473d2bc5c0646a9b70989b858953ca9c053b78a509960a4f9caa otp_doc_man_R11B-5.tar.gz 725858
+MD5 96acec41da87d6ee0ef18e1aab36ffdd otp_src_R11B-5.tar.gz 38332865
+RMD160 67eac12a891df0e8d46b383ea0997f9de3aa6ac6 otp_src_R11B-5.tar.gz 38332865
+SHA256 d41fdfba40f86a50e04b7226ae5cc4581072fad26d14be5e1ca06603813bb175 otp_src_R11B-5.tar.gz 38332865