summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-09-19 17:12:54 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-09-19 17:12:54 +0000
commit4393e5999344662d4f74dc2f5fd981cccfb688ea (patch)
tree5d2f247b2f304ef7bdbe6aa1e972a2d675016e88 /dev-lang/confluence/confluence-0.10.6.ebuild
parentalpha/ia64/sparc stable wrt #283396 (diff)
downloadgentoo-2-4393e5999344662d4f74dc2f5fd981cccfb688ea.tar.gz
gentoo-2-4393e5999344662d4f74dc2f5fd981cccfb688ea.tar.bz2
gentoo-2-4393e5999344662d4f74dc2f5fd981cccfb688ea.zip
Migrate to EAPI 2 in order to remove built_with_use usage.
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'dev-lang/confluence/confluence-0.10.6.ebuild')
-rw-r--r--dev-lang/confluence/confluence-0.10.6.ebuild26
1 files changed, 8 insertions, 18 deletions
diff --git a/dev-lang/confluence/confluence-0.10.6.ebuild b/dev-lang/confluence/confluence-0.10.6.ebuild
index de2f69396274..debbb28b9c80 100644
--- a/dev-lang/confluence/confluence-0.10.6.ebuild
+++ b/dev-lang/confluence/confluence-0.10.6.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/confluence/confluence-0.10.6.ebuild,v 1.1 2008/01/06 20:19:37 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/confluence/confluence-0.10.6.ebuild,v 1.2 2009/09/19 17:12:54 betelgeuse Exp $
-inherit eutils
+EAPI="2"
-EAPI="1"
+inherit eutils
DESCRIPTION="a functional programming language for reactive system design (digital logic, hard-real-time software)"
HOMEPAGE="http://www.funhdl.org/wiki/doku.php?id=confluence"
@@ -15,22 +15,12 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
IUSE="+ocamlopt"
-RDEPEND="dev-lang/ocaml"
+# min version so we are sure we always have ocamlopt in IUSE
+RDEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]"
DEPEND="${RDEPEND}
sys-apps/sed"
-pkg_setup() {
- if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
- eerror "In order to build ${PN} with native code support from ocaml"
- eerror "You first need to have a native code ocaml compiler."
- eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
- die "Please install ocaml with ocamlopt useflag"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
# Install non binary stuff in share...
sed -i -e "s:lib/confluence:share/confluence:" Makefile || die "failed to sed the makefile"
sed -i -e "s:lib/confluence:share/confluence:" src/cfeval/cf.ml || die "failed to sed ml files"
@@ -53,5 +43,5 @@ src_install() {
emake -j1 PREFIX="${D}/usr" OCAMLLIB=`ocamlc -where` install || die "install failed"
echo "CF_LIB=/usr/share/confluence" > "${T}/99${PN}"
doenvd "${T}/99${PN}"
- dodoc NEWS
+ dodoc NEWS || die
}