summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-05-06 11:07:46 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-05-06 11:07:46 +0000
commitb40d5ff6fab00067924b7407a5c10ddd92fab409 (patch)
tree56d5926ce0ba544baf279733a1b4852d6bb47590 /dev-lang/boo
parentVersion bump. (diff)
downloadgentoo-2-b40d5ff6fab00067924b7407a5c10ddd92fab409.tar.gz
gentoo-2-b40d5ff6fab00067924b7407a5c10ddd92fab409.tar.bz2
gentoo-2-b40d5ff6fab00067924b7407a5c10ddd92fab409.zip
Fix bug 268610. Thanks to Priit Laes <amd@store20.com> for reporting.
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/boo')
-rw-r--r--dev-lang/boo/ChangeLog10
-rw-r--r--dev-lang/boo/boo-0.9.0.3203-r1.ebuild (renamed from dev-lang/boo/boo-0.9.0.3203.ebuild)19
-rw-r--r--dev-lang/boo/boo-0.9.1.3287-r1.ebuild (renamed from dev-lang/boo/boo-0.9.1.3287.ebuild)19
-rw-r--r--dev-lang/boo/files/boo-0.9.1.3287-GACproblems.patch29
4 files changed, 56 insertions, 21 deletions
diff --git a/dev-lang/boo/ChangeLog b/dev-lang/boo/ChangeLog
index 8894d57db9c9..d7ca488eae95 100644
--- a/dev-lang/boo/ChangeLog
+++ b/dev-lang/boo/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-lang/boo
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/boo/ChangeLog,v 1.27 2009/05/06 08:09:51 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/boo/ChangeLog,v 1.28 2009/05/06 11:07:45 loki_val Exp $
+
+*boo-0.9.1.3287-r1 (06 May 2009)
+*boo-0.9.0.3203-r1 (06 May 2009)
+
+ 06 May 2009; Peter Alfredsen <loki_val@gentoo.org> -boo-0.9.0.3203.ebuild,
+ +boo-0.9.0.3203-r1.ebuild, -boo-0.9.1.3287.ebuild,
+ +boo-0.9.1.3287-r1.ebuild, +files/boo-0.9.1.3287-GACproblems.patch:
+ Fix bug 268610. Thanks to Priit Laes <amd@store20.com> for reporting.
06 May 2009; Peter Alfredsen <loki_val@gentoo.org> boo-0.9.0.3203.ebuild,
boo-0.9.1.3287.ebuild:
diff --git a/dev-lang/boo/boo-0.9.0.3203.ebuild b/dev-lang/boo/boo-0.9.0.3203-r1.ebuild
index ae50d2b7c283..ec888c7da4c1 100644
--- a/dev-lang/boo/boo-0.9.0.3203.ebuild
+++ b/dev-lang/boo/boo-0.9.0.3203-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/boo/boo-0.9.0.3203.ebuild,v 1.2 2009/05/06 08:09:51 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/boo/boo-0.9.0.3203-r1.ebuild,v 1.1 2009/05/06 11:07:45 loki_val Exp $
EAPI=2
@@ -22,19 +22,17 @@ DEPEND="${RDEPEND}
app-arch/unzip
>=dev-dotnet/nant-0.86_beta1"
-MAKEOPTS="${MAKEOPTS} -j1"
-
RESTRICT="test"
-# Irritating bug: Boo has to be uninstalled for boo to compile.
pkg_setup() {
- if has_version ${CATEGORY}/${PN}
+ if /usr/bin/gacutil -l|grep Boo.Lang.Extensions &> /dev/null
then
- eerror "${CATEGORY}/${PN}'s install process is buggy. It requires that you remove any"
- eerror "existing install before attempting to reinstall it."
- eerror "Please emerge -C ${CATEGORY}/${PN} and try again."
- eerror "See http://bugs.gentoo.org/268610 for details."
- die "Please emerge -C ${CATEGORY}/${PN}"
+ eerror "$(best_version ${CATEGORY}/${PN}) has installed Boo.Lang.Extensions into the GAC."
+ eerror "This is a bug, that will cause compilation of ${CATEGORY}/${PF} to fail. It has"
+ eerror "been fixed in this version. For now, it requires that you uninstall"
+ eerror "${CATEGORY}/${PN} before updating."
+ eerror "Please run: emerge -C ${CATEGORY}/${PN} and try again."
+ die "Please run: emerge -C ${CATEGORY}/${PN} and try again."
fi
}
@@ -42,6 +40,7 @@ src_prepare() {
sed -i -e 's: Boo.Microsoft.Build.Tasks, update-vs2005-env,::' default.build || die
sed -i -e 's@${libdir}/boo@${libdir}/mono/boo@g' \
extras/boo.pc.in || die
+ epatch "${FILESDIR}/boo-0.9.1.3287-GACproblems.patch"
}
src_compile() {
diff --git a/dev-lang/boo/boo-0.9.1.3287.ebuild b/dev-lang/boo/boo-0.9.1.3287-r1.ebuild
index a6953ede7fd9..bc2ebc5d7ae1 100644
--- a/dev-lang/boo/boo-0.9.1.3287.ebuild
+++ b/dev-lang/boo/boo-0.9.1.3287-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/boo/boo-0.9.1.3287.ebuild,v 1.2 2009/05/06 08:09:51 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/boo/boo-0.9.1.3287-r1.ebuild,v 1.1 2009/05/06 11:07:45 loki_val Exp $
EAPI=2
@@ -22,19 +22,17 @@ DEPEND="${RDEPEND}
app-arch/unzip
>=dev-dotnet/nant-0.86_beta1"
-MAKEOPTS="${MAKEOPTS} -j1"
-
RESTRICT="test"
-# Irritating bug: Boo has to be uninstalled for boo to compile.
pkg_setup() {
- if has_version ${CATEGORY}/${PN}
+ if /usr/bin/gacutil -l|grep Boo.Lang.Extensions &> /dev/null
then
- eerror "${CATEGORY}/${PN}'s install process is buggy. It requires that you remove any"
- eerror "existing install before attempting to reinstall it."
- eerror "Please emerge -C ${CATEGORY}/${PN} and try again."
- eerror "See http://bugs.gentoo.org/268610 for details."
- die "Please emerge -C ${CATEGORY}/${PN}"
+ eerror "$(best_version ${CATEGORY}/${PN}) has installed Boo.Lang.Extensions into the GAC."
+ eerror "This is a bug, that will cause compilation of ${CATEGORY}/${PF} to fail. It has"
+ eerror "been fixed in this version. For now, it requires that you uninstall"
+ eerror "${CATEGORY}/${PN} before updating."
+ eerror "Please run: emerge -C ${CATEGORY}/${PN} and try again."
+ die "Please run: emerge -C ${CATEGORY}/${PN} and try again."
fi
}
@@ -42,6 +40,7 @@ src_prepare() {
sed -i -e 's: Boo.Microsoft.Build.Tasks, update-vs2005-env,::' default.build || die
sed -i -e 's@${libdir}/boo@${libdir}/mono/boo@g' \
extras/boo.pc.in || die
+ epatch "${FILESDIR}/boo-0.9.1.3287-GACproblems.patch"
}
src_compile() {
diff --git a/dev-lang/boo/files/boo-0.9.1.3287-GACproblems.patch b/dev-lang/boo/files/boo-0.9.1.3287-GACproblems.patch
new file mode 100644
index 000000000000..e563bcf8b905
--- /dev/null
+++ b/dev-lang/boo/files/boo-0.9.1.3287-GACproblems.patch
@@ -0,0 +1,29 @@
+diff -NrU5 boo-0.9.1.3287.orig/default.build boo-0.9.1.3287/default.build
+--- boo-0.9.1.3287.orig/default.build 2009-05-06 12:07:51.000000000 +0200
++++ boo-0.9.1.3287/default.build 2009-05-06 12:25:31.000000000 +0200
+@@ -561,17 +561,24 @@
+ <include name="*.exe"/>
+ <include name="*.rsp"/>
+ <include name="*.config"/>
+ <include name="*.targets"/>
+ <include name="*.Tasks.dll" />
++ <include name="Boo.Lang.Extensions.dll" />
+ </fileset>
+ </copy>
+
+ <foreach item="File" property="filename">
+ <in>
+ <items>
+- <include name="${build.dir}/Boo.Lang*.dll" />
++ <include name="${build.dir}/Boo.Lang.dll" />
++ <include name="${build.dir}/Boo.Lang.CodeDom.dll" />
++ <include name="${build.dir}/Boo.Lang.Compiler.dll" />
++ <include name="${build.dir}/Boo.Lang.Interpreter.dll" />
++ <include name="${build.dir}/Boo.Lang.Parser.dll" />
++ <include name="${build.dir}/Boo.Lang.PatternMatching.dll" />
++ <include name="${build.dir}/Boo.Lang.Useful.dll" />
+ </items>
+ </in>
+ <do>
+ <exec program="gacutil" useruntimeengine="false" workingdir="${build.dir}">
+ <arg value="/i" />