summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-10-24 03:24:26 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-10-24 03:24:26 +0000
commita6835f92c074953735157a431f9db99dc7dd83d9 (patch)
treecd9abf1b8a6fe3d930999feabe8d3189a396fddb /dev-lang/R
parentMarked stable on amd64 for bug #136665 (diff)
downloadgentoo-2-a6835f92c074953735157a431f9db99dc7dd83d9.tar.gz
gentoo-2-a6835f92c074953735157a431f9db99dc7dd83d9.tar.bz2
gentoo-2-a6835f92c074953735157a431f9db99dc7dd83d9.zip
Fixed linking problems with as-needed. See bug #151908.
(Portage version: 2.1.2_pre3-r7)
Diffstat (limited to 'dev-lang/R')
-rw-r--r--dev-lang/R/ChangeLog6
-rw-r--r--dev-lang/R/R-2.4.0.ebuild3
-rw-r--r--dev-lang/R/files/R-2.4.0-as-needed-gentoo.patch12
3 files changed, 19 insertions, 2 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index bc7d64711309..41bf5b963ce5 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/R
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.79 2006/10/22 18:26:25 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.80 2006/10/24 03:24:26 markusle Exp $
+
+ 24 Oct 2006; Markus Dittrich <markusle@gentoo.org>
+ +files/R-2.4.0-as-needed-gentoo.patch, R-2.4.0.ebuild:
+ Fixed linking problems with as-needed. See bug #151908.
22 Oct 2006; Markus Dittrich <markusle@gentoo.org> R-2.4.0.ebuild:
Append -std=gnu99 to CFLAGS since it is needed to compile
diff --git a/dev-lang/R/R-2.4.0.ebuild b/dev-lang/R/R-2.4.0.ebuild
index ba1fdf9df8fc..da14bd294e34 100644
--- a/dev-lang/R/R-2.4.0.ebuild
+++ b/dev-lang/R/R-2.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.4.0.ebuild,v 1.2 2006/10/22 18:26:25 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.4.0.ebuild,v 1.3 2006/10/24 03:24:26 markusle Exp $
inherit fortran toolchain-funcs flag-o-matic
@@ -55,6 +55,7 @@ pkg_setup() {
src_unpack() {
unpack ${A}
sed -i -e "s:-fpic:-fPIC:g" ${S}/configure
+ epatch "${FILESDIR}"/${P}-as-needed-gentoo.patch
}
src_compile() {
diff --git a/dev-lang/R/files/R-2.4.0-as-needed-gentoo.patch b/dev-lang/R/files/R-2.4.0-as-needed-gentoo.patch
new file mode 100644
index 000000000000..ececae4ba63d
--- /dev/null
+++ b/dev-lang/R/files/R-2.4.0-as-needed-gentoo.patch
@@ -0,0 +1,12 @@
+diff -Naur R-2.4.0/src/modules/lapack/Makefile.in R-2.4.0-new/src/modules/lapack/Makefile.in
+--- R-2.4.0/src/modules/lapack/Makefile.in 2006-09-04 10:41:35.000000000 -0400
++++ R-2.4.0-new/src/modules/lapack/Makefile.in 2006-10-23 22:40:05.000000000 -0400
+@@ -78,7 +78,7 @@
+ ## Include BLAS here, as with (static) ATLAS that pulls all the
+ ## BLAS routines into one place.
+ $(Rlapack_la): $(LIBOBJECTS)
+- $(DYLIB_LINK) -o $@ $(LIBOBJECTS) @BLAS_LIBS@ $(Rlapack_la_LIBADD)
++ $(DYLIB_LINK) -o $@ $(LIBOBJECTS) @BLAS_LIBS@ $(Rlapack_la_LIBADD) $(FLIBS)
+
+ Rlapack_install: $(Rlapack_la)
+ @$(MKINSTALLDIRS) $(Rexeclibdir)