summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-12-12 20:59:35 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-12-12 20:59:35 +0000
commit9705b7ddbb3ebb82e14b09d35aecc274cbaac962 (patch)
treef1d1547764154f7650a53489365e7e325c303438 /dev-lang/R
parentfixed makemaker version (diff)
downloadgentoo-2-9705b7ddbb3ebb82e14b09d35aecc274cbaac962.tar.gz
gentoo-2-9705b7ddbb3ebb82e14b09d35aecc274cbaac962.tar.bz2
gentoo-2-9705b7ddbb3ebb82e14b09d35aecc274cbaac962.zip
version update,
Diffstat (limited to 'dev-lang/R')
-rw-r--r--dev-lang/R/ChangeLog13
-rw-r--r--dev-lang/R/R-1.6.1.ebuild96
-rw-r--r--dev-lang/R/files/digest-R-1.6.11
3 files changed, 107 insertions, 3 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index bebdb6ae161b..6dee9af471cb 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,11 +1,18 @@
# ChangeLog for dev-lang/R
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.5 2002/12/09 04:20:57 manson Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.6 2002/12/12 20:59:35 george Exp $
-\* Autoupdate keywords (12-6-02)
+*R-1.6.1 (12 Dec 2002)
+
+ 12 Dec 2002; George Shapovalov <george@gentoo.org> R-1.6.1.ebuild :
+
+ version update, patching is unnecessary now.
+ Update subitted by Sam Wouters <sam.wouters@esat.kuleuven.ac.be>, see #11313
+
+* Autoupdate keywords (12-6-02)
06 Dec 2002; Rodney Rees <manson@gentoo.org> changed sparc ~sparc keywords
-*R-1.5.1-ebuild (11 July 2002)
+*R-1.5.1 (11 July 2002)
09 Aug 2002; George Shapovalov <george@gentoo.org> R-1.5.1.ebuild :
diff --git a/dev-lang/R/R-1.6.1.ebuild b/dev-lang/R/R-1.6.1.ebuild
new file mode 100644
index 000000000000..4c88c22faffe
--- /dev/null
+++ b/dev-lang/R/R-1.6.1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.6.1.ebuild,v 1.1 2002/12/12 20:59:35 george Exp $
+
+IUSE="atlas X tcltk gnome"
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
+
+SRC_URI="http://cran.r-project.org/src/base/${P}.tgz"
+
+ #There are daily release patches, don't know how to utilize these
+ #"ftp://ftp.stat.math.ethz.ch/Software/${PN}/${PN}-release.diff.gz"
+
+HOMEPAGE="http://www.r-project.org/"
+
+DEPEND="virtual/glibc
+ >=sys-devel/perl-5.6.1-r3
+ >=sys-libs/readline-4.1-r3
+ >=sys-libs/zlib-1.1.3-r2
+ >=media-libs/jpeg-6b-r2
+ >=media-libs/libpng-1.2.1
+ atlas? ( dev-libs/atlas )
+ X? ( virtual/x11 )
+ tcltk? ( dev-lang/tk )
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.4 )"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~x86 ~sparc"
+
+src_compile() {
+
+ local myconf="--enable-R-profiling --enable-R-shlib --with-readline"
+
+ #Eventually, we will want to take into account that a user may have
+ #an alternate or additional blas libraries,
+ #i.e. USE variable blas and and virtual/blas
+ use atlas || myconf="${myconf} --without-blas" #default enabled
+
+ use X || myconf="${myconf} --without-x" #default enabled
+
+ if use tcltk; then
+ #configure needs to find the files tclConfig.sh and tkConfig.sh
+ myconf="${myconf} --with-tcltk --with-tcl-config=/usr/lib --with-tk-config=/usr/lib"
+ else
+ myconf="${myconf} --without-tcltk"
+ fi
+
+ use gnome && myconf="${myconf} --with-gnome" #default disabled
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} || die "./configure failed"
+
+ make || die
+
+}
+
+src_install () {
+
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die "Installation Failed"
+
+ #fix the R wrapper script to have the correct R_HOME_DIR
+ #sed regexp borrowed from included debian rules
+ cp ${D}/usr/lib/R/bin/R ${S}/bin/R.orig
+ sed -e '/^R_HOME_DIR=.*/s::R_HOME_DIR=/usr/lib/R:' \
+ ${S}/bin/R.orig > ${D}/usr/lib/R/bin/R
+
+ #R installs two identical wrappers under /usr/bin and /usr/lib/R/bin/
+ #the 2nd one is corrected by above sed, for the 1st
+ #I'll just symlink it into /usr/bin
+ cd ${D}/usr/bin/
+ rm R
+ dosym ../lib/R/bin/R /usr/bin/R
+ cd ${S}
+
+ dodoc AUTHORS BUGS COPYING* ChangeLog FAQ INSTALL *NEWS README \
+ RESOURCES THANKS VERSION Y2K
+
+ #Add rudimentary menu entry if gnome
+ if use gnome; then
+ insinto /usr/share/gnome/apps/Applications
+ doins ${FILESDIR}/R.desktop
+ insinto /usr/share/pixmaps
+ doins ${FILESDIR}/R-logo.png
+ fi
+
+}
diff --git a/dev-lang/R/files/digest-R-1.6.1 b/dev-lang/R/files/digest-R-1.6.1
new file mode 100644
index 000000000000..28beb4902703
--- /dev/null
+++ b/dev-lang/R/files/digest-R-1.6.1
@@ -0,0 +1 @@
+MD5 7c9b8e8582812448aedd0322bcc135eb R-1.6.1.tgz 8633830