summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-10-31 13:05:36 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-10-31 13:05:36 +0000
commit8dff6c4eeb56ca015b27e0ec8218a4482d43a94d (patch)
tree87a3a597d5ca56c01067f82f314f791a24acbf7b /dev-lang/R
parentUpdated .DirIcon file type detection to match new output I'm getting from a (diff)
downloadgentoo-2-8dff6c4eeb56ca015b27e0ec8218a4482d43a94d.tar.gz
gentoo-2-8dff6c4eeb56ca015b27e0ec8218a4482d43a94d.tar.bz2
gentoo-2-8dff6c4eeb56ca015b27e0ec8218a4482d43a94d.zip
Fixed bug in source code preventing building with USE=-X (see bug #245027).
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-SENTINEL-1 i686)
Diffstat (limited to 'dev-lang/R')
-rw-r--r--dev-lang/R/ChangeLog7
-rw-r--r--dev-lang/R/R-2.8.0.ebuild8
-rw-r--r--dev-lang/R/files/R-2.8.0-without-X.patch14
3 files changed, 27 insertions, 2 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index 0d895a8739bb..8954d478d2e2 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/R
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.140 2008/10/30 10:23:33 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.141 2008/10/31 13:05:36 markusle Exp $
+
+ 31 Oct 2008; Markus Dittrich <markusle@gentoo.org>
+ +files/R-2.8.0-without-X.patch, R-2.8.0.ebuild:
+ Fixed bug in source code preventing building with USE="-X" (see bug
+ #245027). Thanks much to Andrew Savchenko for his patch.
30 Oct 2008; Raúl Porcel <armin76@gentoo.org> R-2.7.2.ebuild:
alpha/ia64 stable #244621
diff --git a/dev-lang/R/R-2.8.0.ebuild b/dev-lang/R/R-2.8.0.ebuild
index 00093b0c7fd7..91020759c2e4 100644
--- a/dev-lang/R/R-2.8.0.ebuild
+++ b/dev-lang/R/R-2.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.8.0.ebuild,v 1.1 2008/10/27 10:32:14 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.8.0.ebuild,v 1.2 2008/10/31 13:05:36 markusle Exp $
EAPI=2
inherit eutils fortran flag-o-matic bash-completion versionator
@@ -76,6 +76,12 @@ src_prepare() {
fi
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-without-X.patch
+}
+
src_configure() {
econf \
--disable-rpath \
diff --git a/dev-lang/R/files/R-2.8.0-without-X.patch b/dev-lang/R/files/R-2.8.0-without-X.patch
new file mode 100644
index 000000000000..0fefc65083ef
--- /dev/null
+++ b/dev-lang/R/files/R-2.8.0-without-X.patch
@@ -0,0 +1,14 @@
+# missing ; in source code causes build failure when configured via
+# --without-X
+diff -Naur R-2.8.0/src/main/platform.c R-2.8.0.new/src/main/platform.c
+--- R-2.8.0/src/main/platform.c 2008-10-07 22:05:05.000000000 -0400
++++ R-2.8.0.new/src/main/platform.c 2008-10-31 08:44:10.000000000 -0400
+@@ -1654,7 +1654,7 @@
+ # ifdef HAVE_X11
+ int X11 = NA_LOGICAL;
+ # else
+- int X11 = FALSE
++ int X11 = FALSE;
+ # endif
+ #endif
+