summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-03-19 16:38:16 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-03-19 16:38:16 +0000
commit4742124907afda90f3b7b1c36247fd2bf9476d28 (patch)
treed3cef8c45dfb2af6890c20cb73b00146d6d94a27 /dev-lang/R
parentNew ebuild for x11-misc/mate-menu-editor, Mozo menu editor for MATE; imported... (diff)
downloadgentoo-2-4742124907afda90f3b7b1c36247fd2bf9476d28.tar.gz
gentoo-2-4742124907afda90f3b7b1c36247fd2bf9476d28.tar.bz2
gentoo-2-4742124907afda90f3b7b1c36247fd2bf9476d28.zip
Version bump
(Portage version: 2.2.8-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'dev-lang/R')
-rw-r--r--dev-lang/R/ChangeLog9
-rw-r--r--dev-lang/R/R-3.0.1-r1.ebuild24
-rw-r--r--dev-lang/R/R-3.0.3.ebuild200
-rw-r--r--dev-lang/R/files/R-2.11.1-parallel.patch7
-rw-r--r--dev-lang/R/files/R-2.13.1-zlib_header_fix.patch7
-rw-r--r--dev-lang/R/files/R-3.0.0-rmath-shared.patch3
6 files changed, 239 insertions, 11 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index ad367ccc4662..f00a9d4586ed 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/R
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.231 2014/03/02 21:33:49 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.232 2014/03/19 16:38:16 bicatali Exp $
+
+*R-3.0.3 (19 Mar 2014)
+
+ 19 Mar 2014; Sébastien Fabbro <bicatali@gentoo.org> +R-3.0.3.ebuild,
+ R-3.0.1-r1.ebuild, files/R-2.11.1-parallel.patch,
+ files/R-2.13.1-zlib_header_fix.patch, files/R-3.0.0-rmath-shared.patch:
+ Version bump
02 Mar 2014; Andreas K. Huettel <dilfridge@gentoo.org> R-3.0.2.ebuild:
Add subslot dependency on dev-libs/icu
diff --git a/dev-lang/R/R-3.0.1-r1.ebuild b/dev-lang/R/R-3.0.1-r1.ebuild
index 3fc719be9820..81878716416f 100644
--- a/dev-lang/R/R-3.0.1-r1.ebuild
+++ b/dev-lang/R/R-3.0.1-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-3.0.1-r1.ebuild,v 1.2 2013/11/03 20:38:33 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-3.0.1-r1.ebuild,v 1.3 2014/03/19 16:38:16 bicatali Exp $
EAPI=5
-inherit bash-completion-r1 autotools eutils flag-o-matic fortran-2 multilib versionator toolchain-funcs
+inherit bash-completion-r1 autotools eutils flag-o-matic fortran-2 multilib versionator toolchain-funcs java-pkg-opt-2
BCP=${PN}-20130129.bash_completion
DESCRIPTION="Language and environment for statistical computing and graphics"
@@ -39,12 +39,13 @@ DEPEND="${CDEPEND}
doc? (
virtual/latex-base
dev-texlive/texlive-fontsrecommended
- )"
+ )
+ java? ( >=virtual/jdk-1.5 )"
RDEPEND="${CDEPEND}
( || ( <sys-libs/zlib-1.2.5.1-r1 >=sys-libs/zlib-1.2.5.1-r2[minizip] ) )
app-arch/xz-utils
- java? ( >=virtual/jre-1.5 )"
+ java? ( >=virtual/jdk-1.5 )"
RESTRICT="minimal? ( test )"
@@ -56,6 +57,12 @@ pkg_setup() {
tc-has-openmp || die "Please enable openmp support in your compiler"
fi
fortran-2_pkg_setup
+
+ # Selects the build VM according to DEPEND and user preferences.
+ # Also sets VM specific addpredict and environment variables.
+ # Does nothing if java is disabled.
+ java-pkg-opt-2_pkg_setup
+
filter-ldflags -Wl,-Bdirect -Bdirect
# avoid using existing R installation
unset R_HOME
@@ -106,6 +113,8 @@ src_prepare() {
use perl && \
export PERL5LIB="${S}/share/perl:${PERL5LIB:+:}${PERL5LIB}"
+ java-pkg-opt-2_src_prepare
+
# don't search /usr/local
sed -i -e '/FLAGS=.*\/local\//c\: # removed by ebuild' configure.ac || die
# Fix for Darwin (OS X)
@@ -130,6 +139,11 @@ src_prepare() {
}
src_configure() {
+ # configure shouldn't run checks for java if disabled.
+ # Requires properly setup JVM or a addpredict hack for
+ # /proc/self/coredump_filter and possibly others.
+ # $(use_enable java)
+
econf \
--enable-byte-compiled-packages \
--enable-R-shlib \
diff --git a/dev-lang/R/R-3.0.3.ebuild b/dev-lang/R/R-3.0.3.ebuild
new file mode 100644
index 000000000000..190a2925d47f
--- /dev/null
+++ b/dev-lang/R/R-3.0.3.ebuild
@@ -0,0 +1,200 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-3.0.3.ebuild,v 1.1 2014/03/19 16:38:16 bicatali Exp $
+
+EAPI=5
+
+inherit bash-completion-r1 eutils flag-o-matic fortran-2 multilib versionator toolchain-funcs
+
+BCP=${PN}-20130129.bash_completion
+DESCRIPTION="Language and environment for statistical computing and graphics"
+HOMEPAGE="http://www.r-project.org/"
+SRC_URI="
+ mirror://cran/src/base/R-3/${P}.tar.gz
+ bash-completion? ( http://dev.gentoo.org/~bicatali/distfiles/${BCP}.bz2 )"
+
+LICENSE="|| ( GPL-2 GPL-3 ) LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="bash-completion cairo doc icu java jpeg lapack minimal nls openmp perl png prefix profile readline static-libs tiff tk X"
+REQUIRED_USE="png? ( || ( cairo X ) ) jpeg? ( || ( cairo X ) ) tiff? ( || ( cairo X ) )"
+
+CDEPEND="
+ app-arch/bzip2:0=
+ app-arch/xz-utils:0=
+ app-text/ghostscript-gpl
+ dev-libs/libpcre:3=
+ virtual/blas:0
+ || ( >=sys-apps/coreutils-8.15 sys-freebsd/freebsd-bin app-misc/realpath )
+ cairo? ( x11-libs/cairo[X] x11-libs/pango )
+ icu? ( dev-libs/icu:= )
+ jpeg? ( virtual/jpeg:0 )
+ lapack? ( virtual/lapack:0 )
+ perl? ( dev-lang/perl )
+ png? ( media-libs/libpng:0= )
+ readline? ( sys-libs/readline:0= )
+ tiff? ( media-libs/tiff:0= )
+ tk? ( dev-lang/tk:0= )
+ X? ( x11-libs/libXmu:0= x11-misc/xdg-utils )"
+
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? (
+ virtual/latex-base
+ dev-texlive/texlive-fontsrecommended
+ )"
+
+RDEPEND="${CDEPEND}
+ ( || ( <sys-libs/zlib-1.2.5.1-r1:0= >=sys-libs/zlib-1.2.5.1-r2:0=[minizip] ) )
+ java? ( >=virtual/jre-1.5 )"
+
+RESTRICT="minimal? ( test )"
+
+R_DIR="${EROOT%/}/usr/$(get_libdir)/${PN}"
+
+pkg_setup() {
+ if use openmp; then
+ if [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then
+ ewarn "OpenMP is not available in your current selected gcc"
+ die "need openmp capable gcc"
+ fi
+ FORTRAN_NEED_OPENMP=1
+ fi
+ fortran-2_pkg_setup
+ filter-ldflags -Wl,-Bdirect -Bdirect
+ # avoid using existing R installation
+ unset R_HOME
+ # Temporary fix for bug #419761
+ if [[ ($(tc-getCC) == *gcc) && ($(gcc-version) == 4.7) ]]; then
+ append-flags -fno-ipa-cp-clone
+ fi
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-2.11.1-parallel.patch \
+ "${FILESDIR}"/${PN}-2.13.1-zlib_header_fix.patch \
+ "${FILESDIR}"/${PN}-3.0.0-rmath-shared.patch
+
+ # fix packages.html for doc (gentoo bug #205103)
+ sed -i \
+ -e "s:../../../library:../../../../$(get_libdir)/R/library:g" \
+ src/library/tools/R/Rd.R || die
+
+ # fix Rscript path when installed (gentoo bug #221061)
+ sed -i \
+ -e "s:-DR_HOME='\"\$(rhome)\"':-DR_HOME='\"${R_DIR}\"':" \
+ src/unix/Makefile.in || die "sed unix Makefile failed"
+
+ # fix HTML links to manual (gentoo bug #273957)
+ sed -i \
+ -e 's:\.\./manual/:manual/:g' \
+ $(grep -Flr ../manual/ doc) || die "sed for HTML links failed"
+
+ use lapack && \
+ export LAPACK_LIBS="$($(tc-getPKG_CONFIG) --libs lapack)"
+
+ if use X; then
+ export R_BROWSER="$(type -p xdg-open)"
+ export R_PDFVIEWER="$(type -p xdg-open)"
+ fi
+ use perl && \
+ export PERL5LIB="${S}/share/perl:${PERL5LIB:+:}${PERL5LIB}"
+
+ # don't search /usr/local
+ sed -i -e '/FLAGS=.*\/local\//c\: # removed by ebuild' configure.ac || die
+ # Fix for Darwin (OS X)
+ if use prefix; then
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ sed -i \
+ -e 's:-install_name libR.dylib:-install_name ${libdir}/R/lib/libR.dylib:' \
+ -e 's:-install_name libRlapack.dylib:-install_name ${libdir}/R/lib/libRlapack.dylib:' \
+ -e 's:-install_name libRblas.dylib:-install_name ${libdir}/R/lib/libRblas.dylib:' \
+ -e "/SHLIB_EXT/s/\.so/.dylib/" \
+ configure.ac || die
+ # sort of "undo" 2.14.1-rmath-shared.patch
+ sed -i \
+ -e "s:-Wl,-soname=libRmath.so:-install_name ${EROOT%/}/usr/$(get_libdir)/libRmath.dylib:" \
+ src/nmath/standalone/Makefile.in || die
+ else
+ append-ldflags -Wl,-rpath="${EROOT%/}/usr/$(get_libdir)/R/lib"
+ fi
+ fi
+}
+
+src_configure() {
+ econf \
+ --enable-byte-compiled-packages \
+ --enable-R-shlib \
+ --disable-R-framework \
+ --with-system-zlib \
+ --with-system-bzlib \
+ --with-system-pcre \
+ --with-system-xz \
+ --with-blas="$($(tc-getPKG_CONFIG) --variable=libdir blas)" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ rdocdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable nls) \
+ $(use_enable openmp) \
+ $(use_enable profile R-profiling) \
+ $(use_enable profile memory-profiling) \
+ $(use_enable static-libs static) \
+ $(use_enable static-libs R-static-lib) \
+ $(use_with cairo) \
+ $(use_with icu ICU) \
+ $(use_with jpeg jpeglib) \
+ $(use_with lapack) \
+ $(use_with !minimal recommended-packages) \
+ $(use_with png libpng) \
+ $(use_with readline) \
+ $(use_with tiff libtiff) \
+ $(use_with tk tcltk) \
+ $(use_with tk tk-config "${EPREFIX}"/usr/lib/tkConfig.sh) \
+ $(use_with tk tcl-config "${EPREFIX}"/usr/lib/tclConfig.sh) \
+ $(use_with X x)
+}
+
+src_compile() {
+ export VARTEXFONTS="${T}/fonts"
+ emake AR="$(tc-getAR)"
+ emake -C src/nmath/standalone shared $(use static-libs && echo static) AR="$(tc-getAR)"
+ use doc && emake info pdf
+}
+
+src_install() {
+ default
+ emake -j1 -C src/nmath/standalone DESTDIR="${D}" install
+
+ if use doc; then
+ emake DESTDIR="${D}" install-info install-pdf
+ dosym ../manual /usr/share/doc/${PF}/html/manual
+ fi
+
+ cat > 99R <<-EOF
+ LDPATH=${R_DIR}/lib
+ R_HOME=${R_DIR}
+ EOF
+ doenvd 99R
+ use bash-completion && newbashcomp "${WORKDIR}"/${BCP} ${PN}
+ # The buildsystem has a different understanding of install_names than what
+ # we require. Since it builds modules like shared objects (wrong), many
+ # objects (all modules) get an incorrect install_name. Fixing the build
+ # system here is not really trivial.
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ local mod
+ pushd "${ED}"/usr/lib/R > /dev/null
+ for mod in $(find . -name "*.dylib") ; do
+ mod=${mod#./}
+ install_name_tool -id "${EPREFIX}/usr/lib/R/${mod}" \
+ "${mod}"
+ done
+ popd > /dev/null
+ fi
+}
+
+pkg_postinst() {
+ if use java; then
+ einfo "Re-initializing java paths for ${P}"
+ R CMD javareconf
+ fi
+}
diff --git a/dev-lang/R/files/R-2.11.1-parallel.patch b/dev-lang/R/files/R-2.11.1-parallel.patch
index 2be95349095a..c713d335badd 100644
--- a/dev-lang/R/files/R-2.11.1-parallel.patch
+++ b/dev-lang/R/files/R-2.11.1-parallel.patch
@@ -1,7 +1,8 @@
-Fix ocasional failure with parallel install (bug #322965)
-Patch by Sebastien Fabbro
+Fix ocasional failure with parallel install
+Gentoo bug: https://bugs.gentoo.org/show_bug.cgi?id=322965
+R bug: https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14505
-https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14505
+Patch by Sebastien Fabbro
--- src/include/Makefile.in.orig 2010-06-15 18:18:54.000000000 +0000
+++ src/include/Makefile.in 2010-06-15 18:19:48.000000000 +0000
diff --git a/dev-lang/R/files/R-2.13.1-zlib_header_fix.patch b/dev-lang/R/files/R-2.13.1-zlib_header_fix.patch
index 42e3b8a811c5..136acb26055f 100644
--- a/dev-lang/R/files/R-2.13.1-zlib_header_fix.patch
+++ b/dev-lang/R/files/R-2.13.1-zlib_header_fix.patch
@@ -1,6 +1,9 @@
-Update for zlib header changes
+Update for zlib header changes for zlib > 1.2.5
-https://bugs.gentoo.org/show_bug.cgi?id=383431
+Gentoo bug: https://bugs.gentoo.org/show_bug.cgi?id=383431
+R bug: https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14951
+
+Patch by Michael Schreckenbauer
--- src/main/unzip.h.orig 2011-09-24 19:35:53.000000000 -0700
+++ src/main/unzip.h 2011-09-24 19:37:06.000000000 -0700
diff --git a/dev-lang/R/files/R-3.0.0-rmath-shared.patch b/dev-lang/R/files/R-3.0.0-rmath-shared.patch
index 4f8f3956d2c0..f53fb7910511 100644
--- a/dev-lang/R/files/R-3.0.0-rmath-shared.patch
+++ b/dev-lang/R/files/R-3.0.0-rmath-shared.patch
@@ -1,7 +1,10 @@
Link with libm to fix unresolved symbols when linked with as-needed
and add a soname to the standalone math library
+R bug: https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14953
+
Patch by Sebastien Fabbro
Adapted to R-3.0.0 by Denis Dupeyron
+
--- src/nmath/standalone/Makefile.in.orig 2013-04-04 14:39:15.777544946 -0600
+++ src/nmath/standalone/Makefile.in 2013-04-04 14:40:51.256153179 -0600
@@ -64,7 +64,8 @@