summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTod Neidt <tod@gentoo.org>2002-02-20 06:12:22 +0000
committerTod Neidt <tod@gentoo.org>2002-02-20 06:12:22 +0000
commit123b3faa2fec142247b9bf035ddbe5043d4be6d1 (patch)
tree5bcf51346242c67c30deaebf113d5eff8707b112 /dev-lang/R
parentsmall dep and syntax update fixes; no rev bump. (diff)
downloadgentoo-2-123b3faa2fec142247b9bf035ddbe5043d4be6d1.tar.gz
gentoo-2-123b3faa2fec142247b9bf035ddbe5043d4be6d1.tar.bz2
gentoo-2-123b3faa2fec142247b9bf035ddbe5043d4be6d1.zip
Initial commit. R is GNU S, a language and environment for statistical computing and graphics. New USE variable 'atlas' used to specify building with auto tuned blas library. Rudimentary .desktop added if gnome is specified (needs work, but works). Html help in gnome is not accesible from toolbar unless netscape is merged (needs work). May need to request portage category 'dev-R' as there are many add-on modules available similar to perl and python.
Diffstat (limited to 'dev-lang/R')
-rw-r--r--dev-lang/R/ChangeLog21
-rw-r--r--dev-lang/R/R-1.4.1.ebuild84
-rw-r--r--dev-lang/R/files/R-logo.pngbin0 -> 4867 bytes
-rw-r--r--dev-lang/R/files/R.desktop17
-rw-r--r--dev-lang/R/files/digest-R-1.4.11
5 files changed, 123 insertions, 0 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
new file mode 100644
index 000000000000..920d488a8e2b
--- /dev/null
+++ b/dev-lang/R/ChangeLog
@@ -0,0 +1,21 @@
+# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.1 2002/02/20 06:12:22 tod Exp $
+
+*R-1.4.1 (19 Feb 2002)
+
+ 19 Feb 2002; T.Neidt <tod@gentoo.org> ChangeLog, R-1.4.1.ebuild :
+
+ Initial commit. R is GNU S - A language and environment for statistical
+ computing and graphics. Gnome and tcltk gui's are available if in USE.
+
+ If gnome, a rudimentary menu entry is made under Applications.
+ However, it has the annoying tendency to pop up a terminal window to start
+ the gui. (todo 1)
+
+ Also, the html files are not accessible from the toolbar menu entry unless
+ you happen to be running netscape. (todo 2)
+
+ This ebuild makes use of a new USE variable, 'atlas', which will compile
+ R using the auto-tuned blas libraries provided by atlas. NOTE: atlas ebuild
+ currently only provides static libraries. Shared libraries are in the works.
diff --git a/dev-lang/R/R-1.4.1.ebuild b/dev-lang/R/R-1.4.1.ebuild
new file mode 100644
index 000000000000..61344e3929e9
--- /dev/null
+++ b/dev-lang/R/R-1.4.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Tod Neidt <tod@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.4.1.ebuild,v 1.1 2002/02/20 06:12:22 tod Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
+
+SRC_URI="http://cran.r-project.org/src/base/${P}.tgz"
+
+ #There are daily release patches, don't know how to utilize these
+ #"ftp://ftp.stat.math.ethz.ch/Software/${PN}/${PN}-release.diff.gz"
+
+HOMEPAGE="http://www.r-project.org/"
+
+DEPEND="virtual/glibc
+ >=sys-devel/perl-5.6.1-r3
+ >=sys-libs/readline-4.1-r3
+ >=sys-libs/zlib-1.1.3-r2
+ >=media-libs/jpeg-6b-r2
+ >=media-libs/libpng-1.0.12
+ atlas? ( dev-libs/atlas )
+ X? ( virtual/x11 )
+ tcltk? ( dev-lang/tk )
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.4 )"
+
+src_compile() {
+
+ local myconf="--enable-R-profiling --enable-R-shlib --with-readline"
+
+ #Eventually, we will want to take into account that a user may have
+ #an alternate or additional blas libraries,
+ #i.e. USE variable blas and and virtual/blas
+ use atlas || myconf="${myconf} --without-blas" #default enabled
+
+ use X || myconf="${myconf} --without-x" #default enabled
+
+ if use tcltk; then
+ #configure needs to find the files tclConfig.sh and tkConfig.sh
+ myconf="${myconf} --with-tcltk --with-tcl-config=/usr/lib --with-tk-config=/usr/lib"
+ else
+ myconf="${myconf} --without-tcltk"
+ fi
+
+ use gnome && myconf="${myconf} --with-gnome" #default disabled
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} || die "./configure failed"
+
+ emake || die "Parallel Make Failed"
+
+}
+
+src_install () {
+
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die "Installation Failed"
+
+ #fix the R wrapper script to have the correct R_HOME_DIR
+ #sed regexp borrowed from included debian rules
+ cp ${D}/usr/bin/R ${S}/bin/R.orig
+ sed -e '/^R_HOME_DIR=.*/s::R_HOME_DIR=/usr/lib/R:' \
+ ${S}/bin/R.orig > ${D}/usr/bin/R
+
+ dodoc AUTHORS BUGS COPYING* ChangeLog FAQ INSTALL *NEWS README \
+ RESOURCES THANKS VERSION Y2K
+
+ #Add rudimentary menu entry if gnome
+ if use gnome; then
+ insinto /usr/share/gnome/apps/Applications
+ doins ${FILESDIR}/R.desktop
+ insinto /usr/share/pixmaps
+ doins ${FILESDIR}/R-logo.png
+ fi
+
+}
diff --git a/dev-lang/R/files/R-logo.png b/dev-lang/R/files/R-logo.png
new file mode 100644
index 000000000000..d9ce5e227202
--- /dev/null
+++ b/dev-lang/R/files/R-logo.png
Binary files differ
diff --git a/dev-lang/R/files/R.desktop b/dev-lang/R/files/R.desktop
new file mode 100644
index 000000000000..ef53caf006d9
--- /dev/null
+++ b/dev-lang/R/files/R.desktop
@@ -0,0 +1,17 @@
+[Desktop Entry]
+Name=R
+Name[pt_BR]=R
+Name[da]=R
+Nama[ja]=R
+Name[no]=R
+Name[uk]=R
+Comment=Statistical computing and graphics
+Comment[pt_BR]=Statistical computing and graphics
+Comment[da]=Statistical computing and graphics
+Comment[ja]=Statistical computing and graphics
+Comment[no]=Statistical computing and graphics
+Comment[uk]=Statistical computing and graphics
+Exec=R --gui=gnome
+Icon=R-logo.png
+Terminal=1
+Type=Application
diff --git a/dev-lang/R/files/digest-R-1.4.1 b/dev-lang/R/files/digest-R-1.4.1
new file mode 100644
index 000000000000..a75025244dd9
--- /dev/null
+++ b/dev-lang/R/files/digest-R-1.4.1
@@ -0,0 +1 @@
+MD5 bf482598325347c7997477eb778552e8 R-1.4.1.tgz 5136906