summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-04-12 21:22:28 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-04-12 21:22:28 +0000
commit00c42363056d0d81e3f7408114516ad818bcd2fd (patch)
tree365de01393a53c83d68d4b71827b9b9f58665b01 /dev-lang/R
parentlibpng forcing upgrade (diff)
downloadgentoo-2-00c42363056d0d81e3f7408114516ad818bcd2fd.tar.gz
gentoo-2-00c42363056d0d81e3f7408114516ad818bcd2fd.tar.bz2
gentoo-2-00c42363056d0d81e3f7408114516ad818bcd2fd.zip
upgrade with new libpng
Diffstat (limited to 'dev-lang/R')
-rw-r--r--dev-lang/R/ChangeLog7
-rw-r--r--dev-lang/R/R-1.4.1-r1.ebuild84
-rw-r--r--dev-lang/R/files/digest-R-1.4.1-r11
3 files changed, 91 insertions, 1 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index 920d488a8e2b..1121b9b52067 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.1 2002/02/20 06:12:22 tod Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.2 2002/04/12 21:22:28 spider Exp $
+
+*R-1.4.1-r1 (11 Apr 2002)
+ 11 Apr 2002; Spider <spider@gentoo.org>
+ Forcing an upgrade due to libpng upgrade.
+
*R-1.4.1 (19 Feb 2002)
diff --git a/dev-lang/R/R-1.4.1-r1.ebuild b/dev-lang/R/R-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..ed6729070cdf
--- /dev/null
+++ b/dev-lang/R/R-1.4.1-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Tod Neidt <tod@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.4.1-r1.ebuild,v 1.1 2002/04/12 21:22:28 spider Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
+
+SRC_URI="http://cran.r-project.org/src/base/${P}.tgz"
+
+ #There are daily release patches, don't know how to utilize these
+ #"ftp://ftp.stat.math.ethz.ch/Software/${PN}/${PN}-release.diff.gz"
+
+HOMEPAGE="http://www.r-project.org/"
+
+DEPEND="virtual/glibc
+ >=sys-devel/perl-5.6.1-r3
+ >=sys-libs/readline-4.1-r3
+ >=sys-libs/zlib-1.1.3-r2
+ >=media-libs/jpeg-6b-r2
+ >=media-libs/libpng-1.2.1
+ atlas? ( dev-libs/atlas )
+ X? ( virtual/x11 )
+ tcltk? ( dev-lang/tk )
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.4 )"
+
+src_compile() {
+
+ local myconf="--enable-R-profiling --enable-R-shlib --with-readline"
+
+ #Eventually, we will want to take into account that a user may have
+ #an alternate or additional blas libraries,
+ #i.e. USE variable blas and and virtual/blas
+ use atlas || myconf="${myconf} --without-blas" #default enabled
+
+ use X || myconf="${myconf} --without-x" #default enabled
+
+ if use tcltk; then
+ #configure needs to find the files tclConfig.sh and tkConfig.sh
+ myconf="${myconf} --with-tcltk --with-tcl-config=/usr/lib --with-tk-config=/usr/lib"
+ else
+ myconf="${myconf} --without-tcltk"
+ fi
+
+ use gnome && myconf="${myconf} --with-gnome" #default disabled
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} || die "./configure failed"
+
+ emake || die "Parallel Make Failed"
+
+}
+
+src_install () {
+
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die "Installation Failed"
+
+ #fix the R wrapper script to have the correct R_HOME_DIR
+ #sed regexp borrowed from included debian rules
+ cp ${D}/usr/bin/R ${S}/bin/R.orig
+ sed -e '/^R_HOME_DIR=.*/s::R_HOME_DIR=/usr/lib/R:' \
+ ${S}/bin/R.orig > ${D}/usr/bin/R
+
+ dodoc AUTHORS BUGS COPYING* ChangeLog FAQ INSTALL *NEWS README \
+ RESOURCES THANKS VERSION Y2K
+
+ #Add rudimentary menu entry if gnome
+ if use gnome; then
+ insinto /usr/share/gnome/apps/Applications
+ doins ${FILESDIR}/R.desktop
+ insinto /usr/share/pixmaps
+ doins ${FILESDIR}/R-logo.png
+ fi
+
+}
diff --git a/dev-lang/R/files/digest-R-1.4.1-r1 b/dev-lang/R/files/digest-R-1.4.1-r1
new file mode 100644
index 000000000000..a75025244dd9
--- /dev/null
+++ b/dev-lang/R/files/digest-R-1.4.1-r1
@@ -0,0 +1 @@
+MD5 bf482598325347c7997477eb778552e8 R-1.4.1.tgz 5136906