summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerkan Kaba <serkan@gentoo.org>2009-03-01 08:12:12 +0000
committerSerkan Kaba <serkan@gentoo.org>2009-03-01 08:12:12 +0000
commitffe262e727f288e082c47eb6e1ac7d394a5f68a1 (patch)
tree791ebc033cd975c1f4d5d2debcb11e9c625bcf1c /dev-java
parentVersion bump. (diff)
downloadgentoo-2-ffe262e727f288e082c47eb6e1ac7d394a5f68a1.tar.gz
gentoo-2-ffe262e727f288e082c47eb6e1ac7d394a5f68a1.tar.bz2
gentoo-2-ffe262e727f288e082c47eb6e1ac7d394a5f68a1.zip
Version bump. Fixes bug #260690.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/java-sdk-docs/ChangeLog10
-rw-r--r--dev-java/java-sdk-docs/java-sdk-docs-1.6.0.10.ebuild41
2 files changed, 49 insertions, 2 deletions
diff --git a/dev-java/java-sdk-docs/ChangeLog b/dev-java/java-sdk-docs/ChangeLog
index 31ca9201956f..086197486865 100644
--- a/dev-java/java-sdk-docs/ChangeLog
+++ b/dev-java/java-sdk-docs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/java-sdk-docs
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/ChangeLog,v 1.60 2008/05/20 14:36:58 caster Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/ChangeLog,v 1.61 2009/03/01 08:12:12 serkan Exp $
+
+*java-sdk-docs-1.6.0.10 (01 Mar 2009)
+
+ 01 Mar 2009; Serkan Kaba <serkan@gentoo.org>
+ +java-sdk-docs-1.6.0.10.ebuild:
+ Version bump. Fixes bug #260690.
20 May 2008; Vlastimil Babka <caster@gentoo.org>
java-sdk-docs-1.5.0-r1.ebuild, java-sdk-docs-1.6.0-r1.ebuild:
diff --git a/dev-java/java-sdk-docs/java-sdk-docs-1.6.0.10.ebuild b/dev-java/java-sdk-docs/java-sdk-docs-1.6.0.10.ebuild
new file mode 100644
index 000000000000..377e32e07078
--- /dev/null
+++ b/dev-java/java-sdk-docs/java-sdk-docs-1.6.0.10.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/java-sdk-docs-1.6.0.10.ebuild,v 1.1 2009/03/01 08:12:12 serkan Exp $
+
+ORIG_NAME="jdk-6u10-docs.zip"
+SRC_URI="jdk-6u10-docs.zip"
+DESCRIPTION="Documentation (including API Javadocs) for Java SDK version ${PV}"
+HOMEPAGE="http://java.sun.com/javase/6/docs/"
+LICENSE="sun-j2sl-6"
+SLOT="1.6.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+DEPEND="app-arch/unzip"
+RDEPEND=""
+RESTRICT="fetch"
+
+DOWNLOAD_URL="https://cds.sun.com/is-bin/INTERSHOP.enfinity/WFS/CDS-CDS_Developer-Site/en_US/-/USD/ViewProductDetail-Start?ProductRef=jdk-6u10-docs-oth-JPR@CDS-CDS_Developer"
+S="${WORKDIR}/docs"
+
+pkg_nofetch() {
+ einfo "Please download ${ORIG_NAME} from "
+ einfo "${DOWNLOAD_URL}"
+ einfo "(select English and agree to the licence) and place it in ${DISTDIR} named as"
+ einfo "${SRC_URI}. Notice the ${PR}. Because Sun changes the doc zip file"
+ einfo "without changing the filename, we have to resort to renaming to keep"
+ einfo "the md5sum verification working for existing and new downloads."
+ einfo ""
+ einfo "If emerge fails because of a md5sum error it is possible that Sun"
+ einfo "has again changed the upstream release, try downloading the file"
+ einfo "again or a newer revision if available. Otherwise report this to"
+ einfo "http://bugs.gentoo.org/67266 and we will make a new revision."
+}
+
+src_install(){
+ insinto /usr/share/doc/${P}/html
+ doins index.html
+
+ for i in *; do
+ [[ -d $i ]] && doins -r $i
+ done
+}