summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2008-03-03 08:18:53 +0000
committerVlastimil Babka <caster@gentoo.org>2008-03-03 08:18:53 +0000
commitfd9daf60e07d95c7841761679b86fa52dd8efbdd (patch)
tree48a2a2670775ecfe40107f3695b7381d8e3ea536 /dev-java
parentRemove ant 1.6.5. Java packages already depend on 1.7.0. (diff)
downloadgentoo-2-fd9daf60e07d95c7841761679b86fa52dd8efbdd.tar.gz
gentoo-2-fd9daf60e07d95c7841761679b86fa52dd8efbdd.tar.bz2
gentoo-2-fd9daf60e07d95c7841761679b86fa52dd8efbdd.zip
Remove ant 1.6.5. Java packages already depend on 1.7.0.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/ant-core/ChangeLog8
-rw-r--r--dev-java/ant-core/ant-core-1.6.5-r14.ebuild74
-rw-r--r--dev-java/ant-core/files/1.6.5-ant171
-rw-r--r--dev-java/ant-core/files/build.sh-exit-fix.patch11
4 files changed, 6 insertions, 258 deletions
diff --git a/dev-java/ant-core/ChangeLog b/dev-java/ant-core/ChangeLog
index 1277e0915535..433c8b179f8d 100644
--- a/dev-java/ant-core/ChangeLog
+++ b/dev-java/ant-core/ChangeLog
@@ -1,11 +1,15 @@
# ChangeLog for dev-java/ant-core
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/ChangeLog,v 1.76 2007/11/28 02:09:02 betelgeuse Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/ChangeLog,v 1.77 2008/03/03 08:18:52 caster Exp $
# Ant-core blocks lower/older versions of ant-tasks,
# since it will not run when there is a version mismatch betwean the 2 packages
# Please unemerge ant-tasks when updating ant-core.
+ 03 Mar 2008; Vlastimil Babka <caster@gentoo.org> -files/1.6.5-ant,
+ -files/build.sh-exit-fix.patch, -ant-core-1.6.5-r14.ebuild:
+ Remove ant 1.6.5. Java packages already depend on 1.7.0.
+
28 Nov 2007; Petteri Räty <betelgeuse@gentoo.org>
ant-core-1.7.0-r1.ebuild:
Quote variables.
diff --git a/dev-java/ant-core/ant-core-1.6.5-r14.ebuild b/dev-java/ant-core/ant-core-1.6.5-r14.ebuild
deleted file mode 100644
index a990f2cf7071..000000000000
--- a/dev-java/ant-core/ant-core-1.6.5-r14.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/ant-core-1.6.5-r14.ebuild,v 1.11 2007/01/21 22:19:13 caster Exp $
-
-JAVA_ANT_DISABLE_ANT_CORE_DEP=true
-inherit java-pkg-2 eutils toolchain-funcs java-ant-2
-
-MY_PN=${PN/-core}
-
-DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files."
-HOMEPAGE="http://ant.apache.org/"
-SRC_URI="mirror://apache/ant/source/apache-${MY_PN}-${PV}-src.tar.bz2"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ia64 ppc ppc64 x86 ~x86-fbsd"
-IUSE="doc source"
-
-DEPEND="source? ( app-arch/zip )
- >=virtual/jdk-1.4
- !<dev-java/ant-tasks-${PV}
- !dev-java/ant-optional"
-RDEPEND=">=virtual/jdk-1.4
- >=dev-java/java-config-1.2"
-
-S="${WORKDIR}/apache-ant-${PV}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Patch build.sh to die with non-zero exit code in case of errors.
- # This patch may be useful for all ant versions.
- epatch "${FILESDIR}/build.sh-exit-fix.patch"
-}
-
-src_compile() {
- if [[ $(tc-arch) == "ppc" ]] ; then
- # We're compiling _ON_ PPC
- export THREADS_FLAG="green"
- fi
-
- ./build.sh -Ddist.dir="${D}/usr/share/${PN}" || die "failed to build"
-
- if use doc; then
- ./build.sh dist_javadocs || die "failed to build docs"
- fi
-}
-
-src_install() {
- newbin "${FILESDIR}/${PV}-ant" ant || die "failed to install wrapper"
-
- dodir "/usr/share/${PN}/bin"
- for each in antRun runant.pl runant.py complete-ant-cmd.pl ; do
- dobin "${S}/src/script/${each}"
- dosym "/usr/bin/${each}" "/usr/share/${PN}/bin/${each}"
- done
-
- dodir /etc/env.d
- echo "ANT_HOME=\"/usr/share/${PN}\"" > "${D}/etc/env.d/20ant"
-
- java-pkg_dojar build/lib/ant.jar
- java-pkg_dojar build/lib/ant-launcher.jar
-
- use source && java-pkg_dosrc src/main/*
-
- dodoc README WHATSNEW KEYS
-
- if use doc; then
- dohtml welcome.html
- java-pkg_dohtml -r docs/*
- java-pkg_dohtml -r dist/docs/*
- fi
-}
diff --git a/dev-java/ant-core/files/1.6.5-ant b/dev-java/ant-core/files/1.6.5-ant
deleted file mode 100644
index ca75068f1949..000000000000
--- a/dev-java/ant-core/files/1.6.5-ant
+++ /dev/null
@@ -1,171 +0,0 @@
-#! /bin/bash
-
-# Copyright 2001-2004 The Apache Software Foundation
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-# Edited for Gentoo Linux
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-core/files/1.6.5-ant,v 1.8 2006/09/13 09:28:31 caster Exp $
-
-# Extract launch and ant arguments, (see details below).
-ant_exec_args=
-no_config=false
-use_jikes_default=false
-ant_exec_debug=false
-show_help=false
-for arg in "$@" ; do
- if [ "$arg" = "--noconfig" ] ; then
- no_config=true
- elif [ "$arg" = "--usejikes" ] ; then
- use_jikes_default=true
- elif [ "$arg" = "--execdebug" ] ; then
- ant_exec_debug=true
- elif [ my"$arg" = my"--h" -o my"$arg" = my"--help" ] ; then
- show_help=true
- ant_exec_args="$ant_exec_args -h"
- else
- if [ my"$arg" = my"-h" -o my"$arg" = my"-help" ] ; then
- show_help=true
- fi
- ant_exec_args="$ant_exec_args \"$arg\""
- fi
-done
-
-# Source/default ant configuration
-if $no_config ; then
- rpm_mode=false
- usejikes=$use_jikes_default
-else
- # load system-wide ant configuration
- if [ -f "/etc/ant.conf" ] ; then
- . /etc/ant.conf
- fi
-
- # load user ant configuration
- if [ -f "$HOME/.ant/ant.conf" ] ; then
- . $HOME/.ant/ant.conf
- fi
- if [ -f "$HOME/.antrc" ] ; then
- . "$HOME/.antrc"
- fi
-
- # provide default configuration values
- if [ -z "$rpm_mode" ] ; then
- rpm_mode=false
- fi
- if [ -z "$usejikes" ] ; then
- usejikes=$use_jikes_default
- fi
-fi
-
-# Always get JAVA_HOME from java-config.
-# Use GENTOO_VM to change which VM is used instead.
-export JAVA_HOME="$(java-config -g JAVA_HOME)"
-
-if [ -z $JAVA_HOME ] ; then
- echo 'Error: No JDK found!'
- echo "Try using java-config script to set your JDK"
- echo "Remember that you need a JDK not a JRE"
- exit 1
-fi
-
-ANT_HOME=/usr/share/ant-core
-
-# set ANT_LIB location
-ANT_LIB="${ANT_HOME}/lib"
-
-if [ -z "$JAVACMD" ] ; then
- if [ -n "$JAVA_HOME" ] ; then
- JAVACMD="$JAVA_HOME/bin/java"
- else
- JAVACMD=`which java 2> /dev/null `
- if [ -z "$JAVACMD" ] ; then
- JAVACMD=java
- fi
- fi
-fi
-
-if [ ! -x "$JAVACMD" ] ; then
- echo "Error: JAVA_HOME is not defined correctly."
- echo " We cannot execute $JAVACMD"
- exit 1
-fi
-
-if [ -z "$LOCALCLASSPATH" ] ; then
- LOCALCLASSPATH=$ANT_LIB/ant-launcher.jar
-else
- LOCALCLASSPATH=$ANT_LIB/ant-launcher.jar:$LOCALCLASSPATH
-fi
-
-# add in the dependency .jar files
-LOCALCLASSPATH="${LOCALCLASSPATH}:`java-config --classpath=log4j,xml-commons-external-1.3,xerces-2,xalan,junit,antlr,bcel,bsh,commons-beanutils-1.6,commons-collections,commons-logging,commons-net,jakarta-oro-2.0,jdepend,jsch,jakarta-regexp-1.3,rhino-1.5,jython,jta,sun-jaf-bin,sun-javamail-bin 2> /dev/null`"
-
-if [ -n "$JAVA_HOME" ] ; then
- if [ -f "$JAVA_HOME/lib/tools.jar" ] ; then
- LOCALCLASSPATH="$LOCALCLASSPATH:$JAVA_HOME/lib/tools.jar"
- fi
-
- if [ -f "$JAVA_HOME/lib/classes.zip" ] ; then
- LOCALCLASSPATH="$LOCALCLASSPATH:$JAVA_HOME/lib/classes.zip"
- fi
-
-else
- echo "Warning: JAVA_HOME environment variable is not set (or not exported)."
- echo " If build fails because sun.* classes could not be found"
- echo " you will need to set the JAVA_HOME environment variable"
- echo " to the installation directory of java."
- echo " Try using java-config script"
-fi
-
-# Allow Jikes support (off by default)
-if $usejikes; then
- ANT_OPTS="$ANT_OPTS -Dbuild.compiler=jikes"
-fi
-
-# Show script help if requested
-if $show_help ; then
- echo $0 '[script options] [options] [target [target2 [target3] ..]]'
- echo 'Script Options:'
- echo ' --help, --h print this message and ant help'
- echo ' --noconfig suppress sourcing of /etc/ant.conf,'
- echo ' $HOME/.ant/ant.conf, and $HOME/.antrc'
- echo ' configuration files'
- echo ' --usejikes enable use of jikes by default, unless'
- echo ' set explicitly in configuration files'
- echo ' --execdebug print ant exec line generated by this'
- echo ' launch script'
- echo ' '
-fi
-
-# Execute ant using eval/exec to preserve spaces in paths,
-# java options, and ant args
-ant_sys_opts=
-
-if [ -n "$JIKESPATH" ]; then
- ant_sys_opts="-Djikes.class.path=\"$JIKESPATH\""
-fi
-
-# 2002-11-02, karltk@gentoo.org:
-# The Blackdown JDK on PPC hiccups with native threads
-#
-if [ "$(uname -m)" == "ppc" ] ; then
- export THREADS_FLAG="green"
-fi
-
-
-ant_exec_command="exec \"$JAVACMD\" $ANT_OPTS -classpath \"$LOCALCLASSPATH\" -Dant.home=\"$ANT_HOME\" -Dant.library.dir=\"$ANT_LIB\" $ant_sys_opts org.apache.tools.ant.launch.Launcher $ANT_ARGS -cp \"$CLASSPATH\" $ant_exec_args"
-
-if $ant_exec_debug ; then
- echo $ant_exec_command
-fi
-eval $ant_exec_command
diff --git a/dev-java/ant-core/files/build.sh-exit-fix.patch b/dev-java/ant-core/files/build.sh-exit-fix.patch
deleted file mode 100644
index 53170617f98a..000000000000
--- a/dev-java/ant-core/files/build.sh-exit-fix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- build.sh.orig 2003-04-16 11:28:29.000000000 +0200
-+++ build.sh 2003-07-02 16:10:06.000000000 +0200
-@@ -18,7 +18,7 @@
-
- if test ! -f bootstrap/lib/ant.jar -o ! -x bootstrap/bin/ant -o ! -x bootstrap/bin/antRun ; then
- echo Bootstrap FAILED
-- exit
-+ exit 1
- fi
-
- LOCALCLASSPATH=lib/xercesImpl.jar:lib/xml-apis.jar:bootstrap/lib/ant.jar